Erreur gradlew setupDecompWorkspace



  • Bonjour !

    C'est mon premier post sur ce forum donc je suis désolé par avance si je fais quelque chose de travers, ou si le message contient beaucoup de répétitions :x

    Donc voici mon problème :

    Je débute dans le modding et j'ai besoin de créer un mod pour mon modpack qui est en 1.7.10.
    Donc je suis le tutoriel correspondant et tout se passe bien jusqu'à l'étape "Installation de Forge" dans le tutoriel "Installer l'espace de travail pour Eclipse" ( ici au cas où).

    Voilà ce qu'il se passe :
    Image erreur

    Pour info :

    • Je suis sous macOS
    • J'ai installé jdk1.8.0_172 ; jdk1.8.0_171 ; jdk-10.0.1.jdk
    • Java JRE et Forge sont bien installés puisque je peux lancer Minecraft en 1.7.10 avec des mods.
    • J'ai téléchargé la version source 1.7.10 10.13.4.1614 de Forge.

    J'ai vérifié si je pouvais obtenir la version de java qui était installé et tout fonctionne bien :

    iMac:forge-1.7.10-10.13.4.1614-1.7.10-src cbinou$ java --version
    java 10.0.1 2018-04-17
    Java(TM) SE Runtime Environment 18.3 (build 10.0.1+10)
    Java HotSpot(TM) 64-Bit Server VM 18.3 (build 10.0.1+10, mixed mode)
    

    Je ne pense pas non plus que le problème puisse venir du chemin vers Forge
    (~/Users/cbinou/Documents/mods/forge-1.7.10-10.13.4.1614-1.7.10-src/).

    Je me suis déjà renseigné, sans avoir trouvé de solutions.
    On m'a dit que ça pouvait venir de la version de Gradle donc voici la version que j'ai : Gradle 4.8.
    Dans une réponse, on m'a dit de rester à Gradle 3.3. Malheureusement, lorsque je l'installais, le terminal utilisait Gradle 4.8 et lorsque je désinstallais Gradle 4.8, il ne reconnaissait pas la commande gradle.

    J'ai aussi déjà cherché sur ce forum sans trouver de réponse.
    Merci donc pour votre aide !
    Si je n'ai pas été assez précis sur certains points, merci de me l'indiquer 🙂

    Pour finir, je ne pense pas que le problème puisse venir du système d'exploitation, mais j'ai à disposition une machine sous Windows si vous pensez que le problème peut venir de là, bien qu'elle soit moins stable que celle sous macOS.

    Bonne journée !


  • Administrateurs

    Bonjour,
    Comme indiqué sur l'image que tu as envoyé, ForgeGradle ne supporte pas les versions de Java supérieurs à la version 8.
    Il te faut donc lancer gradle avec Java 8.



  • Bonjour !
    Merci pour ta réponse 🙂
    Ma question peut paraître idiote mais comment je m'y prends pour lancer gradle avec Java 8 ?
    J'avais déjà le même message d'erreur avant d'avoir installé Java 10.0.1 😕
    Merci.

    EDIT:
    Merci un peu de recherche et j'ai trouvé.
    Donc j'ai lancé gradle avec Java 8 et j'obtiens une nouvelle erreur que voici :

    Starting a Gradle Daemon, 1 incompatible Daemon could not be reused, use --status for details
    
    FAILURE: Build failed with an exception.
    
    * Where:
    Build file '/Users/cbinou/Documents/mods/forge-1.7.10-10.13.4.1614-1.7.10-src/build.gradle' line: 18
    
    * What went wrong:
    A problem occurred evaluating root project 'forge-1.7.10-10.13.4.1614-1.7.10-src'.
    > Failed to apply plugin [id 'forge']
       > You must set the Minecraft Version!
          > java.lang.NullPointerException (no error message)
    
    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
    
    * Get more help at https://help.gradle.org
    
    BUILD FAILED in 4s
    

    Et je suis bloqué ici...
    Merci pour votre aide 🙂


  • Administrateurs

    Puis-je voir ton build.gradle ?



  • Oui bien sûr le voici :

    buildscript {
        repositories {
            mavenCentral()
            maven {
                name = "forge"
                url = "http://files.minecraftforge.net/maven"
            }
            maven {
                name = "sonatype"
                url = "https://oss.sonatype.org/content/repositories/snapshots/"
            }
        }
        dependencies {
            classpath 'net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT'
        }
    }
    
    apply plugin: 'forge'
    
    version = "1.0"
    group= "com.yourname.modid" // http://maven.apache.org/guides/mini/guide-naming-conventions.html
    archivesBaseName = "modid"
    
    minecraft {
        version = "1.7.10-10.13.4.1614-1.7.10"
        runDir = "eclipse"
    }
    
    dependencies {
        // you may put jars on which you depend on in ./libs
        // or you may define them like so..
        //compile "some.group:artifact:version:classifier"
        //compile "some.group:artifact:version"
          
        // real examples
        //compile 'com.mod-buildcraft:buildcraft:6.0.8:dev'  // adds buildcraft to the dev env
        //compile 'com.googlecode.efficient-java-matrix-library:ejml:0.24' // adds ejml to the dev env
    
        // for more info...
        // http://www.gradle.org/docs/current/userguide/artifact_dependencies_tutorial.html
        // http://www.gradle.org/docs/current/userguide/dependency_management.html
    
    }
    
    processResources
    {
        // this will ensure that this task is redone when the versions change.
        inputs.property "version", project.version
        inputs.property "mcversion", project.minecraft.version
    
        // replace stuff in mcmod.info, nothing else
        from(sourceSets.main.resources.srcDirs) {
            include 'mcmod.info'
                    
            // replace version and mcversion
            expand 'version':project.version, 'mcversion':project.minecraft.version
        }
            
        // copy everything else, thats not the mcmod.info
        from(sourceSets.main.resources.srcDirs) {
            exclude 'mcmod.info'
        }
    }
    
    

  • Administrateurs

    Tu as touché aux paramètres de gradle ? (la version indiqué dans gradle/wrapper/gradle-wrapper.properties par exemple). Si oui, remets comme cela était avant.



  • Non, je n'ai pas touché aux paramètres de Gradle.
    Voici mon gradle-wrapper.properties :

    #Wed Jul 02 15:54:47 CDT 2014
    distributionBase=GRADLE_USER_HOME
    distributionPath=wrapper/dists
    zipStoreBase=GRADLE_USER_HOME
    zipStorePath=wrapper/dists
    distributionUrl=https\://services.gradle.org/distributions/gradle-2.0-bin.zip
    
    

    EDIT:
    Je ne sais pas par quelle magie mais tout a fonctionné lorsque j'ai essayé de réentrer la commande ./gradlew setupDecompWorkspace. Je suis allé jusqu'à la fin du tutoriel sans problème.
    Merci beaucoup pour votre aide ! 😄
    Je mets le sujet en résolu.

    Si quelqu'un a eu le même problème mais n'arrive pas à lancer Minecraft avec Eclipse, allez dans "Run Configurations" (dans le menu contextuel du bouton vert pour lancer Minecraft) puis dans JRE et cochez "Alternate JRE" et choisissez la version 8 de Java.