Problème lancement Forge (1.12.2)



  • Bonjour,
    Lorsque que je lance le jeu j'ai un problème avec forge voici :

    Les <destination> sont a remplacer par le chemin d'accès au répertoire du jeu.

    [21:14:01] [Thread-4/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker
    [21:14:02] [Thread-4/INFO] [LaunchWrapper]: Using primary tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker
    [21:14:02] [Thread-4/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLTweaker
    [21:14:02] [Thread-4/INFO] [FML]: Forge Mod Loader version 14.23.5.2844 for Minecraft 1.12.2 loading
    [21:14:02] [Thread-4/INFO] [FML]: Java is Java HotSpot(TM) 64-Bit Server VM, version 1.8.0_202, running on Windows 10:amd64:10.0, installed at C:\Program Files\Java\jre1.8.0_202
    [21:14:02] [Thread-4/ERROR] [FML]: Apache Maven library folder was not in the format expected. Using default libraries directory.
    [21:14:02] [Thread-4/ERROR] [FML]: Full: <destination>/maven-artifact-3.5.3.jar
    [21:14:02] [Thread-4/ERROR] [FML]: Trimmed: <destination>
    [21:14:02] [Thread-4/ERROR] [LaunchWrapper]: Unable to launch
    java.lang.RuntimeException: An error occurred trying to configure the Minecraft home at <destination> for Forge Mod Loader
    	at net.minecraftforge.fml.relauncher.FMLLaunchHandler.setupHome(FMLLaunchHandler.java:111) ~[forge-1.12.2-14.23.5.2844.jar:?]
    	at net.minecraftforge.fml.relauncher.FMLLaunchHandler.setupClient(FMLLaunchHandler.java:81) ~[forge-1.12.2-14.23.5.2844.jar:?]
    	at net.minecraftforge.fml.relauncher.FMLLaunchHandler.configureForClientLaunch(FMLLaunchHandler.java:42) ~[forge-1.12.2-14.23.5.2844.jar:?]
    	at net.minecraftforge.fml.common.launcher.FMLTweaker.injectIntoClassLoader(FMLTweaker.java:141) ~[forge-1.12.2-14.23.5.2844.jar:?]
    	at net.minecraft.launchwrapper.Launch.launch(Launch.java:115) [launchwrapper-1.12.jar:?]
    	at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.12.jar:?]
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_202]
    	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_202]
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_202]
    	at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_202]
    	at fr.theshark34.openlauncherlib.internal.InternalLauncher.launch(InternalLauncher.java:173) [openlauncherlib-3.0.5.jar:?]
    	at com.valbion.launcher.mcmod.Launcher.launch(Launcher.java:80) [bin/:?]
    	at com.valbion.launcher.mcmod.LauncherPanel$1.run(LauncherPanel.java:116) [bin/:?]
    Caused by: java.lang.NoSuchMethodError: com.google.gson.GsonBuilder.setLenient()Lcom/google/gson/GsonBuilder;
    	at net.minecraftforge.fml.relauncher.libraries.ModList.<clinit>(ModList.java:45) ~[forge-1.12.2-14.23.5.2844.jar:?]
    	at net.minecraftforge.fml.relauncher.libraries.LibraryManager.setup(LibraryManager.java:91) ~[forge-1.12.2-14.23.5.2844.jar:?]
    	at net.minecraftforge.fml.relauncher.FMLLaunchHandler.setupHome(FMLLaunchHandler.java:106) ~[forge-1.12.2-14.23.5.2844.jar:?]
    	... 12 more
    

    Je précise que le problème ne vient pas de mon code car après mainte et mainte vérification le code est correct.

    J'ai tenter de lancer avec deux version différente de forge là 1.12.2-14.23.5.2847 et 1.12.2-14.23.5.2844 (version utilisée pour le log).
    Les deux log sont exactement les mêmes avec l'une ou l'autre des versions ( a part bien sur les identifiants des versions qui diffèrent ).

    Je me suis renseigner sur ce type d'erreur et le plus souvent je vois des gens qui ne mette pas les bonnes versions des mods or ici j'ai essayer sans mods pour être sur de ne pas avoir de problèmes avec les versions.

    Cela (pour moi) est surement un problème de libs ou de LWJGL, les assets c'est très peut probable et les mods encore moins puisque que je n'en n'est pas mis.

    A savoir que j'ai déjà développé des mods, launchers, plugins et d'autres en java et sur Minecraft en particulier et je n'ai jamais eu cette erreur.


  • Moddeurs confirmés Rédacteurs Administrateurs

    Bonsoir,

    Je suppose que c'est pour un launcher custom ?
    Si oui la bonne section c'est support pour les moddeurs.

    Et le problème vient d'une bibliothèque qui n'est pas dans la bonne version (google gson)



  • Oui c'est pour un launcher custom, excusez moi je ne savais pas qu'il fallait aller dans cette section.

    Je vais tenter de mettre un version plus récente de GSON.


Log in to reply