Fin du support de la 1.7.10


  • Administrateurs

    Bonjour,

    Cela fait un moment que l'on en discute avec l'équipe, nous avons finalement choisit une date. À partir du 4 septembre, l'équipe de MFF ne fera plus de support pour la version 1.7.10.
    Sur le forum officiel de Forge, cela fait un moment que les choses sont déjà ainsi, LexManos ayant fait le choix de fermer toutes discussions mentionnant une version obsolète.

    Dans notre cas, nous avons choisis une approche moins agressive. Des discussions mentionnant la 1.7.10 pourront continuer à être créé, elles ne seront pas supprimées. En revanche, le support ne sera qu'assuré par les autres membres de la communauté. L'équipe ne répondra plus aux problèmes portant sur cette version.
    Ce choix a été fait afin de pousser les personnes à aller de l'avant. En effet, persister à rester en 1.7.10 est un choix privant des nombreuses nouvelles fonctionnalités des versions récentes de Minecraft ou encore de Forge. En effet, Forge a bien évolué depuis et beaucoup de choses sont bien mieux gérer dans les versions récentes (registre pour gérer les effets de potions, retrait de la limitation des 256 entités globales, puisque les mods utilisent désormais uniquement EntityRegistry.registerModEntity, registres réécrits plus efficace, api pour charger les obj plus évolué, etc.), contient de nouveaux événements et corrige des failles existantes dans les anciennes versions.

    Cela permettra également à l'équipe de se concentrer sur la rédaction de tutoriel plus récents mais également de passer plus de temps sur les demandes d'aides concernant les versions récentes.
    En effet, les demandes d'aides résolus constituent une importante ressource pour le développement et en raison de leur faible age les versions comme la 1.11.2 ou la 1.12.x ont encore peu de demande d'aide résolu. La section résolue de la version 1.7.10 contient à ce jour 1326 demandes résolues, ce qui devrait permettre aux personnes voulant persister dans cette version d'avoir largement assez de ressource.

    Cette fin du support de la 1.7.10 concerne autant la section support pour les moddeurs que la section support pour les utilisateurs.
    La catégorie Cauldron sera quand a elle entièrement archivé, ce type de serveur n'ayant pas survécu à l'affaire de Bukkit. À l'heure actuelle, cela fait plus d'un an que le dernier fork de Cauldron encore maintenu a été laissé à son sort. Cette catégorie sera surement remplacée par une catégorie Sponge, un API alternative à Bukkit qui dispose d'une implémentation pour Forge.

    L'équipe de Minecraft Forge France.



  • Très bon choix !



  • Bien que j'ai longtemps été sous la version 1.7.10 avec mon serveur, je ne suis pas contre cette amélioration ! Nous aussi avons décidé de passer à une version plus récente, la 1.11.2 !



  • Je vais passer a autre chose, je vais me mettre à développer dans des versions plus récentes et ainsi aider la communauté a oblier un peu la 1.7.10.
    Je compte faire un tutoriel avec l'API Baubles !

    EDIT: Y aura t-il encore du support pour mettre a jour son mod de la 1.7.10 vers la 1.8 ou 1.9 ou 1.10 ou 1.11 ou 1.12 ?


  • Administrateurs

    @Infinite : inutile de faire du support pour le passage en version supérieure.
    Il suffit de faire une liste de ce qui a changé entre chaque version.
    On l'a fait pour le passage 1.64 -> 1.7.10 : https://www.minecraftforgefrance.fr/showthread.php?tid=788


  • Administrateurs

    Une mise à jour d'un mod d'une version x vers version y est une demande d'aide concernant la version y, et non la version x.

    Donc oui on aidera pour ce genre de demande d'aide.



  • Ok merci beaucoup 🙂



  • Ceci est bien dommage…

    Il y avait tellement de mods et de joueurs depuis la 1.7.10 voir 1.8 !

    Mais le passage a la 1.9 m'a totalement fait détester Minecraft !

    - Le système de combat totalement null et plat ! Ya pas d'action ! C'est mou !!

    • Pourquoi des ailes ? Enfin je sais pas, je pvp sur un pvp/fac sur une coline et le mec saute puis commence a voler !! N'importe quoi !!
    • Le launcher fais penser a la version xbox (perso pourquoi en vert ? Car c'est la couleur principal du logo non ??)

    Enfin bref,...

    Je trouve sa dommage car maintenant, je trouve qu'il y a beaucoup moins de joueurs et de serveurs sur les versions pc mais plus d'enfant ! (Ce qui pourrie la jeu avec la rage, comportement insupportable et provocateur !)


  • Administrateurs

    @Math WinS:

    Ceci est bien dommage…

    Il y avait tellement de mods et de joueurs depuis la 1.7.10 voir 1.8 !

    Les joueurs en 1.7.10 et 1.8, c'est seulement en France. Dans les autres pays, ils sont déjà en 1.12.x.
    Pour les mods, c'est pareil.

    @Math WinS:

    - Le système de combat totalement null et plat ! Ya pas d'action ! C'est mou !!

    Le système de combat pré 1.9 consistant à appuyer sur un bouton pendant 3 secondes pour gagner. On a vu plus fun comme gameplay.
    Celui post-1.9 est très bien conçu et fait enfin place à de la stratégie.

    @Math WinS:

    • Pourquoi des ailes ? Enfin je sais pas, je pvp sur un pvp/fac sur une coline et le mec saute puis commence a voler !! N'importe quoi !!

    Étant donner que les élytres ont été ajouté pour la version survie du jeu et non pas pour la version PvP. Je ne comprends pas pourquoi tu te plains.

    @Math WinS:

    • Le launcher fais penser a la version xbox (perso pourquoi en vert ? Car c'est la couleur principal du logo non ??)

    Le launcher ne fait absolument pas penser à la version xbox, mais bien au site Minecraft.

    @Math WinS:

    Je trouve sa dommage car maintenant, je trouve qu'il y a beaucoup moins de joueurs et de serveurs sur les versions pc mais plus d'enfant ! (Ce qui pourrie la jeu avec la rage, comportement insupportable et provocateur !)

    Tu te plains de la communauté, mais tu es toi-même un rageux, sinon tu ne viendrais pas te plaindre.

    Je vais finir en disant qu'on est sur un forum de modding et que la question de la communauté qui serait plutôt sur telle ou telle version ne nous concerne absolument pas.


  • Administrateurs

    "C'était mieux avant"


  • Administrateurs

    La catégorie Sponge (remplaçante de la catégorie Cauldron) est désormais ouverte.
    Elle est composée de 3 sections :

    • Tutoriels : un tutoriel rédigé par l'équipe y explique comment installer un serveur Sponge Forge. Nous proposerons par la suite d'autres tutoriels (sur les plugins, voire sur le développement de plugins) s'il y a une demande. Vous pouvez aussi contribuer à cette section en y postant vos tutoriels.
    • Plugins : cette section vous permet de présenter vos plugins. Vous pouvez aussi présenter un plugin qui n'est pas le votre, à condition de faire une discussion bien étoffée et d'y mettre le lien original du plugin ainsi que le nom de l'auteur.
    • Support : cette section doit être utilisé pour toutes demandes d'aides en rapport avec Sponge. Cela peut aussi bien concerner l'installation et la configuration de Sponge, des mods, des plugins que l'aide au développement de plugins.

    Le tutoriel en vidéo associé au première tutoriel texte à aussi servi d'expérimentation pour un nouveau format, dans lequel il y a moins de blanc et les temps indiqués pour chaque partie (vous permettant de regarder que ce qui vous intéresse). Le but étant que vous passez moins de temps à attendre sur la vidéo, en effet vous avons constaté que nos vidéos sont très rarement regardées en entier.

    Nous espérons que ces initiatives vous aideront à aller vers des versions plus récentes.