Problème Texture (texture qui s'affiche pas )



  • Bonjour j'ai un problème avec un nouveau mod que j'ai crée il à environ 3 mois et laissé tombé mais j'ai décidé de le continué mais j'ai un problème de texture mes textures ne s'affiche pas 
    Donc voici ma classe principale 
    http://pastebin.com/CJu1TWHt
    et ensuite la classe de l'item
    http://pastebin.com/XzMUqVHD
    et pour finir un screen 
    http://www.hostingpics.net/viewer.php?id=658531Capture.png

    Merci de vos réponse  😉

    Ps je pense que c'est une chose toute bête mais après des heures de recherche je n'ai pas trouvé



  • ta texture dans le dossier de ton mod s'appelle bien Bronze ?



  • Montre les logs

    Envoyé de mon RAINBOW LITE 4G en utilisant Tapatalk



  • dans les logs sa dit que sa trouve pas le fichier alors que je l'ai mis j'ai du me trompé sur 
    sa main\resources\assets\AventS\textures\items



  • Bonsoir, je te conseille de faire attention à respecter les conventions de nommage.
    Ici ton problème vient du fait que ton répertoire de textures devrait être **assets.avents.textures.items **et non **assets.AventS.textures.items **comme tu as fait.

    Il ne faut pas utiliser de majuscules dans le nom de domaine, au vu de cette erreur, celui-ci est mis en lowerCase ce qui fait que ton mod n'arrive pas à retrouver le dossier lowerCase(AventS) soit **avents **! (J'espère que mon explication est claire :s  )

    En bref, renomme ton dossier assets.avents.textures.items. Je te conseille également de faire attention à bien respecter les conventions de nommage pour tes variables: pas de majuscules sur la première lettre!

    Bonne soirée et bon développement 😄



  • Merci beaucoup j'éssaye  😉


  • Administrateurs

    Salut,
    J'ajoute que le modid et les noms de package devraient aussi être en minuscule.



  • @'robin4002':

    Salut,
    J'ajoute que le modid et les noms de package devraient aussi être en minuscule.

    tout est réglé j'ai tout modifié merci à vous tous  😉



  • @'robin4002':

    Salut,
    J'ajoute que le modid et les noms de package devraient aussi être en minuscule.

    tout est réglé j'ai tout modifié merci à vous tous  😉 
    Ps: j'ai aussi modifié les package sinon je pense qui peux avoir des pb des gradlew build



  • Non le nom des packages gène pas mais c'est toujours mieux

    Envoyé de mon RAINBOW LITE 4G en utilisant Tapatalk


Log in to reply