Problème de démarrage avec LWJGL



  • Salut les amis, alors, récemment je me suis remis au modding. J'ai téléchargé la dernière version en date du MDK de Forge, fais

    gradlew setupDecompWorkspace
    

    et

    gradlew eclipse
    

    puis j'ai démarré eclipse en choisissant comme workspace le dossier eclipse présent dans le dossier Forge. Bon tout ça je savais déjà le faire depuis longtemps, donc pas de problèmes de ce côté là.

    Le problème survient lorsque j'essaie de run le client, la fenêtre de Minecraft n'apparait meme pas, d'après les logs c'est un problème de LWJGL, mais je ne vois pas ce qui pourrait les causer vu que mes drivers sont tous à jour et que si j'utilise le launcher officiel, Minecraft se lance sans problèmes.

    Voila les logs:
    :::

    2016-02-25 10:02:38,363 WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream
    2016-02-25 10:02:38,368 WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream
    [10:02:38] [main/INFO] [GradleStart]: username: skander.jeddi2@gmail.com
    [10:02:38] [main/INFO] [GradleStart]: Extra: []
    [10:02:38] [main/INFO] [GradleStart]: Password found, attempting login
    [10:02:38] [main/INFO]: Logging in with username & password
    [10:02:40] [main/INFO] [GradleStart]: Login Succesful!
    [10:02:40] [main/INFO] [GradleStart]: Running with arguments: [–userProperties, [], –assetsDir, C:/Users/Skander/.gradle/caches/minecraft/assets, --assetIndex, 1.8, --userType, mojang, --accessToken{REDACTED}, --version, 1.8.9, --uuid, 5171151f8c2e444c9c6fdac8f36ee446, --username, Uberfap, --tweakClass, net.minecraftforge.fml.common.launcher.FMLTweaker, --tweakClass, net.minecraftforge.gradle.tweakers.CoremodTweaker]
    [10:02:40] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker
    [10:02:40] [main/INFO] [LaunchWrapper]: Using primary tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker
    [10:02:40] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.CoremodTweaker
    [10:02:40] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLTweaker
    [10:02:40] [main/INFO] [FML]: Forge Mod Loader version 11.15.1.1761 for Minecraft 1.8.9 loading
    [10:02:40] [main/INFO] [FML]: Java is Java HotSpot(TM) 64-Bit Server VM, version 1.8.0_73, running on Windows 10:amd64:10.0, installed at C:\Program Files\Java\jre1.8.0_73
    [10:02:40] [main/INFO] [FML]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation
    [10:02:40] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.CoremodTweaker
    [10:02:40] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.fml.relauncher.FMLCorePlugin
    [10:02:40] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.classloading.FMLForgePlugin
    [10:02:40] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker
    [10:02:40] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLDeobfTweaker
    [10:02:40] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
    [10:02:40] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker
    [10:02:40] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker
    [10:02:40] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper
    [10:02:41] [main/ERROR] [FML]: The binary patch set is missing. Either you are in a development environment, or things are not going to work!
    [10:02:44] [main/ERROR] [FML]: FML appears to be missing any signature data. This is not a good thing
    [10:02:44] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper
    [10:02:44] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLDeobfTweaker
    [10:02:45] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
    [10:02:45] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.TerminalTweaker
    [10:02:45] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.TerminalTweaker
    [10:02:45] [main/INFO] [LaunchWrapper]: Launching wrapped minecraft {net.minecraft.client.main.Main}
    2016-02-25 10:02:47,277 WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream
    2016-02-25 10:02:47,361 WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream
    2016-02-25 10:02:47,366 WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream
    [10:02:48] [Client thread/INFO]: Setting user: Uberfap
    [10:02:54] [Client thread/INFO]: LWJGL Version: 2.9.4
    [10:02:55] [Client thread/ERROR]: Couldn't set pixel format
    org.lwjgl.LWJGLException: Pixel format not accelerated
    at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method) ~[lwjgl-2.9.4-nightly-20150209.jar:?]
    at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52) ~[lwjgl-2.9.4-nightly-20150209.jar:?]
    at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:247) ~[lwjgl-2.9.4-nightly-20150209.jar:?]
    at org.lwjgl.opengl.Display.createWindow(Display.java:306) ~[lwjgl-2.9.4-nightly-20150209.jar:?]
    at org.lwjgl.opengl.Display.create(Display.java:848) ~[lwjgl-2.9.4-nightly-20150209.jar:?]
    at org.lwjgl.opengl.Display.create(Display.java:757) ~[lwjgl-2.9.4-nightly-20150209.jar:?]
    at net.minecraft.client.Minecraft.createDisplay(Minecraft.java:597) [Minecraft.class:?]
    at net.minecraft.client.Minecraft.startGame(Minecraft.java:442) [Minecraft.class:?]
    at net.minecraft.client.Minecraft.run(Minecraft.java:360) [Minecraft.class:?]
    at net.minecraft.client.main.Main.main(Main.java:116) [Main.class:?]
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_73]
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_73]
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_73]
    at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_73]
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135) [launchwrapper-1.12.jar:?]
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.12.jar:?]
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_73]
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_73]
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_73]
    at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_73]
    at net.minecraftforge.gradle.GradleStartCommon.launch(GradleStartCommon.java:97) [start/:?]
    at GradleStart.main(GradleStart.java:26) [start/:?]
    [10:02:56] [Client thread/INFO] [STDOUT]: [net.minecraft.init.Bootstrap:printToSYSOUT:612]: –-- Minecraft Crash Report ----
    // Everything's going to plan. No, really, that was supposed to happen.

    Time: 25/02/16 10:02
    Description: Initializing game

    org.lwjgl.LWJGLException: Pixel format not accelerated
    at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
    at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
    at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:247)
    at org.lwjgl.opengl.Display.createWindow(Display.java:306)
    at org.lwjgl.opengl.Display.create(Display.java:848)
    at org.lwjgl.opengl.Display.create(Display.java:757)
    at org.lwjgl.opengl.Display.create(Display.java:739)
    at net.minecraft.client.Minecraft.createDisplay(Minecraft.java:617)
    at net.minecraft.client.Minecraft.startGame(Minecraft.java:442)
    at net.minecraft.client.Minecraft.run(Minecraft.java:360)
    at net.minecraft.client.main.Main.main(Main.java:116)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at net.minecraftforge.gradle.GradleStartCommon.launch(GradleStartCommon.java:97)
    at GradleStart.main(GradleStart.java:26)

    A detailed walkthrough of the error, its code path and all known details is as follows:

    -- Head --
    Stacktrace:
    at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
    at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
    at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:247)
    at org.lwjgl.opengl.Display.createWindow(Display.java:306)
    at org.lwjgl.opengl.Display.create(Display.java:848)
    at org.lwjgl.opengl.Display.create(Display.java:757)
    at org.lwjgl.opengl.Display.create(Display.java:739)
    at net.minecraft.client.Minecraft.createDisplay(Minecraft.java:617)
    at net.minecraft.client.Minecraft.startGame(Minecraft.java:442)

    -- Initialization --
    Details:
    Stacktrace:
    at net.minecraft.client.Minecraft.run(Minecraft.java:360)
    at net.minecraft.client.main.Main.main(Main.java:116)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at net.minecraftforge.gradle.GradleStartCommon.launch(GradleStartCommon.java:97)
    at GradleStart.main(GradleStart.java:26)

    -- System Details --
    Details:
    Minecraft Version: 1.8.9
    Operating System: Windows 10 (amd64) version 10.0
    Java Version: 1.8.0_73, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 940780736 bytes (897 MB) / 1056309248 bytes (1007 MB) up to 1056309248 bytes (1007 MB)
    JVM Flags: 3 total; -Xincgc -Xmx1024M -Xms1024M
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    FML: 
    Loaded coremods (and transformers): 
    Launched Version: 1.8.9
    LWJGL: 2.9.4
    OpenGL: ERROR RuntimeException: No OpenGL context found in the current thread.
    GL Caps: 
    Using VBOs: No
    Is Modded: Definitely; Client brand changed to 'fml,forge'
    Type: Client (map_client.txt)
    Resource Packs: 
    Current Language: ERROR NullPointerException: null
    Profiler Position: N/A (disabled)
    CPU: <unknown>[10:02:56] [Client thread/INFO] [STDOUT]: [net.minecraft.init.Bootstrap:printToSYSOUT:612]: #@!@# Game crashed! Crash report saved to: #@!@# C:\Users\Skander\Documents\Nforge\run.\crash-reports\crash-2016-02-25_10.02.56-client.txt
    Java HotSpot(TM) 64-Bit Server VM warning: Using incremental CMS is deprecated and will likely be removed in a future release

    :::

    Merci d'avance, je sais pas trop quoi faire, au pire des cas je pourrais export mon mod à chaque modification et le tester en lançant Minecraft avec le launcher officiel, mais bon je pense que ça deviendrait assez long à la longue.</unknown>


  • Modérateurs

    Ça fait longtemps que j'ai pas vu ça…
    On va faire les questions de base:

    • Tes drivers sont bien à jour?
    • Tu as essayé de désactiver la barre de chargement de Forge?


  • 1 - Oui, j'ai vérifié encore une fois avant de répondre, mes drivers sont mis à jour, ni Intel Driver Update Utility ni DriversConfig ne m'indiquent de mises à jour possible.
    2 - La barre de chargement de Forge? J'en ait jamais entendu parler 😞


  • Administrateurs

    Modèle de ta carte graphique ?



  • Intel(R) HD Graphics Family


  • Correcteurs

    Pour la barre de chargement forge, tu dois avoir un fichier splash.properties.


  • Administrateurs

    Minecraft sans forge fonctionne-t-il ?
    Quel est le modèle de ton processeur ?



  • @'DiabolicaTrix':

    Pour la barre de chargement forge, tu dois avoir un fichier splash.properties.

    Non justement, je ne l'ai pas vu que le jeu ne démarre même pas 😞

    @'robin4002':

    Minecraft sans forge fonctionne-t-il ?
    Quel est le modèle de ton processeur ?

    Oui, Minecraft sans Forge fonctionne parfaitement bien.
    Intel(R) Pentium(R) CPU B960 @ 2.20GHz 2.20GHz

    EDIT: Minecraft se lance avec Forge s'il est installé sur le launcher officiel, mais pas à travers Eclipse, WTF


  • Correcteurs

    Est-ce que Minecraft Forge avec le launcher officiel fonctionne?



  • Oui voila, regarde mon edit ^^


  • Administrateurs

    C'est un processeur de la génération sandy bridge.
    Intel n'ont pas publié de pilote compatible openGL pour Windows 10 et cette génération. Donc théoriquement impossible de faire fonctionner minecraft sur cette config avec Windows 10.
    Mais pour une raison que j'ignore complètement, avec une ancienne version de Java 8 le jeu se lance. À mon avis tu as le launcher qui utilise sa propre version de Java (8 update 25) qui elle passe.
    Alors que sur eclipse il utilise la version de java du système, sûrement la dernière en date.



  • Je vais essayer de désinstaller Java et de réinstaller une ancienne version, merci Robin, je vous tiens au courant!
    Edit: ça marche, merci beaucoup Robin! Je passe en résolu.


Log in to reply