Crash lancement serveur



  • Bonsoir,

    J'ai fais une petite mise à jour je l'upload, tranquillement, je lance mon client tranquille j'attends que le serveur se lance mais là crash :

    –-- Minecraft Crash Report ----
    // I just don't know what went wrong 😞

    Time: 24/01/16 18:55
    Description: Exception in server tick loop

    java.lang.NoClassDefFoundError: net/minecraft/client/entity/EntityClientPlayerMP
    at java.lang.Class.getDeclaredConstructors0(Native Method)
    at java.lang.Class.privateGetDeclaredConstructors(Class.java:2671)
    at java.lang.Class.getConstructor0(Class.java:3075)
    at java.lang.Class.getConstructor(Class.java:1825)
    at net.minecraft.entity.EntityList.func_75615_a(EntityList.java:161)
    at net.minecraft.world.chunk.storage.AnvilChunkLoader.loadEntities(AnvilChunkLoader.java:487)
    at net.minecraftforge.common.chunkio.ChunkIOProvider.callStage2(ChunkIOProvider.java:44)
    at net.minecraftforge.common.chunkio.ChunkIOProvider.callStage2(ChunkIOProvider.java:15)
    at net.minecraftforge.common.util.AsynchronousExecutor.skipQueue(AsynchronousExecutor.java:344)
    at net.minecraftforge.common.util.AsynchronousExecutor.getSkipQueue(AsynchronousExecutor.java:302)
    at net.minecraftforge.common.chunkio.ChunkIOExecutor.syncChunkLoad(ChunkIOExecutor.java:12)
    at net.minecraft.world.gen.ChunkProviderServer.loadChunk(ChunkProviderServer.java:194)
    at net.minecraft.world.gen.ChunkProviderServer.func_73158_c(ChunkProviderServer.java:167)
    at net.minecraft.server.MinecraftServer.func_71222_d(MinecraftServer.java:480)
    at net.minecraft.server.MinecraftServer.func_71247_a(MinecraftServer.java:445)
    at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:336)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:631)
    at java.lang.Thread.run(Thread.java:745)
    Caused by: java.lang.ClassNotFoundException: net.minecraft.client.entity.EntityClientPlayerMP
    at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:191)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
    ... 18 more
    Caused by: java.lang.NullPointerException
    at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:182)
    ... 20 more

    A detailed walkthrough of the error, its code path and all known details is as follows:

    -- System Details --
    Details:
    Minecraft Version: 1.7.10
    KCauldron Version: pw.prok:KCauldron:1.7.10-1614.176
    Operating System: Linux (amd64) version 3.14.32-xxxx-std-ipv6-64-hz1000
    Java Version: 1.8.0_60, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 269856608 bytes (257 MB) / 518979584 bytes (494 MB) up to 6227755008 bytes (5939 MB)
    JVM Flags: 20 total; -Xincgc -XX:+UseParNewGC -XX:MaxPermSize=256M -XX:NewRatio=2 -XX:CMSFullGCsBeforeCompaction=1 -XX:+UseConcMarkSweepGC -XX:SoftRefLRUPolicyMSPerMB=2048 -XX:+CMSParallelRemarkEnabled -XX:+DisableExplicitGC -Xnoclassgc -Xoss4M -Xss4M -XX:+UseFastAccessorMethods -XX:CMSInitiatingOccupancyFraction=90 -XX:UseSSE=4 -XX:+UseCMSCompactAtFullCollection -XX:ParallelGCThreads=4 -XX:+AggressiveOpts -Xmx6144M -Xms512M
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    FML: MCP v9.05 FML v7.10.99.99 Minecraft Forge 10.13.4.1614 11 mods loaded, 11 mods active
    States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
    UCHIJAA mcp{9.05} [Minecraft Coder Pack] (minecraft.jar)
    UCHIJAA FML{7.10.99.99} [Forge Mod Loader] (KCauldron-1.7.10-1614.176.jar)
    UCHIJAA Forge{10.13.4.1614} [Minecraft Forge] (KCauldron-1.7.10-1614.176.jar)
    UCHIJAA kimagine{0.2} [KImagine] (minecraft.jar)
    UCHIJAA flansmod{@VERSION@} [Flan's Mod] (AltisCraft.fr.jar)
    UCHIJAA altiscraft.MODID{1.0.0} [AltisCraft.fr] (AltisCraft.fr.jar)
    UCHIJAA t4pro{1.0.1} [Project] (AltisCraft.fr.jar)
    UCHIJAA CarpentersBlocks{0.0.1 Beta} [AltisCraft.fr] (AltisCraft.fr.jar)
    UCHIJAA thirstmod{1.8.14} [Thirst Mod] (AltisCraft.fr.jar)
    UCHIJAA Dynmap{2.2-143} [Dynmap] (Dynmap-2.2-forge-1.7.10.jar)
    UCHIJAA gvc{0.6.1} [�aGliby's�f Voice Chat Mod] (GlibysVC-1.7.10-0.6.2a.jar)
    Profiler Position: N/A (disabled)
    Vec3 Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    Player Count: 0 / 250; []
    Is Modded: Definitely; Server brand changed to 'kcauldron,cauldron,craftbukkit,mcpc,fml,forge'
    Type: Dedicated Server (map_server.txt)

    Je comprends vraiment pas…

    😕

    Merci d'avance

    Cordialement



  • Tu fais sûrement une référence à la classe EntityClientPlayerMP (cilent-side only) dans un endroit côté server.



  • C'est ce que je me suis dis et pourtant non, c'est bizarre, j'éxécute actuellement sur chaque classe une sauvegarde pour voir qu'est-ce qui merde… 😕


  • Administrateurs

    On dirait que c'est Kcauldron lui même qui a un problème



  • J'y ai aussi pensé mais ça me semble bizarre ça me fait ça sur mes 4 serveurs et que lorsque je met ma Mise A Jour donc bon…



  • Ouep car le crash report ne fait aucune référence à une (ou des) quelconque(s) classes que t'aurais éventuellement crées.



  • Ouai mais si ça se fait que lorsque j'ai mis ma Mise A Jour y a obligatoirement un rapport avec ce que j'ai fait dans mon code.


  • Correcteurs

    C'est pas section utilisateurs comme sujet ça?



  • Bah dans ce cas, poste le crash report. Si y a le quelconque rapport avec ton code, il faut le poster qu'on puisse t'aider 😃


  • Administrateurs

    Dans ce cas -> logs

    Toutoune -> non car le problème concerne surement le code du mod de benjamin



  • Problème résolu en tripatouyant pleins de trucs je ne sais pas ce qui avait bugé… Mais bon résolu merci à tous de votre aide précieuse 😉