• Salut …

    Depuis se matin, je fais des modifications sur mon mod.
    J’avais enfin fini, content de le test je fais un gradlew build, je trouve un moyen d’obfuscate mes classes
    et quand je me rends compte qu’il me manquait une texture à faire, je revien pour ouvrir mon projet et booom !
    Un gros ! rouge sur le minecraft et je n’ai plus rien.
    Moment de panique, je me demande quoi faire, je ferme eclipse et je vais faire un gradlew setupDecompWorkspace suivi d’un gradlew eclipse.
    Je réouvre éclipse, j’ai tout mes classes sauf ceux que j’ai fais se matin…

    Avez-vous un idée quelque chose ? Pourquoi ça supprimé mes anciennes classes ? et s’il y a un moyen de remédier à ça …:(

    Cordialement, infectiion21


  • Mauvaise section, il faut aller dans support pour les moddeurs.

    De plus, je n’ai rien compris avec l’histoire du “rouge”, explique mieux si tu veux de l’aide.

  • Administrateurs Rédacteurs Moddeurs confirmés

    Sauf si tu as fait des sauvegarde, non c’est perdu. Tu as fait quoi comme manip exactement ?


  • Narvalo: Quand tu ouvre éclipse, il y a le fichier ‘‘minecraft’’. Alors le mien il y avais un GROS point d’exclamation rouge.

    Robin4002: Normalement j’avais sauvegardé … Alors ducoup il faut tout que je fasse … Mais je veux juste savoir pourquoi ça faite ça :/. Car si je recommence et ça me fait la même affaire encore … 10H de travail pour rien. Et quelle sorte de manip ?

  • Administrateurs Rédacteurs Moddeurs confirmés

    Avant que le gros point d’exclamation rouge apparaisse, tu as fait quoi ?


  • [size=x-smallun gradlew setupDecompWorkspace suivi d’un gradlew eclipse.]

    [size=x-smallEDIT: Je vien de trouver mais je ne sais pas pourquoi ça fait ça … Quand je fait un gradlew build, ça n’ajoute pas se que j’ai ajoutez et ça revient à l’ancien … Je save normalement :/]

  • Administrateurs Rédacteurs Moddeurs confirmés

    Pas normal ça. Refait un setup dans un autre dossier et copie les sources.


  • Est-ce que tu peux m’ajoutez skype et regarder avec moi ? Car je comprends pas vraiment …
    Mon skype –) antoine.naud2

    Merci, je serais dispo dans 30m-1h


  • Il te manque peu être une librairie. Clique sur ton dossier Minecraft dans éclipse, ensuite, va  à “Build pacth” et sélectionne “Configure Build Patch…
    Puis après, va dans “Order and Export” et regarde si ta pas des libraires en rouges.

    Si c’est la cas, ses sois que t’est librairie on disparu je sais pas trop pourquoi ou un problème importation “Mauvais chemin du fichier”


  • si la question n’est pas indiscrètes, c’étais sur quoi les 10 heures de travail ?


  • Sarcastiquement parlant … 😛 enfaite un “5h” de travail certain sur un mod … Assez lourd dirais-je 🙂