Problème launcheur



  • Salut !

    Alors, aujourd'hui mon problème vien d'un launcheur. C'est sur que après avoir créé le mod, il faut quelque chose pour faire marcher le mod.

    Le problème est que je suis allez voir une vidéo pour launcheur 1.7.2 en me disant que ça vas être pareil en 1.7.10
    Alors j'ai suivi tout parfaitement mais le launcheur est en 1.7.2 ! Donc je ne sais pas quoi faire.
    Voilà la vidéo ( vous n'êtes pas obligé d'allez la voir .. ) –)https://www.youtube.com/watch?v=qFm9l9PL2yE
    Au début, il dit que pour changer la version il faut changer le 1.7.10-custon.json et le 1.7.10-custom en 1.7.10-custom.( Assez dur à expliquer :$ )
    Bref, au début les 2 était en 1.7.2. Et je les ait changés...
    En dedans du .json, j'ai changer tout les 1.7.2 en 1.7.10
    Le problème est que quand je lance le launcheur, il ne veut pas se lancer et fait un erreur comme celui ci:

    ​
    Refreshing local version list...
    Refreshing remote version list...
    Launcher 1.0 (through bootstrap 5) started on windows...
    Current time is Nov 5, 2014 8:31:42 PM
    System.getProperty('os.name') == 'Windows 7'
    System.getProperty('os.version') == '6.1'
    System.getProperty('os.arch') == 'amd64'
    System.getProperty('java.version') == '1.7.0_71'
    System.getProperty('java.vendor') == 'Oracle Corporation'
    System.getProperty('sun.arch.data.model') == '64'
    Refresh complete.
    Loaded 1 profile(s); selected 'infectiion21'
    Refreshing auth...
    Getting syncinfo for selected version
    Queueing library & version downloads
    Couldn't get complete version info for PartialVersion{id='1.7.2-custom', updateTime=Wed Oct 09 19:03:12 PDT 2013, releaseTime=Thu Dec 31 23:00:00 PST 1959, type=RELEASE}
    java.io.FileNotFoundException: http://breakfight.livehost.fr/launcher/versions/1.7.2-custom/1.7.2-custom.json
    at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
    at net.minecraft.launcher.Http.performGet(Http.java:56)
    at net.minecraft.launcher.updater.RemoteVersionList.getContent(RemoteVersionList.java:21)
    at net.minecraft.launcher.updater.VersionList.getCompleteVersion(VersionList.java:85)
    at net.minecraft.launcher.updater.VersionManager.getLatestCompleteVersion(VersionManager.java:103)
    at net.minecraft.launcher.GameLauncher.playGame(GameLauncher.java:405)
    at net.minecraft.launcher.ui.bottombar.PlayButtonPanel$1$1.run(PlayButtonPanel.java:34)
    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
    at java.util.concurrent.FutureTask.run(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
    

    Et puis quand je renomme en 1.7.2, il me demande de re starter le launcheur pour être avec la bonne version.
    Alors je ne sais plus quoi modifier et quoi faire, si quelqu'un s'aurait, ou a une vidéo ou un tutoriel pour faire un launcheur en 1.7.10 je suis preneur !
    Si vous voulez plus d'informations ou autre n'hésitez pas.

    Cordialement, infectiion21

    Je vous laisse avec le screen des 2 choses qui fallait que je change en 1.7.10 🙂



  • Cette erreur

    1. java.io.FileNotFoundException: [color=#2a00ffhttp://breakfight.livehost.fr/launcher/versions/1.7.2-custom/1.7.2-custom.json]

    Vien que ton lien existe pas.

    Remplace le par lui http://breakfight.livehost.fr/launcher/versions/1.7.2-custom/1.7.10-custom.json



  • robin4002

    Les launchers customs ne sont désormais plus supportés ni même tolérés par Minecraft Forge France suite au message de Jeb sur son twitter. (cf : https://twitter.com/jeb_/status/461070509992849410,https://twitter.com/jeb_/status/461070990592970753, et https://twitter.com/jeb_/status/461071839935361024).
    À partir de maintenant toutes demandes d'aide concernant un launcher custom sera fermée.
    (Modification du message : 04-29-2014, 11:56 pm par robin4002.)



  • Désolé, et merci darkvinc, je vais essayé



  • Nous te conseillons d'utiliser un installeur, car c'est beaucoup plus pratique, en évitant a l'utilisateur d'avoir plusieurs launchers.


  • Administrateurs

    J'ai déjà donné mon point de vue sur les launchers.

    • le launcher officiel de Minecraft évolue constamment, vous allez à chaque fois vous retrouver avec des emmerdes dès que Mojang changera quelques choses (exemple changement des assets, changement des arguments de lancement de Minecraft dans les nouvelles versions …)
    • Vous pourrissez le disque dur vos utilisateurs. Il se retrouve avec autant de .quelque chose qu'ils ont de launchers custom, avec dedans à chaque fois les mêmes assets, les mêmes bibliothèques … Les deux dossiers assets et libraries font plus de 350 mo à eu deux, donc avec 3 launcher customs ça fait déjà 1 go utilisé sur le disque pour rien car les mêmes fichiers sont déjà dans le .minecraft...
    • Le launcher officiel de minecraft permet de gérer plusieurs profils, vraiment je ne vois plus l'utilité d'un launcher custom actuellement.
    • Et surtout, il est écrit dans le CLUF de Minecraft que le jeu doit être téléchargé depuis les serveurs de Mojang et les serveurs de Mojang uniquement, ré-hébergé le minecraft.jar n'est pas légal.

    Je lock le post, la prochaine fois des avertissements vont tombés.


Verrouillé