Lancement impossible sur Linux



  • Je viens d'installer Forge sur Linux (Installation bien longue d'ailleurs). J'ai également Java d'installé, pas de problème de ce coté
    Voici le code d'erreur :

    
    Exception in thread "main" joptsimple.MissingRequiredOptionException: Missing required option(s) ['userPropreties', 'accesToken', 'version']
    at joptsimple.OptionParser.ensureRequiredOptions(OptionParser.java:447)
    at joptsimple.OptionParser.parse(OptionParser:437)
    at net.minecraft.client.main.Main.main(Main.java:89)
    

    Merci d'avance.


  • Moddeurs confirmés Rédacteurs Administrateurs

    Refait un setup complet avec :
    gradlew setupDecompWorkspace –refresh-dependencies
    (quand même étrange que tu es ce bug sur un installation toute neuf, il a été corrigé depuis un moment).



  • Non, toujours le même code d'erreur.


  • Moddeurs confirmés Rédacteurs Administrateurs

    Il y a un problème avec la classe GradleStart alors, pas normal.
    Le chemin complet de ton dossier forge c'est quoi ?



  • /home/nolan/Documents/Forge/


  • Moddeurs confirmés Rédacteurs Administrateurs

    Ça vient pas de la non plus comme il n'y a pas de caractère spéciaux / accent dans le chemin.
    Tu as bien installé java7 et non le 8 ?



  • La 7u65 pour être précis.

    Edit : mince, je crois que j'ai pas installé le x64 mais le x32


  • Moddeurs confirmés Rédacteurs Administrateurs

    Non, normalement si tu as installé depuis le ppa tu as la version x64.
    Sinon clic sur la flèche à côté de run, puis fait run configuration. Sélectionnes client, et dans arguments -> program arguments, ajoutes :
    –userPropreties {} --accesToken FML, --version 1.7.10



  • Non, j'ai téléchargé un .tar.gz depuis le site et je l'ai lancé via la commande qu'ils indiquent sur le site (site officiel)

    Et nouveau crash report,

    [00:45:07] [main/INFO]: Setting user: dadax7684
    Exception in thread "main" java.lang.ClassCastException: sun.misc.Launcher$AppClassLoader cannot be cast to net.minecraft.launchwrapper.LaunchClassLoader
    at cpw.mods.fml.common.ModClassLoader.<init>(ModClassLoader.java:46)
    at cpw.mods.fml.common.Loader.<init>(Loader.java:181)
    at cpw.mods.fml.common.Loader.instance(Loader.java:160)
    at cpw.mods.fml.common.registry.GameData.addPrefix(GameData.java:901)
    at cpw.mods.fml.common.registry.GameData.register(GameData.java:736)
    at cpw.mods.fml.common.registry.FMLControlledNamespacedRegistry.addObject(FMLControlledNamespacedRegistry.java:117)
    at net.minecraft.block.Block.registerBlocks(Block.java:243)
    at net.minecraft.init.Bootstrap.func_151354_b(Bootstrap.java:457)
    at net.minecraft.client.Minecraft.<init>(Minecraft.java:333)
    at net.minecraft.client.main.Main.main(Main.java:141)
    ```</init></init></init>

  • Moddeurs confirmés Rédacteurs Administrateurs

    Heu ce truc m'a pas du tout l'air bon.
    Il fait un ClassCastException, c'est un problème dans le programme.

    ÉDIT : je viens de voir avec elias qui avait le même problème, en fait il faut changer assetsDir = "eclipse/assets" par runDir = "eclipse" dans le fichier build.gradle puis relancer les commandes gradlew setupDecompWorkspace et gradlew eclipse.



  • Tu me crois si je te dis que c'est pas ça ?
    Exactement le même message d'erreur.


  • Moddeurs confirmés Rédacteurs Administrateurs

    Vraiment étrange ça, sinon on peut regarder sur skype ou avec teamviewer si tu veux.


Log in to reply