1.7.2 [Résolu] Gradle export



  • Bonjour !

    Je n'arrive plus à exporter mon mod en utilisant gradle, il échoue toujours lors du "Resolving dependencies ':classpath'".

    Quand je lance avec –info :

    mbp-de-valentin:forge-1.7.2-10.12.1.1060-src Valentin$ ./gradlew build --info
    Starting Build
    Settings evaluated using empty settings script.
    Projects loaded. Root project using build file '/Users/Valentin/Documents/www.MineCube.net/ModdingForge/forge-1.7.2-10.12.1.1060-src/build.gradle'.
    Included projects: [root project 'forge-1.7.2-10.12.1.1060-src']
    Evaluating root project 'forge-1.7.2-10.12.1.1060-src' using build file '/Users/Valentin/Documents/www.MineCube.net/ModdingForge/forge-1.7.2-10.12.1.1060-src/build.gradle'.
    Resource missing. [HTTP GET: http://repo1.maven.org/maven2/com/mojang/authlib/1.5.16/authlib-1.5.16.pom]
    Resource missing. [HTTP HEAD: http://repo1.maven.org/maven2/com/mojang/authlib/1.5.16/authlib-1.5.16.jar]
    Resource missing. [HTTP GET: http://files.minecraftforge.net/maven/com/mojang/authlib/1.5.16/authlib-1.5.16.pom]
    Resource missing. [HTTP HEAD: http://files.minecraftforge.net/maven/com/mojang/authlib/1.5.16/authlib-1.5.16.jar]
    Resource missing. [HTTP GET: https://oss.sonatype.org/content/repositories/snapshots/com/mojang/authlib/1.5.16/authlib-1.5.16.pom]
    Resource missing. [HTTP HEAD: https://oss.sonatype.org/content/repositories/snapshots/com/mojang/authlib/1.5.16/authlib-1.5.16.jar]
    
    FAILURE: Build failed with an exception.
    
    * What went wrong:
    A problem occurred configuring root project 'forge-1.7.2-10.12.1.1060-src'.
    > Could not resolve all dependencies for configuration ':classpath'.
    > Could not find com.mojang:authlib:1.5.16.
    Required by:
    :forge-1.7.2-10.12.1.1060-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT
    
    * Try:
    Run with –stacktrace option to get the stack trace. Run with --debug option to get more log output.
    
    

    En gros il trouve pas les fichiers "authlib".

    Avec --debug :

    http://pastebin.com/anjkhsM7

    J'ai déjà recherche de l'aide sur internet, j'ai trouvé ça, mais ça n'a pas fonctionné..
    Merci de votre aide !


  • Modérateurs



  • Comment je corrige ça du coup ?


  • Modérateurs

    Tu fais ./gradlew –refreshdependencie ou quelque chose de similaire.

    Envoyé de mon AN7DG3-LZ en utilisant Tapatalk



  • Merci, ça a marché, j'avais déjà essayé tout à l'heure, mais sans succès… 🙂


  • Moddeurs confirmés Rédacteurs Administrateurs

    Ce poste aurait du être mit dans support pour les moddeurs.


Log in to reply