1.7.10 Erreur texture armure (tuto)



  • Créer une armure

    Bonjour j'ai fait le tuto en 1.7.10 pour m’entraîner mais tous va bien sauf au lancement du jeu et là pas de texture sur l'armure quand elle portée(enfin si il y a une texture celle par défaut)dans la console je n'ais pas trouvé d'erreur explicite.

    Merci de m'aider:

    Ma classe principale: 62199.txt
    Ma classe principale (lien):http://pastebin.fr/62199

    Ma classe ItemArmor(ModId):62198.txt
    Ma classe ItemArmor(ModId) (lien): http://pastebin.fr/62198

    Je pense pas que cela peut servir mais vu que ça a un rapport avec mon armure: Classe LivingEventHandler:62200.txt

    En lien:http://pastebin.fr/62200

    [09:23:42] [main/INFO] [GradleStart]: username: elliot.madrid38@gmail.com
    [09:23:42] [main/INFO] [GradleStart]: Extra: []
    [09:23:42] [main/INFO] [GradleStart]: Password found, attempting login
    [09:23:42] [main/INFO]: Logging in with username & password
    [09:23:44] [main/INFO] [GradleStart]: Login Succesful!
    [09:23:44] [main/INFO] [GradleStart]: Running with arguments: [--userProperties, {"preferredLanguage":["fr-fr"]}, --assetsDir, C:/Users/User/.gradle/caches/minecraft/assets, --assetIndex, 1.7.10, --userType, mojang, --accessToken, {REDACTED}, --version, 1.7.10, --uuid, e6b68b1beadc440c872aee87b2d8548a, --username, Helios_38, --tweakClass, cpw.mods.fml.common.launcher.FMLTweaker, --tweakClass, net.minecraftforge.gradle.tweakers.CoremodTweaker]
    [09:23:44] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLTweaker
    [09:23:44] [main/INFO] [LaunchWrapper]: Using primary tweak class name cpw.mods.fml.common.launcher.FMLTweaker
    [09:23:44] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.CoremodTweaker
    [09:23:44] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLTweaker
    [09:23:44] [main/INFO] [FML]: Forge Mod Loader version 7.99.40.1614 for Minecraft 1.7.10 loading
    [09:23:44] [main/INFO] [FML]: Java is Java HotSpot(TM) 64-Bit Server VM, version 1.8.0_241, running on Windows 10:amd64:10.0, installed at C:\Program Files\Java\jdk1.8.0_241\jre
    [09:23:44] [main/INFO] [FML]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation
    [09:23:44] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.CoremodTweaker
    [09:23:44] [main/INFO] [GradleStart]: Injecting location in coremod cpw.mods.fml.relauncher.FMLCorePlugin
    [09:23:44] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.classloading.FMLForgePlugin
    [09:23:44] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
    [09:23:44] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker
    [09:23:44] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
    [09:23:44] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
    [09:23:44] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
    [09:23:44] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
    [09:23:44] [main/ERROR] [FML]: The binary patch set is missing. Either you are in a development environment, or things are not going to work!
    [09:23:45] [main/ERROR] [FML]: FML appears to be missing any signature data. This is not a good thing
    [09:23:45] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
    [09:23:45] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLDeobfTweaker
    [09:23:46] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
    [09:23:46] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.TerminalTweaker
    [09:23:46] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.TerminalTweaker
    [09:23:46] [main/INFO] [LaunchWrapper]: Launching wrapped minecraft {net.minecraft.client.main.Main}
    [09:23:46] [main/INFO]: Setting user: Helios_38
    [09:23:47] [Client thread/INFO]: LWJGL Version: 2.9.1
    [09:23:48] [Client thread/INFO] [STDOUT]: [cpw.mods.fml.client.SplashProgress:start:188]: ---- Minecraft Crash Report ----
    // Hey, that tickles! Hehehe!
    
    Time: 20/04/20 09:23
    Description: Loading screen debug info
    
    This is just a prompt for computer specs to be printed. THIS IS NOT A ERROR
    
    
    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------
    
    -- System Details --
    Details:
    	Minecraft Version: 1.7.10
    	Operating System: Windows 10 (amd64) version 10.0
    	Java Version: 1.8.0_241, Oracle Corporation
    	Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    	Memory: 785039464 bytes (748 MB) / 1037959168 bytes (989 MB) up to 1037959168 bytes (989 MB)
    	JVM Flags: 3 total; -Xincgc -Xmx1024M -Xms1024M
    	AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    	IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    	FML: 
    	GL info: ' Vendor: 'NVIDIA Corporation' Version: '4.6.0 NVIDIA 440.97' Renderer: 'GeForce GTX 1650/PCIe/SSE2'
    [09:23:49] [Client thread/INFO] [MinecraftForge]: Attempting early MinecraftForge initialization
    [09:23:49] [Client thread/INFO] [FML]: MinecraftForge v10.13.4.1614 Initialized
    [09:23:49] [Client thread/INFO] [FML]: Replaced 183 ore recipies
    [09:23:49] [Client thread/INFO] [MinecraftForge]: Completed early MinecraftForge initialization
    [09:23:49] [Client thread/INFO] [FML]: Found 0 mods from the command line. Injecting into mod discoverer
    [09:23:49] [Client thread/INFO] [FML]: Searching C:\Users\User\Desktop\forge-1.7.10-10.13.4.1558-1.7.10-src\mods for mods
    [09:23:54] [Client thread/INFO] [FML]: Forge Mod Loader has identified 4 mods to load
    [09:23:54] [Client thread/INFO] [FML]: Attempting connection with missing mods [mcp, FML, Forge, astral] at CLIENT
    [09:23:54] [Client thread/INFO] [FML]: Attempting connection with missing mods [mcp, FML, Forge, astral] at SERVER
    [09:23:54] [Client thread/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:Astral Mod
    [09:23:54] [Client thread/INFO] [FML]: Processing ObjectHolder annotations
    [09:23:54] [Client thread/INFO] [FML]: Found 341 ObjectHolder annotations
    [09:23:54] [Client thread/INFO] [FML]: Identifying ItemStackHolder annotations
    [09:23:54] [Client thread/INFO] [FML]: Found 0 ItemStackHolder annotations
    [09:23:54] [Client thread/INFO] [FML]: Configured a dormant chunk cache size of 0
    [09:23:54] [Client thread/INFO] [FML]: Applying holder lookups
    [09:23:54] [Client thread/INFO] [FML]: Holder lookups applied
    [09:23:54] [Client thread/INFO] [FML]: Injecting itemstacks
    [09:23:54] [Client thread/INFO] [FML]: Itemstack injection complete
    [09:23:54] [Sound Library Loader/INFO] [STDOUT]: [paulscode.sound.SoundSystemLogger:message:69]: 
    [09:23:54] [Sound Library Loader/INFO] [STDOUT]: [paulscode.sound.SoundSystemLogger:message:69]: Starting up SoundSystem...
    [09:23:55] [Thread-8/INFO] [STDOUT]: [paulscode.sound.SoundSystemLogger:message:69]: Initializing LWJGL OpenAL
    [09:23:55] [Thread-8/INFO] [STDOUT]: [paulscode.sound.SoundSystemLogger:message:69]:     (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)
    [09:23:55] [Thread-8/INFO] [STDOUT]: [paulscode.sound.SoundSystemLogger:message:69]: OpenAL initialized.
    [09:23:55] [Sound Library Loader/INFO] [STDOUT]: [paulscode.sound.SoundSystemLogger:message:69]: 
    [09:23:55] [Sound Library Loader/INFO]: Sound engine started
    [09:23:59] [Client thread/INFO]: Created: 16x16 textures/blocks-atlas
    [09:23:59] [Client thread/INFO]: Created: 16x16 textures/items-atlas
    [09:23:59] [Client thread/INFO] [STDOUT]: [fr.helios.astral.proxy.ClientProxy:registerRender:7]: côté client
    [09:23:59] [Client thread/INFO] [FML]: Injecting itemstacks
    [09:23:59] [Client thread/INFO] [FML]: Itemstack injection complete
    [09:23:59] [Client thread/INFO] [FML]: Forge Mod Loader has successfully loaded 4 mods
    [09:23:59] [Client thread/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:Astral Mod
    [09:23:59] [Client thread/INFO]: Created: 512x256 textures/blocks-atlas
    [09:23:59] [Client thread/INFO]: Created: 256x256 textures/items-atlas
    [09:23:59] [Client thread/INFO] [STDOUT]: [paulscode.sound.SoundSystemLogger:message:69]: 
    [09:23:59] [Client thread/INFO] [STDOUT]: [paulscode.sound.SoundSystemLogger:message:69]: SoundSystem shutting down...
    [09:24:00] [Client thread/INFO] [STDOUT]: [paulscode.sound.SoundSystemLogger:importantMessage:90]:     Author: Paul Lamb, www.paulscode.com
    [09:24:00] [Client thread/INFO] [STDOUT]: [paulscode.sound.SoundSystemLogger:message:69]: 
    [09:24:00] [Sound Library Loader/INFO] [STDOUT]: [paulscode.sound.SoundSystemLogger:message:69]: 
    [09:24:00] [Sound Library Loader/INFO] [STDOUT]: [paulscode.sound.SoundSystemLogger:message:69]: Starting up SoundSystem...
    [09:24:00] [Thread-10/INFO] [STDOUT]: [paulscode.sound.SoundSystemLogger:message:69]: Initializing LWJGL OpenAL
    [09:24:00] [Thread-10/INFO] [STDOUT]: [paulscode.sound.SoundSystemLogger:message:69]:     (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)
    [09:24:00] [Thread-10/INFO] [STDOUT]: [paulscode.sound.SoundSystemLogger:message:69]: OpenAL initialized.
    [09:24:00] [Sound Library Loader/INFO] [STDOUT]: [paulscode.sound.SoundSystemLogger:message:69]: 
    [09:24:00] [Sound Library Loader/INFO]: Sound engine started
    [09:24:03] [Server thread/INFO]: Starting integrated minecraft server version 1.7.10
    [09:24:03] [Server thread/INFO]: Generating keypair
    [09:24:04] [Server thread/INFO] [FML]: Injecting existing block and item data into this server instance
    [09:24:04] [Server thread/INFO] [FML]: Applying holder lookups
    [09:24:04] [Server thread/INFO] [FML]: Holder lookups applied
    [09:24:04] [Server thread/INFO] [FML]: Loading dimension 0 (Astral Test) (net.minecraft.server.integrated.IntegratedServer@4013ba32)
    [09:24:04] [Server thread/INFO] [FML]: Loading dimension 1 (Astral Test) (net.minecraft.server.integrated.IntegratedServer@4013ba32)
    [09:24:04] [Server thread/INFO] [FML]: Loading dimension -1 (Astral Test) (net.minecraft.server.integrated.IntegratedServer@4013ba32)
    [09:24:04] [Server thread/INFO]: Preparing start region for level 0
    [09:24:04] [Server thread/INFO]: Changing view distance to 12, from 10
    [09:24:05] [Netty Client IO #0/INFO] [FML]: Server protocol version 2
    [09:24:05] [Netty IO #1/INFO] [FML]: Client protocol version 2
    [09:24:05] [Netty IO #1/INFO] [FML]: Client attempting to join with 4 mods : FML@7.10.99.99,Forge@10.13.4.1614,astral@1.0,mcp@9.05
    [09:24:05] [Netty IO #1/INFO] [FML]: Attempting connection with missing mods [] at CLIENT
    [09:24:05] [Netty Client IO #0/INFO] [FML]: Attempting connection with missing mods [] at SERVER
    [09:24:05] [Client thread/INFO] [FML]: [Client thread] Client side modded connection established
    [09:24:05] [Server thread/INFO] [FML]: [Server thread] Server side modded connection established
    [09:24:05] [Server thread/INFO]: Helios_38[local:E:26da162e] logged in with entity id 224 at (-117.43753291865485, 63.797350686368674, 316.59299405138944)
    [09:24:05] [Server thread/INFO]: Helios_38 a rejoint la partie
    [09:24:08] [Server thread/INFO]: Saving and pausing game...
    [09:24:08] [Server thread/INFO]: Saving chunks for level 'Astral Test'/Overworld
    [09:24:08] [Server thread/INFO]: Saving chunks for level 'Astral Test'/Nether
    [09:24:08] [Server thread/INFO]: Saving chunks for level 'Astral Test'/The End
    [09:24:09] [Server thread/INFO]: Stopping server
    [09:24:09] [Server thread/INFO]: Saving players
    [09:24:09] [Server thread/INFO]: Saving worlds
    [09:24:09] [Server thread/INFO]: Saving chunks for level 'Astral Test'/Overworld
    [09:24:09] [Server thread/INFO]: Saving chunks for level 'Astral Test'/Nether
    [09:24:09] [Server thread/INFO]: Saving chunks for level 'Astral Test'/The End
    [09:24:09] [Server thread/INFO] [FML]: Unloading dimension 0
    [09:24:09] [Server thread/INFO] [FML]: Unloading dimension -1
    [09:24:09] [Server thread/INFO] [FML]: Unloading dimension 1
    [09:24:09] [Server thread/INFO] [FML]: Applying holder lookups
    [09:24:09] [Server thread/INFO] [FML]: Holder lookups applied
    [09:24:10] [Client thread/INFO]: Stopping!
    [09:24:10] [Client thread/INFO] [STDOUT]: [paulscode.sound.SoundSystemLogger:message:69]: 
    [09:24:10] [Client thread/INFO] [STDOUT]: [paulscode.sound.SoundSystemLogger:message:69]: SoundSystem shutting down...
    [09:24:10] [Client thread/INFO] [STDOUT]: [paulscode.sound.SoundSystemLogger:importantMessage:90]:     Author: Paul Lamb, www.paulscode.com
    [09:24:10] [Client thread/INFO] [STDOUT]: [paulscode.sound.SoundSystemLogger:message:69]: 
    Java HotSpot(TM) 64-Bit Server VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
    

  • Moddeurs confirmés Rédacteurs Administrateurs

    Bonjour,

    Dans la classe de ton armure tu n'as pas importé le bon entity.
    Ajouter un @Override au dessus de la fonction getArmorTexture t'aurai permit d'avoir une erreur.

    Et sinon Minecraft Forge France ne fait plus de support pour la 1.7.10, j'archive donc cette discussion directement.


  • Moddeurs confirmés Rédacteurs Administrateurs

    Bonjour,

    Dans la classe de ton armure tu n'as pas importé le bon entity.
    Ajouter un @Override au dessus de la fonction getArmorTexture t'aurai permit d'avoir une erreur.

    Et sinon Minecraft Forge France ne fait plus de support pour la 1.7.10, j'archive donc cette discussion directement.


Log in to reply