Erreur commande .\gradlew setupDecompWorkspace



  • Bonjour,

    Je me suis lancer dans le modding minecraft forge depuis peu j'ai déjà suivi des cours JAVA sur openClassRoom et j'ai déjà fait deux mods (1.12.2; 1.9.4).
    Je veux faire un mod en 1.7.10 j'ai suivi le tutoriel jusqu'a la préparation de sa Workspace(je suis sur Eclipse)
    la j'ai tout essayer pour faire marcher la commande mais pas moyen je m'en retourne a vous désormais, je suis a cours d'idées.

    Voici le message d'erreur complet de la commande (si besoin d'autre source me demander):

    PS C:\Users\User\Desktop\forge-1.7.10-10.13.4.1558-1.7.10-src> .\gradlew task
    
    FAILURE: Build failed with an exception.
    
    * What went wrong:
    A problem occurred configuring root project 'forge-1.7.10-10.13.4.1558-1.7.10-src'.
    > Could not resolve all dependencies for configuration ':classpath'.
       > Could not resolve net.md-5:SpecialSource:1.7.3.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT
          > Could not GET 'http://repo1.maven.org/maven2/net/md-5/SpecialSource/1.7.3/SpecialSource-1.7.3.pom'. Received status code 501 from server: HTTPS Required
       > Could not resolve org.apache.httpcomponents:httpclient:4.3.3.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT
          > Could not HEAD 'http://repo1.maven.org/maven2/org/apache/httpcomponents/httpclient/4.3.3/httpclient-4.3.3.pom'. Received status code 501 from server: HTTPS Required
       > Could not resolve org.apache.httpcomponents:httpmime:4.3.3.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT
          > Could not HEAD 'http://repo1.maven.org/maven2/org/apache/httpcomponents/httpmime/4.3.3/httpmime-4.3.3.pom'. Received status code 501 from server: HTTPS Required
       > Could not resolve com.github.abrarsyed.jastyle:jAstyle:1.2.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT
          > Could not GET 'http://repo1.maven.org/maven2/com/github/abrarsyed/jastyle/jAstyle/1.2/jAstyle-1.2.pom'. Received status code 501 from server: HTTPS Required
       > Could not resolve net.sf.trove4j:trove4j:2.1.0.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT
          > Could not HEAD 'http://repo1.maven.org/maven2/net/sf/trove4j/trove4j/2.1.0/trove4j-2.1.0.pom'. Received status code 501 from server: HTTPS Required
       > Could not resolve com.google.code.gson:gson:2.2.4.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > de.oceanlabs.mcp:RetroGuard:3.6.6
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > de.oceanlabs.mcp:mcinjector:3.2-SNAPSHOT
          > Could not HEAD 'http://repo1.maven.org/maven2/com/google/code/gson/gson/2.2.4/gson-2.2.4.pom'. Received status code 501 from server: HTTPS Required
       > Could not resolve com.google.guava:guava:18.0.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
          > Could not HEAD 'http://repo1.maven.org/maven2/com/google/guava/guava/18.0/guava-18.0.pom'. Received status code 501 from server: HTTPS Required
       > Could not resolve org.ow2.asm:asm-debug-all:5.0.3.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
          > Could not HEAD 'http://repo1.maven.org/maven2/org/ow2/asm/asm-debug-all/5.0.3/asm-debug-all-5.0.3.pom'. Received status code 501 from server: HTTPS Required
       > Could not resolve com.github.tony19:named-regexp:0.2.3.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT
          > Could not HEAD 'http://repo1.maven.org/maven2/com/github/tony19/named-regexp/0.2.3/named-regexp-0.2.3.pom'. Received status code 501 from server: HTTPS Required
       > Could not resolve com.cloudbees:diff4j:1.1.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT
          > Could not HEAD 'http://repo1.maven.org/maven2/com/cloudbees/diff4j/1.1/diff4j-1.1.pom'. Received status code 501 from server: HTTPS Required
       > Could not resolve net.sf.jopt-simple:jopt-simple:4.6.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > de.oceanlabs.mcp:RetroGuard:3.6.6
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > de.oceanlabs.mcp:mcinjector:3.2-SNAPSHOT
          > Could not HEAD 'http://repo1.maven.org/maven2/net/sf/jopt-simple/jopt-simple/4.6/jopt-simple-4.6.pom'. Received status code 501 from server: HTTPS Required
       > Could not resolve org.eclipse.core:jobs:3.5.300-v20130429-1813.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
          > Could not GET 'http://repo1.maven.org/maven2/org/eclipse/core/jobs/3.5.300-v20130429-1813/jobs-3.5.300-v20130429-1813.pom'. Received status code 501 from server: HTTPS Required
       > Could not resolve org.eclipse:osgi:3.9.1-v20130814-1242.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
          > Could not GET 'http://repo1.maven.org/maven2/org/eclipse/osgi/3.9.1-v20130814-1242/osgi-3.9.1-v20130814-1242.pom'. Received status code 501 from server: HTTPS Required
       > Could not resolve org.eclipse.core:contenttype:3.4.200-v20130326-1255.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
          > Could not GET 'http://repo1.maven.org/maven2/org/eclipse/core/contenttype/3.4.200-v20130326-1255/contenttype-3.4.200-v20130326-1255.pom'. Received status code 501 from server: HTTPS Required
       > Could not resolve org.eclipse.core:resources:3.2.1-R32x_v20060914.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
          > Could not GET 'http://repo1.maven.org/maven2/org/eclipse/core/resources/3.2.1-R32x_v20060914/resources-3.2.1-R32x_v20060914.pom'. Received status code 501 from server: HTTPS Required
       > Could not resolve org.eclipse.equinox:common:3.6.200-v20130402-1505.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
          > Could not GET 'http://repo1.maven.org/maven2/org/eclipse/equinox/common/3.6.200-v20130402-1505/common-3.6.200-v20130402-1505.pom'. Received status code 501 from server: HTTPS Required
       > Could not resolve org.eclipse.text:org.eclipse.text:3.5.101.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
          > Could not GET 'http://repo1.maven.org/maven2/org/eclipse/text/org.eclipse.text/3.5.101/org.eclipse.text-3.5.101.pom'. Received status code 501 from server: HTTPS Required
       > Could not resolve org.eclipse.jgit:org.eclipse.jgit:3.2.0.201312181205-r.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
          > Could not GET 'http://repo1.maven.org/maven2/org/eclipse/jgit/org.eclipse.jgit/3.2.0.201312181205-r/org.eclipse.jgit-3.2.0.201312181205-r.pom'. Received status code 501 from server: HTTPS Required
       > Could not resolve org.eclipse.equinox:preferences:3.5.100-v20130422-1538.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
          > Could not GET 'http://repo1.maven.org/maven2/org/eclipse/equinox/preferences/3.5.100-v20130422-1538/preferences-3.5.100-v20130422-1538.pom'. Received status code 501 from server: HTTPS Required
       > Could not resolve net.sf.jopt-simple:jopt-simple:4.6.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
          > Could not HEAD 'http://repo1.maven.org/maven2/net/sf/jopt-simple/jopt-simple/4.6/jopt-simple-4.6.pom'. Received status code 501 from server: HTTPS Required
       > Could not resolve org.eclipse.core:runtime:3.9.0-v20130326-1255.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
          > Could not GET 'http://repo1.maven.org/maven2/org/eclipse/core/runtime/3.9.0-v20130326-1255/runtime-3.9.0-v20130326-1255.pom'. Received status code 501 from server: HTTPS Required
       > Could not resolve org.ow2.asm:asm-debug-all:5.0.3.
         Required by:
             :forge-1.7.10-10.13.4.1558-1.7.10-src:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > de.oceanlabs.mcp:mcinjector:3.2-SNAPSHOT
          > Could not HEAD 'http://repo1.maven.org/maven2/org/ow2/asm/asm-debug-all/5.0.3/asm-debug-all-5.0.3.pom'. Received status code 501 from server: HTTPS Required
    
    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
    
    BUILD FAILED
    
    Total time: 30.662 secs
    

    Voila Merci de m'aider

    Ps: Je suis un peu jeune(13 ans) mais si on m'explique je comprends bien en général.



  • Pour régler ce problème il faut aller dans le dossier, "graddle" puis "wrapper" et ouvrir le fichier "graddle-wrapper.properties" et modifier la ligne

    distributionUrl=https\://services.gradle.org/distributions/gradle-2.0-bin.zip
    

    par

    distributionUrl=https\://services.gradle.org/distributions/gradle-2.6-bin.zip
    


  • Pour régler ce problème il faut aller dans le dossier, "graddle" puis "wrapper" et ouvrir le fichier "graddle-wrapper.properties" et modifier la ligne

    distributionUrl=https\://services.gradle.org/distributions/gradle-2.0-bin.zip
    

    par

    distributionUrl=https\://services.gradle.org/distributions/gradle-2.6-bin.zip
    


  • je te remercie je vais enfin pouvoir continuer a m'exercer.

    😋



  • Derien ^^ (moi même ça m'est arrivé)



  • Les "gars", stop la 1.7 ! mettez-vous à jour, svp : 1.12.2/1.14.4/1.15.2 !
    La 1.7 est trop vieille et n'est plus supporté par les forums, et son setup a été complexifié par Forge eux-mêmes.


  • Moddeurs confirmés Rédacteurs Administrateurs

    @JohnProgrammer a dit dans Erreur commande .\gradlew setupDecompWorkspace :

    et son setup a été complexifié par Forge eux-mêmes.

    Non, Forge n'a rien fait pour le rendre plus compliqué.
    C'est un changement du côté de maven qui a causé ce problème.

    Mais sinon effectivement la 1.7 n'est plus supporté.



  • Ah excuses Robin, j'ai du mal lire ça.


Log in to reply