Aider-moi j'arrive pas a importer le forge MDK (version 1.12.2) dans mon IDE



  • Lorsque que j'importe le fichier build.gradle de minecraft-forge 1.12.2 dans mon IDE (intellij IDEA
    ou eclipse) depuit que j'ai réinstallez celui-ci j'ai des erreurs que je comprend pas.
    J'ai essayer avec le mdk de forge et j'ai essayer avec le plugin minecraft dev mais sa marche pas.
    j'ai ces erreurs là.

    lors de l'imporation avec le plugin j'ai cette erreur:

    • Cause:org.gradle.api.internal.TaskOutputsInternal.dir(Ljava/lang/Object;)Lorg/gradle/api/tasks/TaskOutputs;

    Et voici en détail:

    * FAILURE: Build failed with an exception.
    
    * Where:
    Build file 'C:\Users\scott\Desktop\untitled\build.gradle' line: 14
    
    * What went wrong:
    A problem occurred evaluating root project 'untitled'.
    > org.gradle.api.internal.TaskOutputsInternal.dir(Ljava/lang/Object;)Lorg/gradle/api/tasks/TaskOutputs;
    
    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
    
    * Get more help at https://help.gradle.org
    
    - CONFIGURE FAILED in 4s
    

    et lors de l'importation avec le mdk j'ai cette erreur:

    • Expected BEGIN_OBJECT but was STRING at line 1 column 1

    et voici son détail:

    - This mapping 'snapshot_20171003' was designed for MC 1.12! Use at your own peril.
    
    - FAILURE: Build failed with an exception.
    
    * What went wrong:
    A problem occurred configuring root project 'forge-1.12.2-14.23.5.2768-mdk'.
    > java.lang.IllegalStateException: Expected BEGIN_OBJECT but was STRING at line 1 column 1
    
    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
    
    - CONFIGURE FAILED
    
    - Total time: 5.139 secs
    

    Merci d'avance de m'aider .
    Je suis bloqué car j'ai java 8 version 221 avant j'utilisé la version 211 mais je pence que sa na rien a voir car depuit que j'ai reinstaller intellij Idea (aprés une pause de 1 ans pour tester eclipse) il y a plein de chose qui on changer et je suis perdu.

    Pour ceux qui trouve l'erreur aidez-moi j'ai que 14 ans et c'est une passion j'ai pas envie de passer des jours dessus supplementaire car sa fait deja 2 semaine que je galére.

    Merci D'avance pour la deuxieme fois.


  • Moddeurs confirmés Rédacteurs Administrateurs

    Bonjour,

    Il me semble que l'importation en tant que projet gradle ne soit 100% fonctionnel qu'en 1.13.2 et +.
    En 1.12.2 et avant il faut taper les commandes gradlew setupDecompWorkspace puis gradlew eclipse (pour eclipse, pour idea je ne sais plus la commande) et l'importer en tant que simple projet Java.

    Note pour l'avenir : les demandes d'aides concernant la programmation vont dans aide pour les moddeurs et non dans discussion générale ... + penses à utiliser le markdown ``` pour les logs.



  • Merci c'était le premier message que je posté.
    Mais comment on fait pour réparer gradle sur éclipse ou sur intellij Idea ,
    avez-vous une idée ?
    ( Il faudrait télécharger une nouvelle version de gradle a part pour compiller ? )



  • Sur intellij il faux importer a partir de l'interface de demarage mais sa me mais l'erreur si dessus


  • Moddeurs confirmés Rédacteurs Administrateurs

    Je n'utilises pas intellij Idea donc je ne vais pas pouvoir t'aider plus.

    Mais sauf erreur de ma part, il n'est pas possible d'utiliser l'importation gradle avant la 1.13, il faut importer le projet en tant que projet java, après avoir tapé les commandes gradle à la main.



  • Il n'y a donc pas de technic pour ouvrir forge 1.12.2 (même sur éclipse)


  • Moddeurs confirmés Rédacteurs Administrateurs

    Si, en important le projet en tant que projet Java et non comme projet gradle.
    https://www.minecraftforgefrance.fr/topic/2588/installer-et-configurer-l-espace-de-travail-de-forge/

    C'est ce que je t'ai dit dans ma première réponse.



  • Salut,
    Personnellement, j'ai eu quelques soucis aussi, pour les résoudre, j'ai mis a jour gradle en 4.8.1 (fichier gradle\wrapper\gradles-wrapper.properties en modifiant dans le lien la version ex 2.14 : url://xxx/xxx/xxx/xxx/xxx-2.14/xxx) en 4.8.1.
    Puis j'ai effectué la commande gradlew wrapper
    Puis gradlew setupDecompWorkspace
    Puis j'ai import le build.gradle dans idea
    Et ca a marché nickel.

    En espérant que ça va t'aider,
    Flow arg



  • @Flow-Arg merci mais sa na pas marcher


Log in to reply