Problème avec minecraft (Unable to launch java.lang.ClassNotFoundException: cpw.mods.fml.common.launcher.FMLTweaker)



  • Bonjour,
    Suite à la création d'un launcher, je n'arrive pas a lancé minecraft.
    Voici les logs lors du crash:

    [OpenLauncherLib] Launching Minecraft
    [OpenLauncherLib] Successfully launched
    [23:49:51] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLTweaker
    [23:49:51] [main/ERROR] [LaunchWrapper]: Unable to launch
    java.lang.ClassNotFoundException: cpw.mods.fml.common.launcher.FMLTweaker
    	at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.8.0_211]
    	at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_211]
    	at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source) ~[?:1.8.0_211]
    	at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_211]
    	at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:106) ~[launchwrapper-1.12.jar:?]
    	at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_211]
    	at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_211]
    	at java.lang.Class.forName0(Native Method) ~[?:1.8.0_211]
    	at java.lang.Class.forName(Unknown Source) ~[?:1.8.0_211]
    	at net.minecraft.launchwrapper.Launch.launch(Launch.java:98) [launchwrapper-1.12.jar:?]
    	at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.12.jar:?]
    

    J'ai réinstaller Forge plusieurs fois, c'est bien la bonne version (1.12.2).
    Merci de votre futur aide 🙂



  • Bonjour,

    C'était bien le launcher qui à foiré à cause du tweakclass (comme à dit @SpyMan & @robin4002).
    J'ai régler le soucis et maintenant il se lance 🙂

    Merci à vous.


  • Moddeurs confirmés Rédacteurs Administrateurs

    Salut,
    Tu essaies de lancer le jeu avec le tweakclass de forge 1.7.10, forcement si tu as forge 1.12.2 ça ne risque pas de fonctionner ...



  • ca sent le launcher foireux ca...



  • Bonjour,

    C'était bien le launcher qui à foiré à cause du tweakclass (comme à dit @SpyMan & @robin4002).
    J'ai régler le soucis et maintenant il se lance 🙂

    Merci à vous.



  • Bonjour
    je vien de tomber sur ton post et j'ai le meme probleme sur le launcher que je vient de creer ...
    comment a tu regler ton probleme ?
    merci d'avance
    arnauz



  • Yo, je ne sais pas moi, c'est votre code pas le mien..., si vous voulez de l'aide envoyé peut être des logs + code ?


Log in to reply