Probleme de crash a cause de mon nouveau mob.



  • Bonjour a tous !
    Alors voila cela fait plusieurs jours que j'essaye tant bien que mal à creer un nouveau mob sur minecraft 1.6.4,
    mais au lancement de celui-ci le jeu crash ! 😕

    Est-ce un probleme au niveau du ClientProxy, du CommonProxy , du proxy.registerRender(); ou d'autres choses ? :huh:
    Merci d'avance pour votre aide et bonne journée. 😄

    Ma classe principale
    La console
    Mon CommonProxy
    Mon ClientProxy


  • Administrateurs

    2014-03-01 18:43:10 [Infos] [STDOUT] java.lang.NullPointerException
    2014-03-01 18:43:10 [Infos] [STDOUT] at modendercraft.ModelChevalier.<init>(ModelChevalier.java:90)
    

    ModelChevalier.java ?</init>



  • Merci d'une reponse si rapide ^^ oui c'est le .class dans lequel il y a le model de mon mob.
    Le voici : http://pastebin.com/8HD0GTXJ


  • Administrateurs

    Ligne 90, enlève le partie_4.mirror = true;
    et ligne 97, enlève partie_4.mirror = false;

    Sinon pour tout ce qui concerne les codes, il faut poster dans la section support pour les moddeurs, je déplace la discussion.



  • Tu n'aurais pas oublier d'instancier partie_4 ?
    partie_1 = new ModelRenderer(this, 90, 10); -> OK
    Partie_2 = new ModelRenderer(this, 90, 8); -> OK
    partie_3 = new ModelRenderer(this, 88, 9); -> OK
    partie_4 -> ???
    partie_5 = new ModelRenderer(this, 90, 10); -> OK

    La tu accede a un attribut mirror sur un objet = a null.
    C'est pour cela que ça plante 😉

    Attention aux conventions de nommage 😉 Utilise le refractor sous eclipse pour renommer tes variables 😉

    EDIT : Ah non, je viens de voir que tu initialise quand même ta variable mais tu l'initialise après que tu accèdes a l'attribut mirror donc le problème reste le même. Lorsque tu tentes d'accéder a mirror, ton objet vaut null et null ne possède pas d'attribut mirror.


Log in to reply