Installer l'espace de travail pour Eclipse



  • Bon tout d'abord désolé d'envoyer ce message en Octobre 2018. Mais je voudrais bien crer un mod. Malheuresement pendant la commande ./gradlew setupDecompWorkspace dans PowerShell cela ne marche absolument pas j'ai bien le JDK installé et j'ai même refait le tuto une 2e fois je ne comprends pas..
    BUILD FAILLED.

    Merci de votre réponse d'avance !
    wshZXNG


  • Administrateurs

    Salut,
    Il faudrait les logs complet (avoir juste BUILD FAILED be nous permet en aucun cas de trouver la source du problème).



  • Bonjour,
    j'en suis à l'étape "gradlew setupDecompWorkspace" et j'ai le droit à un jolie Failed quand je le lance : 'Perhaps JAVA_HOME does not point to the JDK.
    It is currently set to "C:\Program Files\Java\jre1.8.0_111"'

    Le truc c'est que ça fait déjà un moment que j'utilise eclipse sans trop de problème, j'ai essayé de changer JAVA_HOME mais il n'est pas visible dans mes variable d'environnement. J'ai donc mis mon jdk à la place du jre et il a encore moins aimé.

    Je ne suis pas sur d'avoir bien fais pour le jdk (j'ai juste dl la source de la version 12.0.1 et je ne sais pas si ça correspond)

    Bref, aidez moi siouplaît^^



  • Yo, la var env JAVA_HOME doit pointer sur le repertoire contenant le repertoire bin du JDK
    JRE = Java Runtime Environment
    JDK = Java Developpment Kit


  • Administrateurs

    Non, c'est bien sur le dossier principal du jdk et non sur le dossier bin.

    Assures-toi que le chemin et le bon (là sur l'erreur cela pointe sur le jre, ce n'est pas bon).



  • Ok merci mais tout ça je ne sais en fait...
    Mon problème est que je ne sais pas où trouver JAVA_HOME je ne le vois pas ni dans :
    Ordinateur > Propriétés > Paramètres système avancés > Variables d'environnement > Variables utilisateur pour XXXXX
    ni dans :
    Ordinateur > Propriétés > Paramètres système avancés > Variables d'environnement > Variables système

    Du coup j'ai feinté et j'ai pris mon dossier jdk télécharger sur internet et je l'ai renommé pour qu'il correspondre à l'addresse visé mais du coup j'ai une pop-up qui s'ouvre : "Impossible de démarrer le programme car il manque jli.dll sur votre ordinateur.[...]"

    Donc je me pose deux questions :

    • Pourquoi je ne voit pas la variable JAVA_HOME?
    • Pourquoi mon jdk ne marche pas (quand je le place là où pointe JAVA_HOME)?

  • Administrateurs

    Oula, faut surtout pas faire ça, car il y a des clés dans le registre et autre endroit qui référence le dossier. On ne déplace jamais des dossiers se trouvant dans Program Files !

    Laisses le JDK a son emplacement de base.
    Il faut simplement créer la variable JAVA_HOME si elle n'existe pas, en mettant le chemin du dossier du jdk en valeur.



  • Je viens justement de créer la variable et ça n'a rien changé, elle est juste ignorée, ce qui ne m'étonne pas car même sans que je puisse la voir il arrivaient à me sortir le path du jre...
    Mais vue que j'ai juste télécharger le dossier src et placé là je suppose que j'ai mal fait quelque chose, je vais télécharger l'installeur 😕


  • Administrateurs

    Tu as relancé le cmd après avoir ajouté la variable ?

    Et oui normal qu'il trouvait le jre, si JAVA_HOME n'existe pas il prend le dossier de la JVM utilisé pour s'exécuter.



  • En plus j'avais lu un truc sur le fait que le cmd charge les variables d'environnements au démarage d'un fenêtre^^
    Je viens de le relancer, et ça ne marche toujours pas mais ça a avancé : "Could not determine java version from 12.0.1" C'est parceque mon jdk s'appel "jdk12.0.1" à tout les coups xD
    Enfin bon je télécharge un installeur et le reste ira tranquillou je pense.
    Bref, je pense pouvoir me débrouiller jusqu'à la prochaine tuile.

    En tout cas un grand merci^^



  • les versions anterieure a la 1.13 ne supporte pas version de java > a java 8 !!!



  • J'ai un pitit message à chaque fois que je quitte minecraft mais ça ne gêne pas sinon (je crois) après tout si je n'utilise pas de fonctionnalité de la java 8 ça devrait le faire non?


  • Administrateurs

    Je n'ai pas compris la question. Tu peux détailler ? Tu es en quelle version et de quoi tu parles concernant la 1.8 ?



  • Je parlais de java 8 mais j'ai marqué 1.8^^ Une erreur de saisie^^ (que j'ai corrigé du coup)
    Je suis en 1.7.10 et je code avec java 8 et donc je n'ai pas eu de problème jusqu'à présent, c'est juste un retour à @SpyMan ^^



  • Il fallait faire pareil mais pour IntelliJ Idea genre a la place de gradlew eclipse on met gradlew idea puis on ouvre IntelliJ et on selectionne en cliquant sur le bouton "open" le fichier <nomdumod>.ipr et fini!


Log in to reply