Erreur compilation



  • J'arrive pas a compiler aider moi svp   
    [size=smallest j'utilise cette version : jdk1.8.0_131]



  • Salut,
    un String dans un switch ? Original, qu'en penses-tu ?

    EDIT = Autant pour moi, c'est possible. En revanche, il faudra compiler ton projet avec Java 7 et non 6. Autre chose, je ne sais pas si ta méthode generate est appelée autre part, sinon il faudra penser à faire implémenter ta classe de IWorldGenerator.



  • @'Plaigon':

    Salut,
    un String dans un switch ? Original, qu'en penses-tu ?

    EDIT = Autant pour moi, c'est possible. En revanche, il faudra compiler ton projet avec Java 7 et non 6. Autre chose, je ne sais pas si ta méthode generate est appelée autre part, sinon il faudra penser à faire implémenter ta classe de IWorldGenerator.

    Salut j'ai essayer de mettre en Java 7 mais il me dise pareil


  • Administrateurs

    Salut;
    Il faut mettre ceci :

    sourceCompatibility = targetCompatibility = "1.7"
    compileJava {
       sourceCompatibility = targetCompatibility = "1.7"
    }
    

    dans le fichier build.gradle en dessous de archivesBaseName pour demander à compilateur d'utiliser Java 7.