Crash serveur Tconstruct



  • Il y a un problème avec Tconstruct apparament forge n'est pas a la bonne version.
    Il y aurait-il un moyen de contourner les reboot sachant que je vais devoir reconfigurer mes plugin …
    Voici le log :

    C:\Users\Utilisateur\Desktop\Machine>java -Xms512M -Xmx1024M -XX:PermSize=256m -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:+UseStringCache -jar cauldron-1.7.10-1.1207.01.198-server.jar
    Java HotSpot(TM) Client VM warning: ignoring option PermSize=256m; support was removed in 8.0
    Java HotSpot(TM) Client VM warning: ignoring option UseStringCache; support was removed in 8.0
    [09:34:32 INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLServerTweaker
    [09:34:32 INFO]: Using primary tweak class name cpw.mods.fml.common.launcher.FMLServerTweaker
    [09:34:32 INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLServerTweaker
    [09:34:32 INFO]: Forge Mod Loader version 7.10.25.1207 for Minecraft 1.7.10 loading
    [09:34:33 INFO]: Java is Java HotSpot(TM) Client VM, version 1.8.0_121, running on Windows 10:x86:10.0, installed at C:\Program Files (x86)\Java\jre1.8.0_121
    [09:34:33 INFO]: Loading tweaker net.minecraftforge.lex.legacyjavafixer.LegacyJavaFixer from legacyjavafixer-1.0.jar
    [09:34:33 INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
    [09:34:33 INFO]: Loading tweak class name net.minecraftforge.lex.legacyjavafixer.LegacyJavaFixer
    [09:34:33 INFO]: [LegacyJavaFixer] Tweaker: cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker@1da8e08
    [09:34:33 INFO]: [LegacyJavaFixer] Replacing tweaker cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker@1da8e08 with net.minecraftforge.lex.legacyjavafixer.LegacyJavaFixer$SortReplacement@800aaa
    [09:34:33 INFO]: [LegacyJavaFixer] Tweaker: FMLCorePlugin {[]}
    [09:34:33 INFO]: [LegacyJavaFixer] Tweaker: FMLForgePlugin {[]}
    [09:34:33 INFO]: [LegacyJavaFixer] Tweaker: cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker@1da8e08
    [09:34:33 INFO]: [LegacyJavaFixer] Replacing tweaker cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker@1da8e08 with net.minecraftforge.lex.legacyjavafixer.LegacyJavaFixer$SortReplacement@800aaa
    [09:34:33 INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker
    [09:34:33 INFO]: Calling tweak class net.minecraftforge.lex.legacyjavafixer.LegacyJavaFixer$SortReplacement
    [09:34:33 INFO]: [LegacyJavaFixer] Replacing sort
    [09:34:33 INFO]: [LegacyJavaFixer] Detected TerminalTweaker
    [09:34:33 INFO]: Calling tweak class net.minecraftforge.lex.legacyjavafixer.LegacyJavaFixer$SortReplacement
    [09:34:33 INFO]: Calling tweak class net.minecraftforge.lex.legacyjavafixer.LegacyJavaFixer
    [09:34:33 INFO]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
    [09:34:35 INFO]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
    [09:34:35 INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLDeobfTweaker
    [09:34:36 INFO]: Loading tweak class name cpw.mods.fml.common.launcher.TerminalTweaker
    [09:34:36 INFO]: Calling tweak class cpw.mods.fml.common.launcher.TerminalTweaker
    [09:34:36 INFO]: Launching wrapped minecraft {net.minecraft.server.MinecraftServer}
    [09:34:44 INFO]: Starting minecraft server version 1.7.10
    [09:34:44 INFO]: Attempting early MinecraftForge initialization
    [09:34:44 INFO]: MinecraftForge v10.13.0.1207 Initialized
    [09:34:44 INFO]: Replaced 182 ore recipies
    [09:34:44 INFO]: Completed early MinecraftForge initialization
    [09:34:44 INFO]: Searching C:\Users\Utilisateur\Desktop\Machine\mods for mods
    [09:34:45 INFO]: Mod debug is missing the required element 'name'. Substituting debug
    [09:34:45 WARN]: Mod debug is missing the required element 'version' and no fallback can be found. Substituting '1.0'.
    [09:34:46 INFO]: Forge Mod Loader has identified 17 mods to load
    [09:34:46 ERROR]: The mod TConstruct (Tinkers' Construct) requires mod versions [Forge@[10.13.3.1384,11.14)] to be available
    [09:34:46 ERROR]: Encountered an unexpected exception
    cpw.mods.fml.common.MissingModsException
           at cpw.mods.fml.common.Loader.sortModList(Loader.java:244) ~[Loader.class:git-Cauldron-MCPC-Plus-1.7.10-1.1207.01.198]
           at cpw.mods.fml.common.Loader.loadMods(Loader.java:472) ~[Loader.class:git-Cauldron-MCPC-Plus-1.7.10-1.1207.01.198]
           at cpw.mods.fml.server.FMLServerHandler.beginServerLoading(FMLServerHandler.java:87) ~[FMLServerHandler.class:git-Cauldron-MCPC-Plus-1.7.10-1.1207.01.198]
           at cpw.mods.fml.common.FMLCommonHandler.onServerStart(FMLCommonHandler.java:317) ~[FMLCommonHandler.class:git-Cauldron-MCPC-Plus-1.7.10-1.1207.01.198]
           at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:170) ~[lt.class:?]
           at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:620) [MinecraftServer.class:?]
           at java.lang.Thread.run(Unknown Source) [?:1.8.0_121]
    [09:34:46 ERROR]: This crash report has been saved to: C:\Users\Utilisateur\Desktop\Machine\.\crash-reports\crash-2017-02-04_09.34.46-server.txt
    [09:34:46 WARN]: Can't revert to frozen GameData state without freezing first.
    [09:34:46 INFO]: Applying holder lookups
    [09:34:46 INFO]: Holder lookups applied
    [09:34:46 INFO]: The state engine was in incorrect state CONSTRUCTING and forced into state SERVER_STOPPED. Errors may have been discarded.
    
    C:\Users\Utilisateur\Desktop\Machine>pause
    Appuyez sur une touche pour continuer…
    
    HELP PLZ !!!
    


  • Il suffit de mettre à jour Forge (donc Thermos/Cauldron selon ce que tu utilises) et ça devrait résoudre le problème.


  • Administrateurs

    En effet si tu as Cauldron faut passer sur Thermos (c'est le même principe, mods forge + plugins bukkit) qui est basé sur une version plus récente de Forge.
    https://github.com/CyberdyneCC/Thermos/releases

    Impossible de reload par contre et pas moyen de contourner cette limitation, elle est voulu car de nombreux mod réagissent très très mal avec le /reload.



  • @'robin4002':

    En effet si tu as Cauldron faut passer sur Thermos (c'est le même principe, mods forge + plugins bukkit) qui est basé sur une version plus récente de Forge.
    https://github.com/CyberdyneCC/Thermos/releases

    Impossible de reload par contre et pas moyen de contourner cette limitation, elle est voulu car de nombreux mod réagissent très très mal avec le /reload.

    Merci mais j'ai ma foi du mal comprendre comment fait pour changer le serv vers thermos …



  • Tu utilisais quoi avant ? Cauldron ? Si oui je pense qu'il suffit de changer le jar de cauldron par celui de thermos.



  • Oui, mais sa fait sa :

    C:\Users\Utilisateur\Desktop\Teste Termo>java -XX:PermSize=128m -XX:MaxPermSize=256m -Xmx2G -Xms1G -jar Thermos-1.7.10-1558-server.jar -o false
    Java HotSpot(TM) Client VM warning: ignoring option PermSize=128m; support was removed in 8.0
    Java HotSpot(TM) Client VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
    Error occurred during initialization of VM
    Could not reserve enough space for 2097152KB object heap
    
    C:\Users\Utilisateur\Desktop\Teste Termo>PAUSE
    Appuyez sur une touche pour continuer…
    

  • Administrateurs

    Manque de ram.



  • J'ai 4Go de ram sa suffit pas



  • En tout cas il arrive pas à allouer les 2go indiqués dans les arguments de lancement, vérifies que t'ait pas de programme consommateur de ram qui tourne.


  • Administrateurs

    java -version tu donnes quoi ?
    S'il n'y a pas 64 bits dans le résultat, tu as java 32 bits et dans ce cas la ram est limité à ~1,5go.



  • Java is Java HotSpot(TM) Client VM, version 1.8.0_121, running on Windows 10:x86:10.0, installed at C:\Program Files (x86)\Java\jre1.8.0_121
    

    C'est pas précisé 64bits donc c'est du 32bits, il faut que tu le désinstalles et que tu installes java 64bits.



  • Merci bcp ! Je vais essayé



  • J'avais effectivement le java 32 bit… a chaque fois que je jouer en solo il me disait :
    To can be installe java 64 bit (a peu près)
    J'y faisais pas gaffe j'ai installé de 64 bit et ça marche merci a tous !