Impossible de lancer le jeu



  • Bonjour,

    Quand je veux lancer Minecraft via Eclipse après avoir moddé, le jeu ne se lance pas et ça me met çe message :

    [16:55:50] [main/INFO] [FML]: Java is Java HotSpot(TM) 64-Bit Server VM, version 1.8.0_121, running on Windows 7:amd64:6.1, installed at C:\Program Files\Java\jdk1.8.0_121\jre
    [16:55:50] [main/INFO] [FML]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation
    [16:55:50] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
    [16:55:50] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker
    [16:55:50] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
    [16:55:50] [main/ERROR] [LaunchWrapper]: Unable to launch
    java.util.ConcurrentModificationException
    at java.util.ArrayList$Itr.checkForComodification(ArrayList.java:901) ~[?:1.8.0_121]
    at java.util.ArrayList$Itr.remove(ArrayList.java:865) ~[?:1.8.0_121]
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:117) [launchwrapper-1.9.jar:?]
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.9.jar:?]
    Java HotSpot(TM) 64-Bit Server VM warning: Using incremental CMS is deprecated and will likely be removed in a future release

    Merci de bien m'aider à résoudre mon probléme… 😢



  • Bizarre…est-ce que tu as d'autre mods en plus du tien dans ton envirronnement de dev ? Est le tien est un mod normal, pas un coremod (qui modifie directement les classes du jeu).

    EDIT : ah bah robin m'a apris quelque chose, je croyais que c'était que Cauldron qui faisait ça.


  • Administrateurs

    Salut,
    Les vieilles versions de forge ne fonctionnent pas avec Java 8.
    Il faut installer le mod legacy fixer : http://files.minecraftforge.net/LegacyJavaFixer/legacyjavafixer-1.0.jar ou de préférence mettre à jour forge.



  • @'robin4002':

    Salut,
    Les vieilles versions de forge ne fonctionnent pas avec Java 8.
    Il faut installer le mod legacy fixer : http://files.minecraftforge.net/LegacyJavaFixer/legacyjavafixer-1.0.jar ou de préférence mettre à jour forge.

    merci beaucoup !!  🙂