Erreur lancement



  • Bonjour,

    J'ai décidé de ré ouvrir mon ancien mod en 1.7.2 et malheureusement je remarque qu'il ne s'ouvre plus et je ne comprends pas pourquoi car il fonctionnait très bien avant.
    Voici le rapport du crash :
    :::
    java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_101]
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_101]
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_101]
    at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_101]
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:134) [launchwrapper-1.9.jar:?]
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.9.jar:?]
    Caused by: java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path
    at java.lang.ClassLoader.loadLibrary(Unknown Source) ~[?:1.8.0_101]
    at java.lang.Runtime.loadLibrary0(Unknown Source) ~[?:1.8.0_101]
    at java.lang.System.loadLibrary(Unknown Source) ~[?:1.8.0_101]
    at org.lwjgl.Sys$1.run(Sys.java:73) ~[lwjgl-2.9.0.jar:?]
    at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_101]
    at org.lwjgl.Sys.doLoadLibrary(Sys.java:66) ~[lwjgl-2.9.0.jar:?]
    at org.lwjgl.Sys.loadLibrary(Sys.java:95) ~[lwjgl-2.9.0.jar:?]
    at org.lwjgl.Sys.<clinit>(Sys.java:112) ~[lwjgl-2.9.0.jar:?]
    at net.minecraft.client.Minecraft.getSystemTime(Minecraft.java:2674) ~[Minecraft.class:?]
    at net.minecraft.client.main.Main.main(Main.java:40) ~[Main.class:?]
    … 6 more
    :::

    Il ne trouve pas la librairie lwgl pourtant j'ai bien un dossier native dans le dossier build contenant cette lib.</clinit>


  • Administrateurs

    Salut,
    Refais un setup.
    Si ce n'est toujours pas bon fait un setup en 1.7.10 et copie les sources.



  • Toujours pareil, du coup si je fais le setup en 1.7.10 le mod sera toujours fonctionnel en 1.7.2 ?



  • Oui, tu auras surement quelques petit trucs à changer mais rien de très difficile je pense.



  • @'AymericRed':

    Oui, tu auras surement quelques petit trucs à changer mais rien de très difficile je pense.

    Quelle peut en être la raison ? La 1.7.2 n'est plus supporté ?



  • Les sources de la 1.7.2 existent toujours, mais oui elle n'est olus supportée, c'est une vieille version, et il y a la 1.7.10 qui corrige plein de bugs, d'ailleurs, pourquoi ne passes-tu pas en 1.7.10, qui ne change rien au gameplay.