Problème particules blocs multi-textures



  • [font=Ubuntu, sans-serifJe suis sur Eclipse avec forge-1.8.9-11.15.1.1722-mdk .]

    [font=Ubuntu, sans-serifBonjour, j'ai créé plusieurs blocs multi-textures, tout est fonctionnel, sauf une chose:]

    Les particules n'ont pas de textures.
    Pourtant, sur mes blocs à une seule texture, les particules fonctionnent.

    Un exemple de json avec le chemin des dossiers et du fichier:

    models->block->date_palm_block

    {
        "parent": "block/cube",
        "textures": {
            "up": "modegypte:blocks/Block_date_palm_top",
            "down": "modegypte:blocks/Block_date_palm_top",
            "north": "modegypte:blocks/block_date_palm",
            "south": "modegypte:blocks/block_date_palm",
            "west": "modegypte:blocks/block_date_palm",
            "east": "modegypte:blocks/block_date_palm"
        }
    }
    

    Comment attribuer une des textures du bloc aux particules quand le bloc est cassé?
    Merci.


  • Moddeurs confirmés Rédacteurs Administrateurs

    Salut,
    Comme ça :

    {
    "parent": "block/cube",
    "textures": {
    "up": "modegypte:blocks/Block_date_palm_top",
    "down": "modegypte:blocks/Block_date_palm_top",
    "north": "modegypte:blocks/block_date_palm",
    "south": "modegypte:blocks/block_date_palm",
    "west": "modegypte:blocks/block_date_palm",
    "east": "modegypte:blocks/block_date_palm",
    "particle":"modegypte:blocks/block_date_palm"
    }
    }
    


  • Ah merci, j'avais essayé cette ligne au dessus de "up" et ça n'avait pas fonctionné.
    Résolu.


Log in to reply