Installateur qui crash au lancement



  • Bonjour, j'utilise l'installateur de MFF depuis maintenant un bon moment sur mon serveur et jusqu'ici tout va à peu près bien. Le problème c'est qu'un nouveau joueur n'arrive pas à lancer le launcher, il crash à chaque fois. Je précise que tous les autres n'ont aucun problème.

    Voici le crash :

    –-- Minecraft Crash Report ----
    // Oops.
    
    Time: 08/05/16 15:44
    Description: Registering texture
    
    net.minecraft.client.renderer.StitcherException: Unable to fit: rafithekiller:carte (31) - size: 256x256 - Maybe try a lowerresolution texturepack?
       at net.minecraft.client.renderer.texture.Stitcher.func_94305_f(Stitcher.java:74)
       at net.minecraft.client.renderer.texture.TextureMap.func_110571_b(TextureMap.java:242)
       at net.minecraft.client.renderer.texture.TextureMap.func_110551_a(TextureMap.java:90)
       at net.minecraft.client.renderer.texture.TextureManager.func_110579_a(SourceFile:72)
       at net.minecraft.client.renderer.texture.TextureManager.func_110580_a(SourceFile:61)
       at net.minecraft.client.renderer.texture.TextureManager.func_130088_a(SourceFile:52)
       at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:524)
       at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:815)
       at net.minecraft.client.main.Main.main(SourceFile:103)
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
       at java.lang.reflect.Method.invoke(Unknown Source)
       at net.minecraft.launchwrapper.Launch.launch(Launch.java:134)
       at net.minecraft.launchwrapper.Launch.main(Launch.java:2Lub
       at fr.minecraftforgefrance.updater.Updater.runMinecraft(Updater.java:133)
       at fr.minecraftforgefrance.updater.Updater.<init>(Updater.java:96)
       at fr.minecraftforgefrance.updater.Updater.main(Updater.java:35)
    
    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------
    
    -- Head --
    Stacktrace:
       at net.minecraft.client.renderer.texture.Stitcher.func_94305_f(Stitcher.java:74)
       at net.minecraft.client.renderer.texture.TextureMap.func_110571_b(TextureMap.java:242)
       at net.minecraft.client.renderer.texture.TextureMap.func_110551_a(TextureMap.java:90)
    
    -- Resource location being registered --
    Details:
       Resource location: minecraft:textures/atlas/items.png
       Texture object class: net.minecraft.client.renderer.texture.TextureMap
    Stacktrace:
       at net.minecraft.client.renderer.texture.TextureManager.func_110579_a(SourceFile:72)
       at net.minecraft.client.renderer.texture.TextureManager.func_110580_a(SourceFile:61)
       at net.minecraft.client.renderer.texture.TextureManager.func_130088_a(SourceFile:52)
       at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:524)
    
    -- Initialization --
    Details:
    Stacktrace:
       at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:815)
       at net.minecraft.client.main.Main.main(SourceFile:103)
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
       at java.lang.reflect.Method.invoke(Unknown Source)
       at net.minecraft.launchwrapper.Launch.launch(Launch.java:134)
       at net.minecraft.launchwrapper.Launch.main(Launch.java:2Lub
       at fr.minecraftforgefrance.updater.Updater.runMinecraft(Updater.java:133)
       at fr.minecraftforgefrance.updater.Updater.<init>(Updater.java:96)
       at fr.minecraftforgefrance.updater.Updater.main(Updater.java:35)
    
    -- System Details --
    Details:
       Minecraft Version: 1.7.2
       Operating System: Windows 7 (x86) version 6.1
       Java Version: 1.7.0_71, Oracle Corporation
       Java VM Version: Java HotSpot™ Client VM (mixed mode), Oracle Corporation
       Memory: 139336424 bytes (132 MB) / 356839424 bytes (340 MB) up to 1060372480 bytes (1011 MB)
       JVM Flags: 6 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx1G -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M
       AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
       IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
       FML: MCP v9.03 FML v7.2.217.1161 Minecraft Forge 10.12.2.1161 13 mods loaded, 13 mods active
       mcp{9.03} [Minecraft Coder Pack] (minecraft.jar) Unloaded->Constructed->Pre-initialized
       FML{7.2.217.1161} [Forge Mod Loader] (forge-1.7.2-10.12.2.1161-mc172.jar) Unloaded->Constructed->Pre-initialized
       Forge{10.12.2.1161} [Minecraft Forge] (forge-1.7.2-10.12.2.1161-mc172.jar) Unloaded->Constructed->Pre-initialized
       CustomSpawner{3.2.0.dev.R3} [DrZhark's CustomSpawner] (CustomMobSpawner 3.2.0-DEV-R3.zip) Unloaded->Constructed->Pre-initialized
       customnpcs{1.7.2-2} [CustomNpcs] (CustomNPCs_1.7.2.jar) Unloaded->Constructed->Pre-initialized
       MoCreatures{6.2.0.dev.R3} [DrZhark's Mo'Creatures Mod] (DrZharks MoCreatures Mod v6.2.0-DEV-R3.zip) Unloaded->Constructed->Pre-initialized
       ftfloocraft{1.7.10-0.3.1} [Floocraft] (Floocraft-1.7.10-0.3.1.jar) Unloaded->Constructed->Pre-initialized
       MineChess{1.3.7} [MineChess] (MineChess-Mod-1.7.2.zip) Unloaded->Constructed->Pre-initialized
       halloween{1.0.0} [Halloween] (ModHalloween.jar) Unloaded->Constructed->Pre-initialized
       ordreduphenix{1.0.0} [Ordre du Phenix] (ordreduphenix-1.0.jar) Unloaded->Constructed->Pre-initialized
       pottermod{0.2} [PotterMod] (Pottermod-0.2.jar) Unloaded->Constructed->Pre-initialized
       quidcraft{0.1} [Quidcraft] (Quidcraft-0.1(1.7.2).jar) Unloaded->Constructed->Pre-initialized
       witchery{0.20.4} [Witchery] (witchery-1.7.2-0.20.4.jar) Unloaded->Constructed->Pre-initialized
       Launched Version: LOrdreduPhenix
       LWJGL: 2.9.0
       OpenGL: AMD Mobility Radeon HD 5000 Series GL version 4.5.13399 Compatibility Profile Context 15.200.1062.1004, ATI Technologies Inc.
       Is Modded: Definitely; Client brand changed to 'fml,forge'
       Type: Client (map_client.txt)
       Resource Packs: []
       Current Language: English (US)
       Profiler Position: N/A (disabled)
       Vec3 Pool Size: ~~ERROR~~ NullPointerException: null
       Anisotropic Filtering: Off (1)
    

    Je ne m'y connais pas plus que ça en lecture de crash-report mais j'avais pensé à un PC pas assez performant peut être?
    En tout cas merci beaucoup pour votre aide :)</init></init>



  • Ta texture pour un bloc ou item est en 256x256, c'est un peu beaucoup quand même

    Unable to fit: rafithekiller:carte (31) - size: 256x256 - Maybe try a lowerresolution texturepack?
    

  • Moddeurs confirmés Rédacteurs Administrateurs

    En effet il y a une texture trop grosse pour son pc.

    Mettre à jour le pilote graphique peut régler le problème.



  • Salut, le problème s'est résolu de lui même, le joueur après avoir attendu un moment (sans rien faire) a vu son launcher se lancer. Autre problème néanmoins j'ai constaté qu'il était impossible de lancer le launcher Minecraft avec Java8, il faut pour cela avoir java7.. je ne sais pas si je suis passé à côté de quelque chose, que la réponse a déjà été donnée ou quoi que ce soit mais il y a il une alternative à ce problème? L'installation systématique de la version précédente de java est en effet assez pénible pour les nouveaux joueurs alors si il y a moyen de régler cela, je suis preneur!

    Merci beaucoup! 🙂

    EDIT : Je précise que j'utilise une ancienne version de Forge, une version 1.7.2, il me semble que le problème vient de là..


  • Moddeurs confirmés Rédacteurs Administrateurs

    https://www.minecraftforgefrance.fr/showthread.php?tid=10
    "Si vous utilisez une ancienne version de Forge et Java 8 update 20 (ou plus récent), vous allez rencontrez l'erreur java.lang.ConcurrentModificationException : mettez à jour Forge vers le build 1217 ou plus récent, ou installer ce mod correctif : http://files.minecraftforge.net/LegacyJavaFixer/legacyjavafixer-1.0.jar"



  • Merci! 🙂


Log in to reply