Impossible de se connecter sur le serveur FTB (Java?)



  • Salut à tous, j'ai un petit problème depuis hier soir,
    Quand j'essaye de me connecter sur mon serveur Feed The Beast, le "logging in" s'affiche pendant environ dix secondes puis cela m'affiche "Internal exception: java.net.SocketTimeoutException: Read timed out".
    J'ai arrêté, démarré, redémarré le serveur déjà plusieurs fois ainsi que mon ordi mais rien n'y fait, je n'arrive toujours pas à me connecter. 😕
    J'héberge mon serveur chez OmgServ, j'ai une offre Premium Illimitée, le serveur est sous Feed The Beast avec le modpack Ultimate en version 1.4.7
    Le nombre de caractères etant limités sur ce message, je mettrais les logs sur un site d'upload de fichiers texte:

    Voici l'intégralité du contenu de la console FTB:

    Crash Report Console FTB

    Ainsi que le contenu de la contenu de la console du serveur:

    Crash Report Console Serveur

    Et voilà enfin le crash report:

    Crash Report Minecraft

    Voilà, j'espère avoir fourni assez d'informations et si vous avez besoin de plus , n'hésitez pas à demander 🙂


  • Administrateurs

    Salut,
    Tu reçois l'erreur read timed out car le serveur crash quand tu te connecte dessus (donc il ne répond plus au client).
    L'erreur vient du mod ic2, il y a un NPE dans le code :
    java.lang.RuntimeException: java.lang.NullPointerException
    at ic2.core.IC2.onLivingSpecialSpawn(IC2.java:2270)
    Essayes avec une autre version d'IC2.



  • Merci, cependant comme je l'ai dit je joue sur Feed The Beast Ultimate qui est un modpack et je ne sais pas si il est possible ni comment changer d'IC2, ca se fait direct par le serveur FTP ou il y a autre chose à faire?
    Pourtant hier tout allais bien, et à un moment je me suis déconnecté et depuis ça crash, le problème pourrait-il venir des machines d'IC2? Car avant que cela ne crash, j'etais justement en train de retapper tout le système d'alimentation de ma base. 😕
    Il est arrivé rarement aussi que je puisse me connecter mais seul une dizaine de chunks autour de moi étaient loadés et cela crashais au bout de 10 secondes.


  • Administrateurs

    C'est sur le tick d'une entity que ça crash donc non aucun rapport avec les machines.



  • Ce qui est etrange c'est que le mod IndustrialCraft2 n'apporte aucune entitée, il y a juste des blocs 😕


  • Administrateurs

    En effet elle n'ajoute pas d'entité mais elle utilise l'event onLivingSpecialSpawn. Et c'est dans cette event qu'ic2 cause un NPE.



  • Problème réglé, un membre du forum officiel d'IC2 m'a donné un patch a rajouter aux mods du serveur pour les bugs d'entités tels que celui-ci.
    Au cas ou quelqu'un d'autre aurait le même problème que moi, je met ci-dessous le lien de mon topic sur le forum IC2:
    http://forum.industrial-craft.net/index.php?page=Thread&threadID=11995