• Holé, Holé !

    Je vien aujourd’hui pour vous demandez votre aide puisque je commence à être tanné …
    Depuis plus de 1h30, je cherche, je test, je cherche pourquoi mon seul item dans mon mod n’affiche pas sa texture et son nom.

    Alors voilà:

    La classe principale (concernant mon item)

    cg = new CG().setUnlocalizedName("cg").setTextureName(MODID + ":c_g").setCreativeTab(palladiumCreativeTabs);
    
    GameRegistry.registerItem(cg, "item_cg");
    
    public static Item cg;
    
    

    La classe de l’item:

    package palladiumcraft.common;
    
    import net.minecraft.client.renderer.texture.IIconRegister;
    import net.minecraft.item.Item;
    
    public class CG extends Item {
    
    }
    

    Finalement, les chemins d’accès à la texture:
    C:\Users\antoine\Desktop\Forge 1.7.10\src\main\resources\assets\modpalladium\textures\items\c_g.png ( la texture n’est pas c_g.png mais en format png … )

    Et le nom:
    C:\Users\antoine\Desktop\Forge 1.7.10\src\main\resources\assets\modpalladium\lang\en_US.lang
    Dans le fichier LANG:
    item.cg.name=Gem Contractée

    Voilà tous se que j’ai à propos de l’item en question qui me souleeeeeeee !!! 😞

    Merci, j’espère que vous allez trouver l’erreur car je ne la trouve pas …
    Si vous voulez d’ample information dites-moi le !

    Cordialement, infectiion21

  • Administrateurs Rédacteurs Moddeurs confirmés

    Vérifie que les fichiers sont visibles sur eclipse quand tu déroule src/main/resources
    Si non, clic sur le dossier puis appuies sur f5


  • @‘robin4002’:

    Vérifie que les fichiers sont visibles sur eclipse quand tu déroule src/main/resources
    Si non, clic sur le dossier puis appuies sur f5

    C’est peut-être tout bête mais regarde si ton jeu est bien en anglais dans la même lang que ton fichier lang ^^


  • Merci Robin … Enfaite, dans mon fichier --) [size=x-smallC:\Users\antoine\Desktop\Forge 1.7.10\src\main\resources\assets\modpalladium\textures\items\c_g.png]
    [size=x-smallLa texture à apparu mais quand j’allais dans src/main/ressources via éclipse il n’était pas là …]
    [size=x-smallMême chose pour le fichier lang :)]