Problème de lancement



  • Bonjour !
    J'ai eu pour noël un nouveau PC et j'ai installé Forge en 1.7.2 sans aucun problème sauf que quand je lance mon minecraft avec le profil Forge, une fois que le chargement du launcher est terminée, je n'ai plus rien.

    J'ai installé Java 7 en 64 Bits et en 32 Bits mais le problème n'est toujours pas résolu.

    Quelqu'un aurait une solution s'il vous plait ?

    Merci d'avance.

    PS : Je vais utiliser Forge pour jouer avec les Shaders et quelques mods pour le PvP.


  • Modérateurs

    Premièrement, laisse le launcher ouvert: sur le launcher, sélectionne ton profil Forge et fais "Edit Profile". Ensuite coche "Launcher Visibility" et choisis "Keep the launcher open".

    Relance ton jeu et donne nous le contenu du crash (avec des balises spoiler, merci)

    Ensuite évite d'installer une version 64bits et 32bits d'un même logiciel en même temps. Surtout que Java 32 bits est peu performant sur un ordinateur 64bits.

    Pour vérifier si ton ordinateur est en 32 ou 64bits: http://minecraftforgefrance.fr/showthread.php?tid=557#windows



  • Salut moi c'est la même chose  
    voici les logs :
    http://image.noelshack.com/fichiers/2014/52/1419784625-logs-minecraft.png

    Merci de me donné une réponse au plus vite ! 😊


  • Administrateurs

    Suffit de lire la FAQ : http://minecraftforgefrance.fr/showthread.php?tid=10&pid=17469#pid17469

    Si vous utilisez une ancienne version de Forge et Java 8 update 20 (ou plus récent), vous allez rencontrez l'erreur java.lang.ConcurrentModificationException : mettez à jour Forge vers le build 1217 ou plus récent, ou installer ce mod correctif : http://files.minecraftforge.net/LegacyJavaFixer/legacyjavafixer-1.0.jar



  • @'jglrxavpok':

    Premièrement, laisse le launcher ouvert: sur le launcher, sélectionne ton profil Forge et fais "Edit Profile". Ensuite coche "Launcher Visibility" et choisis "Keep the launcher open".

    Relance ton jeu et donne nous le contenu du crash (avec des balises spoiler, merci)

    Ensuite évite d'installer une version 64bits et 32bits d'un même logiciel en même temps. Surtout que Java 32 bits est peu performant sur un ordinateur 64bits.

    Pour vérifier si ton ordinateur est en 32 ou 64bits: http://minecraftforgefrance.fr/showthread.php?tid=557#windows

    Rebonjour.

    Voici mon " Game Output "
    [19:26:28] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLTweaker
    [19:26:28] [main/INFO] [LaunchWrapper]: Using primary tweak class name cpw.mods.fml.common.launcher.FMLTweaker
    [19:26:28] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLTweaker
    [19:26:28] [main/INFO] [FML]: Forge Mod Loader version 7.2.217.1147 for Minecraft 1.7.2 loading
    [19:26:28] [main/INFO] [FML]: Java is Java HotSpot(TM) 64-Bit Server VM, version 1.8.0_25, running on Windows 7:amd64:6.1, installed at C:\Program Files (x86)\Minecraft\runtime\jre-x64\1.8.0_25
    [19:26:28] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
    [19:26:28] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker
    [19:26:28] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
    [19:26:28] [main/ERROR] [LaunchWrapper]: Unable to launch
    java.util.ConcurrentModificationException
    at java.util.ArrayList$Itr.checkForComodification(ArrayList.java:901) ~[?:1.8.0_25]
    at java.util.ArrayList$Itr.remove(ArrayList.java:865) ~[?:1.8.0_25]
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:117) [launchwrapper-1.9.jar:?]
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.9.jar:?]
    Java HotSpot(TM) 64-Bit Server VM warning: Using incremental CMS is deprecated and will likely be removed in a future release

    Je tiens a signaler que je dispose de Java 7 Update 71 et de Java 8 Update 25 et que j'ai absolument besoin de la version 1.7.2 de forge car je vais sur des serveurs qui sont encore en 1.7.2

    Merci d'avance pour votre réponse


  • Administrateurs

    La solution est deux messages haut dessus :
    @'robin4002':

    Suffit de lire la FAQ : http://minecraftforgefrance.fr/showthread.php?tid=10&pid=17469#pid17469

    Si vous utilisez une ancienne version de Forge et Java 8 update 20 (ou plus récent), vous allez rencontrez l'erreur java.lang.ConcurrentModificationException : mettez à jour Forge vers le build 1217 ou plus récent, ou installer ce mod correctif : http://files.minecraftforge.net/LegacyJavaFixer/legacyjavafixer-1.0.jar



  • @'robin4002':

    La solution est deux messages haut dessus :

    @'robin4002':

    Suffit de lire la FAQ : http://minecraftforgefrance.fr/showthread.php?tid=10&pid=17469#pid17469

    Si vous utilisez une ancienne version de Forge et Java 8 update 20 (ou plus récent), vous allez rencontrez l'erreur java.lang.ConcurrentModificationException : mettez à jour Forge vers le build 1217 ou plus récent, ou installer ce mod correctif : http://files.minecraftforge.net/LegacyJavaFixer/legacyjavafixer-1.0.jar

    J'ai déjà essayer d'installer le mod correctif mais quand je le lance rien ne se passe, est-ce normal ou pas ?
    Et la version 1.7.2 de forge n'a pas de bulid au dessus de 1217.
    La dernier version est la 1147.


  • Administrateurs

    L'installation de ce mod devrait pourtant corriger le problème, renvoie les logs après l'installation du mods.



  • @'robin4002':

    L'installation de ce mod devrait pourtant corriger le problème, renvoie les logs après l'installation du mods.

    [21:29:48] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLTweaker
    [21:29:48] [main/INFO] [LaunchWrapper]: Using primary tweak class name cpw.mods.fml.common.launcher.FMLTweaker
    [21:29:48] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLTweaker
    [21:29:48] [main/INFO] [FML]: Forge Mod Loader version 7.2.217.1147 for Minecraft 1.7.2 loading
    [21:29:48] [main/INFO] [FML]: Java is Java HotSpot(TM) 64-Bit Server VM, version 1.8.0_25, running on Windows 7:amd64:6.1, installed at C:\Program Files (x86)\Minecraft\runtime\jre-x64\1.8.0_25
    [21:29:48] [main/INFO] [FML]: Loading tweaker optifine.OptiFineForgeTweaker from OptiFine_1.7.10_HD_U_B4.jar
    [21:29:48] [main/ERROR] [FML]: The coremod api.player.forge.PlayerAPIPlugin is requesting minecraft version 1.7.10 and minecraft is 1.7.2. It will be ignored.
    [21:29:48] [main/INFO] [FML]: Loading tweaker shadersmodcore.loading.SMCTweaker from ShadersModCore-v2.3.28-mc1.7.10-f.jar
    [21:29:48] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
    [21:29:48] [main/INFO] [LaunchWrapper]: Loading tweak class name optifine.OptiFineForgeTweaker
    [21:29:48] [main/INFO] [LaunchWrapper]: Loading tweak class name shadersmodcore.loading.SMCTweaker
    [21:29:48] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker
    [21:29:48] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
    [21:29:48] [main/ERROR] [LaunchWrapper]: Unable to launch
    java.util.ConcurrentModificationException
    at java.util.ArrayList$Itr.checkForComodification(ArrayList.java:901) ~[?:1.8.0_25]
    at java.util.ArrayList$Itr.remove(ArrayList.java:865) ~[?:1.8.0_25]
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:117) [launchwrapper-1.9.jar:?]
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.9.jar:?]
    Java HotSpot(TM) 64-Bit Server VM warning: Using incremental CMS is deprecated and will likely be removed in a future release


  • Administrateurs

    Deux problèmes :
    1 - tu as des mods 1.7.10 en 1.7.2 (optifine, shader mod) qui sont des cores mods, ils ne fonctionnent pas en 1.7.2, il faut prendre la version pour 1.7.2
    2 - le mod correcteur n'est pas présent, en tout cas il n'est pas chargé …



  • @'robin4002':

    Deux problèmes :
    1 - tu as des mods 1.7.10 en 1.7.2 (optifine, shader mod) qui sont des cores mods, ils ne fonctionnent pas en 1.7.2, il faut prendre la version pour 1.7.2
    2 - le mod correcteur n'est pas présent, en tout cas il n'est pas chargé …

    J'ai enlevé les mods pour tester et sa se lance toujours pas.
    Quand je lance le legacyjavafixer -1.0, il ne se passe rien du tout.


  • Administrateurs

    legacyjavafixer n'est pas un exécutable, il faut le placer dans le dossier mods et voila.



  • @'robin4002':

    legacyjavafixer n'est pas un exécutable, il faut le placer dans le dossier mods et voila.

    Ah d'accord, Sa marche enfin !
    Merci pour ton aide.