Lancement de mon mod Minecraft impossible



  • Bonjour,
    J'ai un problème sur mon mod.
    Lorsque j'essaye de lancer mon mod pour pouvoir le testé, j'ai ce message d'erreur :

    Java HotSpot(TM) 64-Bit Server VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
    [13:00:31] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLTweaker
    [13:00:31] [main/INFO] [LaunchWrapper]: Using primary tweak class name cpw.mods.fml.common.launcher.FMLTweaker
    [13:00:31] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLTweaker
    [13:00:31] [main/INFO] [FML]: Forge Mod Loader version 7.2.211.1121 for Minecraft 1.7.2 loading
    [13:00:31] [main/INFO] [FML]: Java is Java HotSpot(TM) 64-Bit Server VM, version 1.8.0_05, running on Mac OS X:x86_64:10.8.5, installed at /Library/Java/JavaVirtualMachines/jdk1.8.0_05.jdk/Contents/Home/jre
    [13:00:31] [main/INFO] [FML]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation
    [13:00:31] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
    [13:00:31] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker
    [13:00:31] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
    [13:00:31] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
    [13:00:31] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
    [13:00:31] [main/ERROR] [FML]: The binary patch set is missing. Either you are in a development environment, or things are not going to work!
    [13:00:32] [main/ERROR] [FML]: The minecraft jar file:/Users/Thomas/.gradle/caches/minecraft/net/minecraftforge/forge/1.7.2-10.12.2.1121/forgeSrc-1.7.2-10.12.2.1121.jar!/net/minecraft/client/ClientBrandRetriever.class appears to be corrupt! There has been CRITICAL TAMPERING WITH MINECRAFT, it is highly unlikely minecraft will work! STOP NOW, get a clean copy and try again!
    [13:00:32] [main/ERROR] [FML]: FML has been ordered to ignore the invalid or missing minecraft certificate. This is very likely to cause a problem!
    [13:00:32] [main/ERROR] [FML]: Technical information: ClientBrandRetriever was at jar:file:/Users/Thomas/.gradle/caches/minecraft/net/minecraftforge/forge/1.7.2-10.12.2.1121/forgeSrc-1.7.2-10.12.2.1121.jar!/net/minecraft/client/ClientBrandRetriever.class, there were 0 certificates for it
    [13:00:32] [main/ERROR] [FML]: FML appears to be missing any signature data. This is not a good thing
    [13:00:32] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
    [13:00:32] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLDeobfTweaker
    [13:00:33] [main/INFO] [LaunchWrapper]: Launching wrapped minecraft {net.minecraft.client.main.Main}
    [13:00:33] [main/ERROR] [LaunchWrapper]: Unable to launch
    java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_05]
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_05]
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_05]
    at java.lang.reflect.Method.invoke(Method.java:483) ~[?:1.8.0_05]
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:134) [launchwrapper-1.9.jar:?]
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.9.jar:?]
    Caused by: java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1857) ~[?:1.8.0_05]
    at java.lang.Runtime.loadLibrary0(Runtime.java:870) ~[?:1.8.0_05]
    at java.lang.System.loadLibrary(System.java:1119) ~[?:1.8.0_05]
    at org.lwjgl.Sys$1.run(Sys.java:73) ~[lwjgl-2.9.1-nightly-20131017.jar:?]
    at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_05]
    at org.lwjgl.Sys.doLoadLibrary(Sys.java:66) ~[lwjgl-2.9.1-nightly-20131017.jar:?]
    at org.lwjgl.Sys.loadLibrary(Sys.java:95) ~[lwjgl-2.9.1-nightly-20131017.jar:?]
    at org.lwjgl.Sys.<clinit>(Sys.java:112) ~[lwjgl-2.9.1-nightly-20131017.jar:?]
    at net.minecraft.client.Minecraft.getSystemTime(Minecraft.java:2674) ~[Minecraft.class:?]
    at net.minecraft.client.main.Main.main(Main.java:40) ~[Main.class:?]
    … 6 more
    

    Pouvez-vous m'aidez svp ?
    Merci d'avance.

    PS : J'utilise la version forge-1.7.2-10.10.12.2.1121-src</clinit>


  • Administrateurs

    lwjgl n'est pas dans ton classpath, il semblerai que toutes les build 1.7.2 de forge souffre de ce problème, il faut soit l'ajouter manuellement soit passer en 1.7.10.



  • Merci beaucoup !
    Mon problème est résolu 😄



  • @'robin4002':

    lwjgl n'est pas dans ton classpath, il semblerai que toutes les build 1.7.2 de forge souffre de ce problème, il faut soit l'ajouter manuellement soit passer en 1.7.10.

    Salut,
    Si l'on veut l' ajouter manuellement où peut on le trouver ?


  • Administrateurs



  • @'robin4002':

    Sur ironcraft dermenslof a donné cette solution : http://forum.ironcraft.fr/index.php/topic/5802-problème-de-lancement-jeu/#entry74505

    Je n'ai pas de dossier native dans le dossier Minecraft/build


  • Administrateurs



  • @'robin4002':

    http://dl.mcnanotech.fr/robin4002/natives.zip

    Merci où dois-je mettre ce dossier ?


  • Administrateurs

    extrait dans le dossier buid.