Problème lancement serveur



  • AHHH ! Se 1.7.10 et mes erreurs …

    Donc, j'ai recompiler mon mods, je l'ai en .rar et le r'ajoute dans mon ftp pour lancer mon serveur avec mon mods dessus. Malheureusement, il ne marche pas et fait cette erreur:

    ​08.11 01:52:06 [Multicraft] Not restarting crashed server.
    
    08.11 01:52:06 [Multicraft] Server stopped
    08.11 01:52:06 [Multicraft] Server shut down
    08.11 01:52:05 [Server] INFO at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.7.0_67]
    08.11 01:52:05 [Server] INFO at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) ~[?:1.7.0_67]
    08.11 01:52:05 [Server] INFO at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.7.0_67]
    08.11 01:52:05 [Server] INFO at cpw.mods.fml.common.FMLModContainer.constructMod(FMLModContainer.java:492) ~[FMLModContainer.class:git-Cauldron-MCPC-Plus-1.7.10-1.1207.01.198]
    08.11 01:52:05 [Server] INFO at cpw.mods.fml.common.ProxyInjector.inject(ProxyInjector.java:76) ~[ProxyInjector.class:git-Cauldron-MCPC-Plus-1.7.10-1.1207.01.198]
    
    08.11 01:52:05 [Server] INFO cpw.mods.fml.common.LoaderException: java.lang.ClassNotFoundException: palladiumcraft.Proxy.CommonProxy
    08.11 01:52:05 [Server] ERROR Caught exception from modpalladium
    08.11 01:52:05 [Server] ERROR The following problems were captured during this phase
    08.11 01:52:05 [Server] INFO modpalladium{V1.0.0} [Mod Palladium] (modpalladium-1.0.jar) Unloaded->Errored
    

    Donc ducoup, je regarde cette erreur et voit:

    08.11 01:52:05 [Server] INFO cpw.mods.fml.common.LoaderException: java.lang.ClassNotFoundException: palladiumcraft.Proxy.CommonProxy
    

    Alors je vais dans ma classe palladiumcraft.Proxy.CommonProxy
    Ma classe:

    ​package palladiumcraft.proxy;
    
    public class CommonProxy {
    public void registerRender() {
    System.out.println("méthode côté serveur");
    }
    }
    

    Donc ducoup je me dit: Mais qu'elle est le problème encore de cette version de minecraft qui me cause trop de problème .. 
    Alors je suis ici aujourd'hui pour vous demander votre aide …:)

    Merci,
    Cordialement, infectiion21



  • Tente de virer le système outprint et retest pour voir



  • Tu devrais déjà l avoir en .jar et non en  .rar


  • Administrateurs

    java.lang.ClassNotFoundException: palladiumcraft.Proxy.CommonProxy
    
    package palladiumcraft.proxy;
    
    public class CommonProxy {
    

    Tu as l'erreur sous les yeux, c'est un problème de majuscule au P de proxy qui ne devrait pas y être.



  • Et Robin comment je fait pour plus qu'il y soit dans l'erreur o0 ?



  • @'Infectiion21':

    Et Robin comment je fait pour plus qu'il y soit dans l'erreur o0 ?

    bah le nom du package où se trouve ta classe commonProxy, doit être le même que celui dans ta classe common
    exemple :
    sur l'image le nom en rouge est le même (ou devrait pour toi) être le même que celui en bleu : toi attention a tes majuscules pour le p

    Toute façon si tu as une telle erreur essaie de les régler avec ce que te propose eclipse et si ça ne te va pas : 
    ctrl + z  😄 😄

    lien de l'image : http://hpics.li/c995bec


  • Administrateurs

    Dans ta classe principale, au niveau du @SidedProxy corrige le chemin vers le proxy serveur, c'est là-bas que tu t'es planté …



  • Parfait je vais essayer sa 🙂 merci



  • @'robin4002':

    Dans ta classe principale, au niveau du @SidedProxy corrige le chemin vers le proxy serveur, c'est là-bas que tu t'es planté …

    a ok je n'y avais pas pensé



  • Oui, je pense à 100% que c'est un problème de majuscules/minuscules.
    Lorsque tu test ton mod via Eclipse il considère les majuscules/minuscules pareil (je crois que c'est à cause de Windows si tu l'as), donc faut juste renommé et sa marchera dans ton serveur.