Impossibilité de compiler flan's mod



  • Bonjour ! Alors cette fois-ci, mon problème concerne flan's mod.  Je suis dans l'impossibilité de le compiler pour une raison que j'ignore

    Les logs de la console

    ​****************************
    
     Powered By MCP:
     http://mcp.ocean-labs.de/
     Searge, ProfMobius, Fesh0r,
     R4wk, ZeuX, IngisKahn, bspkrs
     MCP Data version : unknown
    ****************************
    :compileApiJava UP-TO-DATE
    :processApiResources UP-TO-DATE
    :apiClasses UP-TO-DATE
    : sourceMainJava UP-TO-DATE
    :compileJava
    warning: [options] bootstrap class path not set in conjunction with -source 1.6
    C:\Users\Brice\Desktop\dossier minecraft\minecraft\MCP Forge\build\sources\java\
    com\flansmod\client\model\mw\ModelMTAR.java:1: error: illegal character: \187
    ´╗┐//This File was created with the Minecraft-SMP Modelling Toolbox 2.0.0.0
     ^
    C:\Users\Brice\Desktop\dossier minecraft\minecraft\MCP Forge\build\sources\java\
    com\flansmod\client\model\mw\ModelMTAR.java:1: error: illegal character: \191
    ´╗┐//This File was created with the Minecraft-SMP Modelling Toolbox 2.0.0.0
      ^
    C:\Users\Brice\Desktop\dossier minecraft\minecraft\MCP Forge\build\sources\java\
    com\flansmod\client\model\mw\ModelSPAS.java:1: error: illegal character: \187
    ´╗┐//This File was created with the Minecraft-SMP Modelling Toolbox 2.0.0.0
     ^
    C:\Users\Brice\Desktop\dossier minecraft\minecraft\MCP Forge\build\sources\java\
    com\flansmod\client\model\mw\ModelSPAS.java:1: error: illegal character: \191
    ´╗┐//This File was created with the Minecraft-SMP Modelling Toolbox 2.0.0.0
      ^
    4 errors
    1 warning
    :compileJava FAILED
    
    FAILURE: Build failed with an exception.
    
    * What went wrong:
    Execution failed for task ':compileJava'.
    > Compilation failed; see the compiler error output for details.
    
    * Try:
    Run with –stacktrace option to get the stack trace. Run with --info or --debug
    option to get more log output.
    
    BUILD FAILED
    

    Merci d'avance !


  • Administrateurs

    Il y a un problème d'encodage, si tu avais mit ta workspace en UTF8 comme montrer dans le tutoriel sur l'installation de l'espace de travail tu n'aurai pas eu ce problème.



  • Mon encodage est en UTF8 pourtant…


  • Administrateurs

    Étrange, sinon supprime les caractères qui cause problème (╗ et ┐) dans les fichiers indiqués dans les logs.



  • Okay je vais voir ça



  • Les caractères sont introuvable..C'est impossible à recompiler flan's mod ?

    EDIT: j'ai supprimé les classes qui buguait et ça a apparemment marché…