SOLVED Bug eclipse librairies


  • Bonjour/Bonsoir, en voulant tester mon mod sous eclipse, je me suis rendu compte que, d'une manière qui 'est totalement inconnue, eclipse avait bougé toutes les librairies de Minecraft vers "Referenced Librairies", ce qui empêche tout lancement du jeu. J'ai voulu tester en enlevant/remettant les librairies mais rien ne change. Pouvez-vous m'aider ?

    PS : Désolé si je créé 2 topics le même jour mais ça n'a aucun rapport avec l'autre


  • @'MrBlockTNT':

    Bonjour/Bonsoir, en voulant tester mon mod sous eclipse, je me suis rendu compte que, d'une manière qui 'est totalement inconnue, eclipse avait bougé toutes les librairies de Minecraft vers "Referenced Librairies", ce qui empêche tout lancement du jeu. J'ai voulu tester en enlevant/remettant les librairies mais rien ne change. Pouvez-vous m'aider ?

    PS : Désolé si je créé 2 topics le même jour mais ça n'a aucun rapport avec l'autre

    SceenShot plz.

  • Moddeurs confirmés Rédacteurs Administrateurs

    Ça ne devrait pas causer de problème pourtant. Tu as changés de version d'eclipse ?
    Sinon relance un gradlew eclipse.


  • @Diangle
    Pas trop besoin de sreen, ce qu'il faut savoir c'est que ça a été déplacé vers un "dossier" type JRE librairies mais avec un autre nom.

    @robin4002 
    ça ne risque pas de supprimer mes sources ?

  • Moddeurs confirmés Rédacteurs Administrateurs

    Non.


  • Tu as quel version de java ? la 8_20 ?


  • Java 8_20 pose des problèmes avc minecraft. Reste en Java 7 ou descend en Java 8_11 (Il me semble que cette version fonctionne)

    De plus, pourquoi il ne se lance pas? Rien dans la console? Pas d'erreur à l'écran?


  • @robin4002
    Je vais tester alors

    @Diangle
    Je n'ai pas changé de version de Java depuis ma dernière utilisation, mais c'est la 1.8.0_11, donc pas de souci là dessus

    @utybo
    Erreur : impossible de trouver ou charger la classe principale net.minecraft.launchwrapper.Launch

    EDIT : gradlew eclipse ne change rien 😞


  • fait un gradlew setupDecompWorkspace avec après gradlew setupDevWorkspace, sinon supprime le .gradle et recommence tous (gradlew …)


  • Je teste.

    EDIT : Pareil ça ne change rien 😞 (supprimer le .gradle et tout recommencer)
    DOUBLE EDIT : Il semblerait que, pour une raison qui m'est inconnue, eclipse se soit mis à faire ça automatiquement, sans changer de version. En effet, j'ai créé un projet Java et j'ai ajouté les libs et eclipse mes les as mises dans "Referenced Libraries".

  • Moddeurs confirmés Rédacteurs Administrateurs

    Copie ton dossier src, supprime le dossier forge, refait un setup puis remet ton dossier src.
    Ou alors re-télécharge eclipse classic.