[1.7]Problème texture Item



  • Bonjours après avoir fais le tutoriel de création d'item en 1.7 et avoir suivit les instructions a la lettre ma textures ne s'affiche pas, pourtant mon items est bien chargé par le jeu, le nom de l'item ne s'affiche pas lui aussi.
    Voici le chemin vers ma texture
    Desktop\modding Emergia 1.7\forge\src\main\resources\assets\emergia\textures\items
    Le chemin vers le lang :
    Desktop\modding Emergia 1.7\forge\src\main\resources\assets\emergia\lang

    ma classe principal :

    package fr.emergia.EmergiaMod.common;
    
    import net.minecraft.item.Item;
    import cpw.mods.fml.common.Mod;
    import cpw.mods.fml.common.Mod.EventHandler;
    import cpw.mods.fml.common.Mod.Instance;
    import cpw.mods.fml.common.SidedProxy;
    import cpw.mods.fml.common.event.FMLInitializationEvent;
    import cpw.mods.fml.common.event.FMLPostInitializationEvent;
    import cpw.mods.fml.common.event.FMLPreInitializationEvent;
    import cpw.mods.fml.common.registry.GameRegistry;
    import fr.emergia.EmergiaMod.proxy.CommonProxy;
    
    @Mod(modid = "emergia", name = "EmergiaModPrincipal", version = "1.1" )
    
    public class EmergiaMenu
    {
    public static final String MODID = "emergia";
    
    public static Item LA;
    
    @Instance ("emergia")
    public static EmergiaMenu instance;
    
    @SidedProxy(clientSide = "fr.emergia.EmergiaMod.proxy.ClientProxy", serverSide = "fr.emergia.EmergiaMod.proxy.CommonProxy")
    public static CommonProxy proxy;
    
    @EventHandler
    public void preInit(FMLPreInitializationEvent event)
    {
    //Block
    
    //Item
    LA = new LA().setUnlocalizedName("LA").setTextureName("EmergiaMenu.MODID:LA");
    //Escalier
    
    //GameRegistry
    GameRegistry.registerItem(LA, "1201");
    }
    
    @EventHandler
    public void init(FMLInitializationEvent event)
    {
    //Craft
    
    //Event
    
    //autre
    proxy.RegisterRender();
    
    }
    
    @EventHandler
    public void postInit(FMLPostInitializationEvent event)
    {
    //Commande
    
    }
    
    }
    
    

    et le contenu du fichier lang :

    
    item.LA.name=Lingot Argent
    
    

    Après plusieurs test je ne vois pas ce qui pourrait aller mal 😕
    Merci de votre futur aide
    azatom
    EDIT : j'ai zappé les logs 😛

    
    [20:44:58] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLTweaker
    [20:44:58] [main/INFO] [LaunchWrapper]: Using primary tweak class name cpw.mods.fml.common.launcher.FMLTweaker
    [20:44:58] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLTweaker
    [20:44:58] [main/INFO] [FML]: Forge Mod Loader version 7.2.125.1034 for Minecraft 1.7.2 loading
    [20:44:58] [main/INFO] [FML]: Java is Java HotSpot(TM) 64-Bit Server VM, version 1.7.0_45, running on Windows 7:amd64:6.1, installed at C:\Program Files\Java\jre7
    [20:44:58] [main/INFO] [FML]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation
    [20:44:59] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
    [20:44:59] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker
    [20:44:59] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
    [20:44:59] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
    [20:44:59] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
    [20:44:59] [main/ERROR] [FML]: The binary patch set is missing. Either you are in a development environment, or things are not going to work!
    [20:44:59] [main/ERROR] [FML]: The minecraft jar file:/C:/Users/Thomas/.gradle/caches/minecraft/net/minecraftforge/forge/1.7.2-10.12.0.1034/forgeSrc-1.7.2-10.12.0.1034.jar!/net/minecraft/client/ClientBrandRetriever.class appears to be corrupt! There has been CRITICAL TAMPERING WITH MINECRAFT, it is highly unlikely minecraft will work! STOP NOW, get a clean copy and try again!
    [20:44:59] [main/ERROR] [FML]: FML has been ordered to ignore the invalid or missing minecraft certificate. This is very likely to cause a problem!
    [20:44:59] [main/ERROR] [FML]: Technical information: ClientBrandRetriever was at jar:file:/C:/Users/Thomas/.gradle/caches/minecraft/net/minecraftforge/forge/1.7.2-10.12.0.1034/forgeSrc-1.7.2-10.12.0.1034.jar!/net/minecraft/client/ClientBrandRetriever.class, there were 0 certificates for it
    [20:44:59] [main/ERROR] [FML]: FML appears to be missing any signature data. This is not a good thing
    [20:44:59] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
    [20:44:59] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLDeobfTweaker
    [20:44:59] [main/INFO] [LaunchWrapper]: Launching wrapped minecraft {net.minecraft.client.main.Main}
    [20:45:00] [main/INFO]: Setting user: azatom
    [20:45:01] [Client thread/INFO]: LWJGL Version: 2.9.0
    [20:45:01] [Client thread/INFO] [MinecraftForge]: Attempting early MinecraftForge initialization
    [20:45:01] [Client thread/INFO] [FML]: MinecraftForge v10.12.0.1034 Initialized
    [20:45:01] [Client thread/INFO] [FML]: Replaced 128 ore recipies
    [20:45:01] [Client thread/INFO] [MinecraftForge]: Completed early MinecraftForge initialization
    [20:45:01] [Client thread/INFO] [FML]: Searching C:\Users\Thomas\Desktop\modding Emergia 1.7\forge\eclipse\mods for mods
    [20:45:01] [Client thread/INFO] [examplemod]: Mod examplemod is missing the required element 'name'. Substituting examplemod
    [20:45:02] [Client thread/ERROR] [FML]: FML has detected a mod that is using a package name based on 'net.minecraft.src' : net.minecraft.src.FMLRenderAccessLibrary. This is generally a severe programming error. There should be no mod code in the minecraft namespace. MOVE YOUR MOD! If you're in eclipse, select your source code and 'refactor' it into a new package. Go on. DO IT NOW!
    [20:45:03] [Client thread/INFO] [FML]: Forge Mod Loader has identified 5 mods to load
    [20:45:03] [Client thread/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:examplemod, FMLFileResourcePack:Emergia Mod principal
    [20:45:03] [Client thread/INFO] [FML]: Configured a dormant chunk cache size of 0
    
    Starting up SoundSystem…
    Initializing LWJGL OpenAL
    (The LWJGL binding of OpenAL. For more information, see http://www.lwjgl.org)
    OpenAL initialized.
    
    [20:45:04] [Sound Library Loader/INFO]: Sound engine started
    [20:45:04] [Client thread/INFO]: Created: 512x256 textures/blocks-atlas
    [20:45:04] [Client thread/ERROR]: Using missing texture, unable to load emergiamenu.modid:textures/items/LA.png
    java.io.FileNotFoundException: emergiamenu.modid:textures/items/LA.png
    at net.minecraft.client.resources.SimpleReloadableResourceManager.getResource(SimpleReloadableResourceManager.java:71) ~[SimpleReloadableResourceManager.class:?]
    at net.minecraft.client.renderer.texture.TextureMap.loadTextureAtlas(TextureMap.java:128) [TextureMap.class:?]
    at net.minecraft.client.renderer.texture.TextureMap.loadTexture(TextureMap.java:93) [TextureMap.class:?]
    at net.minecraft.client.renderer.texture.TextureManager.loadTexture(TextureManager.java:89) [TextureManager.class:?]
    at net.minecraft.client.renderer.texture.TextureManager.loadTickableTexture(TextureManager.java:71) [TextureManager.class:?]
    at net.minecraft.client.renderer.texture.TextureManager.loadTextureMap(TextureManager.java:58) [TextureManager.class:?]
    at net.minecraft.client.Minecraft.startGame(Minecraft.java:624) [Minecraft.class:?]
    at net.minecraft.client.Minecraft.run(Minecraft.java:934) [Minecraft.class:?]
    at net.minecraft.client.main.Main.main(Main.java:112) [Main.class:?]
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.7.0_45]
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.7.0_45]
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.7.0_45]
    at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.7.0_45]
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:134) [launchwrapper-1.9.jar:?]
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.9.jar:?]
    [20:45:04] [Client thread/INFO]: Created: 256x256 textures/items-atlas
    DIRT BLOCK >> tile.dirt
    méthode côté client
    [20:45:04] [Client thread/INFO] [FML]: Forge Mod Loader has successfully loaded 5 mods
    [20:45:05] [MCO Availability Checker #1/ERROR]: Couldn't connect to Realms
    [20:45:05] [Client thread/INFO]: Stopping!
    
    SoundSystem shutting down…
    Author: Paul Lamb, www.paulscode.com
    
    

  • Moddeurs confirmés Rédacteurs Administrateurs

    .setTextureName("EmergiaMenu.MODID:LA")
    What ?

    => .setTextureName(EmergiaMenu.MODID + ":LA")



  • Et pour le nom ?


  • Moddeurs confirmés Rédacteurs Administrateurs

    Le nom c'est correcte, je pense que tu as fail le fichier non ? lang est un dossier, en_US.lang est un fichier dans le dossier lang qui doit contenir ce que tu as mit. Sinon regarde le tutoriel en vidéo sur la base :

    Youtube Video – [25:56..]


Log in to reply