Commande "gradlew setupDecompWorkspace" non fonctionnelle



  • Forge : 1.7.10-10.13.4.1614

    Bonjour, Bonsoir,

    Au bout de la 4ème installation(suivi de la suppression du dossier "User.gradle" et la source de Forge/ le dossier "src" de Forge), la commande "gradlew setupDecompWorkspace" a enfin fonctionner à 100% (Je suis votre tutoriel, démarrant donc de la 3ème vidéo de la chaîne), mais le "gradlew eclipse" ne met que 50 secondes maximum et le dossier où les sources de Minecraft sont pour pouvoir modder ne se créé pas, je parle du dossier assets situé dans (pour moi) : "C:\Users\Alexis\Desktop\Développement\Modding\forge-1.7.10\eclipse"
    J'ai pris les sources de forge-1.7.10-10.13.4.1614 et j'ai suivis le tutoriel.
    Mais, rien à faire, même au bout de 4 fois, le dossier assets ne se créé pas, donc en lançant eclipse, ce qu'on voit, le "Minecraft" ne contient rien (screen en fin de post), il y a une flèche pour dérouler, je clique, mais, rien ne s'affiche et la flèche disparait, donc je ne peux pas moddé.
    C'est très pénible et je ne sais comment résoudre ceci, parce que j'ai l'impression, que ce dossier assets, il contient tout ce qu'on voit dans le tuto, donc, je ne peux vraiment rien faire.

    Cordialement, ZeEvoker2Vex.

    Screens :

    Les assets inexistants
    Le Minecraft vide


  • Administrateurs

    Salut,
    Les accents dans le chemin du dossier causent problème en général, renomme ton dossier Développement en Developpement puis refais un setup.



  • @robin4002
    Salut ! Je vais essayé, merci bien !



  • Rebonjour !

    ça ne marche pas, mais, par contre, au début (1er reset ce matin), j'ai supprimé dans le dossier "C:" de mon PC un dossier "Gradle".
    Je l'ai trouvé en regardant mes variables d'environnement et j'ai vu "C:\Gradle\gradle-5.1\bin".
    Est-ce que de ne plus avoir ce dossier cause un problème ?
    Ou, en réécoutant la vidéo, j'ai écouté que y avait un gradle wrapper déjà intégrer à Forge, donc pas besoin d'installer Gradle, mais je me rappelle, un jour, j'ai voulu l'installé. Serait-ce un reste de Gradle inutile ?
    Peut-être que en fesant "gradlew" ça essaye de faire un lien avec la variable d'environnement nan ?

    Cordialement, ZeEvoker2Vex.


  • Administrateurs

    Ce n'est pas ça qui entre en conflit, car pour utiliser le gradle installé sur le système il faut utiliser la commande gradle et non gradlew (gradlew = gradle wrapper).

    Tu as bien refait la totalité du setup après avoir renommé ? (le mieux serait de re-télécharger un mdk clean et refaire les deux commandes gradlew)



  • Euh, ok, mais c'est quoi "mdk" ?
    Merki ❤


  • Administrateurs

    mdk = mod development kit, le fichier zip que tu as téléchargé.



  • Ah, ok, sur http://files.minecraftforge.net/, en anglais le site c'est "mdk" et non "src".
    Mais, j'avais gardé une save (si on peut dire j'ai juste eu la chance de pas vider la corbeille et j'ai pu restauré le fichier téléchargé), donc normalement, ça devrait allé 🤔
    Mais après tout, je vais réessayé et je vous/te recontacte après.

    Cordialement, un ZE2V sauvage x)



  • Hey !
    Désolé de l'absence, j'y ai fais hier, mais, toujours pas, le gradlew eclipse carrément se bloque au moment du "downloadClient", et il reste sur ce téléchargement pendant trop longtemps (j'ai laissé pendant 3h puis j'y ai refais le lendemain matin, donc hier), et ben nan toujours pareil..

    Cordialement.


  • Administrateurs

    Il bloque systématiquement sur cette étape ?



  • Tu a une bonne connection ? Moi ça avais fait la même chose mais c’était ma co qui étais mauvaise (ou c’était moi qui avais un problème)



  • @robin4002 oui tout le temps au "downloadClient"
    Sinon @AZ_the_froggie je ne pense pas parce que les pages web chargeaient vite et Minecraft était sur du 40ms (quand je bug, mon ping(ms) monte tout le temps au même niveau, 200ms, donc c'est soi je bug pas, soit bug minimum 200ms.

    Cordialement.


  • Administrateurs

    Tu as un anti-virus ou autre qui pourrait bloquer le téléchargement ?



  • Ben Avast Antivirus mais ce serait bizarre parce que avant ça marcher, c'est depuis que j'ai réinstallé le mdk comme ta dit.


  • Administrateurs

    Apparemment il y avait un souci avec les serveurs de forge, tu peux réessayer maintenant ?
    Utilises cette commande : qui forcera la mise à jour de forge gradle.
    ./gradlew setupDecompWorkspace --refresh-dependencies



  • Ok merci je test ça ^^
    Quelle chance si c'est ça !!! x)



  • This post is deleted!


  • Ohhhhhh le boulet, c'était setupDecompWorkspace l'erreur du downloadClient 🤦
    J'ai corrigé le titre. Sinon, bonne nouvelle ?
    ":extractMcpData UP-TO-DATE --> AIE ?
    :getVersionJson
    :extractUserDev UP-TO-DATE --> AIE ?
    :genSrgs SKIPPED --> AIE ?
    :extractNatives UP-TO-DATE --> AIE ?
    :getAssetsIndex
    :getAssets
    :makeStart
    [ant:javac] warning: [options] bootstrap class path not set in conjunction with -source 1.6
    [ant:javac] 1 warning
    :downloadMcpTools SKIPPED --> AIE ?
    :downloadClient
    :downloadServer
    :mergeJars
    :deobfuscateJar
    Applying SpecialSource...
    Applying Exceptor...
    :decompile
    :processSources
    Injecting fml files
    Applying fml patches
    Applying forge patches
    :remapJar
    :extractMinecraftSrc
    :recompMinecraft
    Note: Some input files use or override a deprecated API.
    Note: Recompile with -Xlint:deprecation for details.
    Note: Some input files use unchecked or unsafe operations.
    Note: Recompile with -Xlint:unchecked for details.
    :repackMinecraft
    :setupDecompWorkspace

    BUILD SUCCESSFUL

    Total time: 5 mins 57.16 secs"


  • Administrateurs

    Il n'y a rien d'anormal dans ces logs.

    Les UP-TO-DATE c'est parce que tu as déjà les fichiers dans ton cache de gradle. Idem pour le SKIPPED.



  • Ok merci, ben, je lance le gradlew eclipse dès que je sis chez moi


Log in to reply