problème de workspace



  • Je suis sur Windows 10 et je comprend pas pourquoi .
    PS C:\Users\killi> "C:\Users\killi\Desktop\forge 1.12.2"
    C:\Users\killi\Desktop\forge 1.12.2
    PS C:\Users\killi> gradlew -Dorg.gradle.jvmargs=-Xmx2048M setupDecompWorkspace
    gradlew : Le terme «gradlew» n'est pas reconnu comme nom d'applet de commande, fonction, fichier de script ou programme
    exécutable. Vérifiez l'orthographe du nom, ou si un chemin d'accès existe, vérifiez que le chemin d'accès est correct et
    réessayez.
    Au caractère Ligne:1 : 1

    • gradlew -Dorg.gradle.jvmargs=-Xmx2048M setupDecompWorkspace
    •   + CategoryInfo          : ObjectNotFound: (gradlew:String) [], CommandNotFoundException
        + FullyQualifiedErrorId : CommandNotFoundException


  • je rentre ca dans l'executeur de commande et rien a faire il ne veut rien savoir … il me dit que gradlew est un mauvais terme 😕


  • Administrateurs

    Salut,
    Les demandes vont dans les sections de support (support pour les moddeurs dans le cas du développement).
    J'ai déplacé dans la bonne section, merci de faire plus attention à l'avenir.

    Tu as oublié de taper cd (pour change directory) avant de mettre le chemin du dossier forge. Et sur le powershell, il faut taper .\gradlew au lieu de gradlew



  • @robin4002 Merci ! le .\gradlew marche parfaitement, mais une fois lancer, il télécharge 18 mb de fichier et après sa me met ca :
    FAILURE: Build failed with an exception.

    • What went wrong:
      Task '.gradle.jvmargs=-Xmx2048M' not found in root project 'forge 1.12.2'.

    • Try:
      Run gradlew tasks to get a list of available tasks. Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

    BUILD FAILED

    Total time: 5 mins 5.831 secs
    PS C:\Users\killi\Desktop\Codage\forge 1.12.2>

    c'est normal, je pense pas ?


  • Administrateurs

    Tu as tapé quoi exactement ?
    Car là il y a essayé d'interpréter une partie de l'argument pour augmenter la ram comme une tâche, donc ça laisse penser a un espace en trop dans ce que tu as tapé.



  • J'ai tapé la commande que tu précise : .\gradlew -Dorg.gradle.jvmargs=-Xmx2048M setupDecompWorkspace



  • @robin4002 je ne comprend pas j'ai refait les manips de 0 du point- de ta vidéo, et toujour rien, quand le lance la commande ca ne marche pas .


  • Administrateurs

    2 Go de mémoire n'est pas suffisant pour les workspaces depuis plusieurs versions, il faut passer au moins à 3 Go



  • @Superloup10 Daccord, donc je sais qu'il faut mettre 3 mille mais 3 mille quelque chose nan ?


  • Administrateurs

    Tu as juste à mettre dans le gradle.properties : org.gradle.jvmargs=-Xmx3G
    Et ensuite, tu auras juste à lancer la commande : .\gradlew setupDecompWorkspace
    Puis : .\gradlew eclipse



  • @Superloup10 merci énormément ! je pourrai enfin au bout de 2 jour de galère commencer , et j'avais aussi une question qui me trotte dans la tête depuis hier, si on veut créer un autre mod, faut-il refaire la manip ?



  • ca depend si tu utilise ou non le meme workspace


Log in to reply