Failed to load resources



  • Bonjour, je suis actuellement en train de faire un mod de Custom main menu, mais je bloque depuis hier sur quelque chose d'assez gavant.
    En effet : mon mod ne veut tout simplement pas charger de textures, avec, à chaque fois, comme erreur,

    [09:24:01] [Client thread/WARN]: Failed to load texture: newera:textures/gui/background.png
    java.io.FileNotFoundException: newera:textures/gui/background.png
    at net.minecraft.client.resources.SimpleReloadableResourceManager.getResource(SimpleReloadableResourceManager.java:71) ~[SimpleReloadableResourceManager.class:?]
    at net.minecraft.client.renderer.texture.SimpleTexture.loadTexture(SimpleTexture.java:35) ~[SimpleTexture.class:?]
    at net.minecraft.client.renderer.texture.TextureManager.loadTexture(TextureManager.java:89) [TextureManager.class:?]
    at net.minecraft.client.renderer.texture.TextureManager.bindTexture(TextureManager.java:45) [TextureManager.class:?]
    at fr.deathworld.newera.GuiCustomMainMenu.renderBackGround(GuiCustomMainMenu.java:418) [GuiCustomMainMenu.class:?]
    at fr.deathworld.newera.GuiCustomMainMenu.drawScreen(GuiCustomMainMenu.java:508) [GuiCustomMainMenu.class:?]
    at net.minecraft.client.renderer.EntityRenderer.updateCameraAndRender(EntityRenderer.java:1137) [EntityRenderer.class:?]
    at net.minecraft.client.Minecraft.runGameLoop(Minecraft.java:1067) [Minecraft.class:?]
    at net.minecraft.client.Minecraft.run(Minecraft.java:962) [Minecraft.class:?]
    at net.minecraft.client.main.Main.main(Main.java:164) [Main.class:?]
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_162]
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_162]
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_162]
    at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_162]
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135) [launchwrapper-1.12.jar:?]
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.12.jar:?]
    at net.minecraftforge.gradle.GradleStartCommon.launch(Unknown Source) [start/:?]
    at GradleStart.main(Unknown Source) [start/:?]
    

    Je suis sous IntelliJ, je gère donc mon projet avec Gradle, que j'ai bien édité avec le modid, ect.

    Mon ModID est normalement bien configuré, comme vous pouvez le voir ici (Main.java) :

    @Mod(modid = "newera", name = "NewEra Mod", version = "0.1", acceptedMinecraftVersions = "[1.10.2]")
    public class Main {
    
       public static final String NEWERA = "newera";
    
       @Mod.Instance(Main.NEWERA)
       public static Main instance;
    
       @SidedProxy(clientSide = "fr.deathworld.newera.MainClient", serverSide = "fr.deathworld.newera.MainServer")
       public static MainCommon proxy;
    
       @Mod.EventHandler
       public void preInit(FMLPreInitializationEvent event){
           proxy.preInit(event.getSuggestedConfigurationFile());
       }
    
       @Mod.EventHandler
       public void init(FMLInitializationEvent event){
           proxy.init();
       }
    }
    

    Ensuite, voici les dossiers et fichiers de mon projet, qui me paraissent également bien configurés :

    Finalement, voici la façon dont j'essaye de load les textures :

       private final ResourceLocation backGround = new ResourceLocation(Main.NEWERA, "textures/gui/background.png");
    
    

    Sauriez-vous m'aider à résoudre ce problème ? 😕

    Merci d'avance !


  • Rédacteurs

    Salut,
    Peux-tu mettre les logs complets s'il te plait ?