Erreur Gradlew



  • Bonjour je reviens vers vous (lol) car j'ai un petits probleme avec gradlew au niveau de .Gradlew task. l'erreur c'est :

    C:\Users\Fusked>cd Desktop/Dev/Forge

    C:\Users\Fusked\Desktop\DEV\forge>gradlew task
    Etag download for http://files.minecraftforge.net/maven/de/oceanlabs/mcp/version
    s.json failed with code 400
    Etag download for http://export.mcpbot.bspk.rs/versions.json failed with code 40
    0

    FAILURE: Build failed with an exception.

    • Where:
      Build file 'C:\Users\Fusked\Desktop\DEV\forge\build.gradle' line: 15

    • What went wrong:
      A problem occurred evaluating root project 'forge'.

    Failed to apply plugin [id 'net.minecraftforge.gradle.forge']
       > java.lang.IllegalStateException: Expected BEGIN_OBJECT but was STRING at li
    ne 1 column 1

    • Try:
      Run with –stacktrace option to get the stack trace. Run with --info or --debug
      option to get more log output.

    BUILD FAILED

    Total time: 3 mins 4.287 secs

    C:\Users\Fusked\Desktop\DEV\forge>


  • Administrateurs

    Voilà ton problème : Build file 'C:\Users\Fusked\Desktop\DEV\forge\build.gradle' line: 15



  • @'Superloup10':

    Voilà ton problème : Build file 'C:\Users\Fusked\Desktop\DEV\forge\build.gradle' line: 15

    je suis allez voir la ligne 15 de build.gradle

    apply plugin: 'net.minecraftforge.gradle.forge'

    Que dois je faire après?


  • Administrateurs

    Tu peux donner ton build.gradle complet ?


  • Administrateurs

    Salut,
    Il y a visiblement un soucis avec le plugin forge, essaies avec :
    gradlew task –refresh-dependencies

    Si le problème persiste, tentes à nouveau plus tard.



  • // For those who want the bleeding edge
    buildscript {
    repositories {
    jcenter()
    maven {
    name = "forge"
    url = "http://files.minecraftforge.net/maven"
    }
    }
    dependencies {
    classpath 'net.minecraftforge.gradle:ForgeGradle:2.2-SNAPSHOT'
    }
    }
    apply plugin: 'net.minecraftforge.gradle.forge'
    
    /*
    // for people who want stable - not yet functional for MC 1.8.8 - we require the forgegradle 2.1 snapshot
    plugins {
    id "net.minecraftforge.gradle.forge" version "2.0.2"
    }
    */
    version = "1.0"
    group= "com.yourname.modid" // http://maven.apache.org/guides/mini/guide-naming-conventions.html
    archivesBaseName = "modid"
    
    minecraft {
    version = "1.9.4-12.17.0.2051"
    runDir = "run"
    
    // the mappings can be changed at any time, and must be in the following format.
    // snapshot_YYYYMMDD snapshot are built nightly.
    // stable_# stables are built at the discretion of the MCP team.
    // Use non-default mappings at your own risk. they may not allways work.
    // simply re-run your setup task after changing the mappings to update your workspace.
    mappings = "snapshot_20160518"
    // makeObfSourceJar = false // an Srg named sources jar is made by default. uncomment this to disable.
    }
    
    dependencies {
    // you may put jars on which you depend on in ./libs
    // or you may define them like so..
    //compile "some.group:artifact:version:classifier"
    //compile "some.group:artifact:version"
    
    // real examples
    //compile 'com.mod-buildcraft:buildcraft:6.0.8:dev' // adds buildcraft to the dev env
    //compile 'com.googlecode.efficient-java-matrix-library:ejml:0.24' // adds ejml to the dev env
    
    // the 'provided' configuration is for optional dependencies that exist at compile-time but might not at runtime.
    //provided 'com.mod-buildcraft:buildcraft:6.0.8:dev'
    
    // the deobf configurations: 'deobfCompile' and 'deobfProvided' are the same as the normal compile and provided,
    // except that these dependencies get remapped to your current MCP mappings
    //deobfCompile 'com.mod-buildcraft:buildcraft:6.0.8:dev'
    //deobfProvided 'com.mod-buildcraft:buildcraft:6.0.8:dev'
    
    // for more info…
    // http://www.gradle.org/docs/current/userguide/artifact_dependencies_tutorial.html
    // http://www.gradle.org/docs/current/userguide/dependency_management.html
    
    }
    
    processResources
    {
    // this will ensure that this task is redone when the versions change.
    inputs.property "version", project.version
    inputs.property "mcversion", project.minecraft.version
    
    // replace stuff in mcmod.info, nothing else
    from(sourceSets.main.resources.srcDirs) {
    include 'mcmod.info'
    
    // replace version and mcversion
    expand 'version':project.version, 'mcversion':project.minecraft.version
    }
    
    // copy everything else, thats not the mcmod.info
    from(sourceSets.main.resources.srcDirs) {
    exclude 'mcmod.info'
    }
    }
    

    la commande gradlew task --refresh-dependencies ne change rien je ressaye demain .