Petit soucis au niveau de la création d'un item



  • Bonsoir à tous

    Entre 2 recherche pour faire des textures comme ceci
    0_1536506336497_textures warlords.png
    j'essaye d'implanter mon premier item dans mon mod sauf que je pense qu'il y a un petit conflit entre l'item et le bloc que j'ai implenter juste avant , je m'explique :
    mon minecraft se lance et puis je me retrouve avec mon bloc implenter avant en main avec la texture de l'item que je voulais et impossible de mettre la main sur "lesdit"item bref j'ai cru que cela venais du .json dans le models/item qui avait le même nom que celui du bloc , je l'ai renommé et bizarrement quand j'ai relancé minecraft mon bloc n'avait plus de texture et je ne trouvais pas l'item:

    Bref maintenant que j'ai déballé tout mon chagrin ^^ je passe au logs:

    [23:38:49] [Client thread/INFO] [FML]: MinecraftForge v11.15.1.1722 Initialized
    [23:38:49] [Client thread/INFO] [FML]: Replaced 204 ore recipies
    [23:38:50] [Client thread/INFO] [FML]: Found 0 mods from the command line. Injecting into mod discoverer
    [23:38:50] [Client thread/INFO] [FML]: Searching C:\Users\stephanie\Documents\quentin\Modding\forge-1.8.9\run\mods for mods
    [23:38:53] [Client thread/INFO] [FML]: Forge Mod Loader has identified 4 mods to load
    [23:38:53] [Client thread/INFO] [FML]: Attempting connection with missing mods [mcp, FML, Forge, wakfu] at CLIENT
    [23:38:53] [Client thread/INFO] [FML]: Attempting connection with missing mods [mcp, FML, Forge, wakfu] at SERVER
    [23:38:54] [Client thread/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:Mod Minecraft
    [23:38:54] [Client thread/INFO] [FML]: Processing ObjectHolder annotations
    [23:38:54] [Client thread/INFO] [FML]: Found 384 ObjectHolder annotations
    [23:38:54] [Client thread/INFO] [FML]: Identifying ItemStackHolder annotations
    [23:38:54] [Client thread/INFO] [FML]: Found 0 ItemStackHolder annotations
    [23:38:54] [Client thread/INFO] [FML]: Configured a dormant chunk cache size of 0
    [23:38:54] [Forge Version Check/INFO] [ForgeVersionCheck]: [Forge] Starting version check at http://files.minecraftforge.net/maven/net/minecraftforge/forge/promotions_slim.json
    [23:38:55] [Client thread/INFO] [FML]: Applying holder lookups
    [23:38:55] [Client thread/INFO] [FML]: Holder lookups applied
    [23:38:55] [Client thread/INFO] [FML]: Injecting itemstacks
    [23:38:55] [Client thread/INFO] [FML]: Itemstack injection complete
    [23:38:55] [Forge Version Check/INFO] [ForgeVersionCheck]: [Forge] Found status: UP_TO_DATE Target: null
    [23:38:55] [Sound Library Loader/INFO]: Starting up SoundSystem…
    [23:38:55] [Thread-9/INFO]: Initializing LWJGL OpenAL
    [23:38:55] [Thread-9/INFO]: (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)
    [23:38:56] [Thread-9/INFO]: OpenAL initialized.
    [23:38:56] [Sound Library Loader/INFO]: Sound engine started
    [23:39:12] [Client thread/INFO] [FML]: Max texture size: 8192
    [23:39:12] [Client thread/INFO]: Created: 16x16 textures-atlas
    [23:39:12] [Client thread/ERROR] [FML]: Model definition for location wakfu:wakfu_bloc#inventory not found
    [23:39:14] [Client thread/INFO] [FML]: Injecting itemstacks
    [23:39:14] [Client thread/INFO] [FML]: Itemstack injection complete
    [23:39:14] [Client thread/INFO] [FML]: Forge Mod Loader has successfully loaded 4 mods
    [23:39:14] [Client thread/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:Mod Minecraft
    [23:39:14] [Client thread/INFO]: SoundSystem shutting down…
    [23:39:14] [Client thread/WARN]: Author: Paul Lamb, www.paulscode.com
    [23:39:14] [Sound Library Loader/INFO]: Starting up SoundSystem…
    [23:39:14] [Thread-11/INFO]: Initializing LWJGL OpenAL
    [23:39:14] [Thread-11/INFO]: (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)
    [23:39:14] [Thread-11/INFO]: OpenAL initialized.
    [23:39:15] [Sound Library Loader/INFO]: Sound engine started
    [23:39:37] [Client thread/INFO] [FML]: Max texture size: 8192
    [23:39:38] [Client thread/INFO]: Created: 512x512 textures-atlas
    [23:39:38] [Client thread/ERROR] [FML]: Model definition for location wakfu:wakfu_bloc#inventory not found
    [23:39:39] [Realms Notification Availability checker #1/INFO]: Could not authorize you against Realms server: Invalid session id
    [23:39:43] [Realms Notification Availability checker #1/INFO]: Could not authorize you against Realms server: Invalid session id
    [23:39:44] [Server thread/INFO]: Starting integrated minecraft server version 1.8.9
    [23:39:44] [Server thread/INFO]: Generating keypair
    [23:39:44] [Server thread/INFO] [FML]: Injecting existing block and item data into this server instance
    [23:39:44] [Server thread/INFO] [FML]: Found a missing id from the world wakfu:bloc_de_wakfu
    [23:39:44] [Server thread/INFO] [FML]: Found a missing id from the world wakfu:Bloc_de_wakfu
    [23:39:44] [Server thread/INFO] [FML]: Applying holder lookups
    [23:39:44] [Server thread/INFO] [FML]: Holder lookups applied
    [23:39:44] [Server thread/INFO] [FML]: Loading dimension 0 (New World) (net.minecraft.server.integrated.IntegratedServer@7fc5b1d8)
    [23:39:44] [Server thread/INFO] [FML]: Loading dimension 1 (New World) (net.minecraft.server.integrated.IntegratedServer@7fc5b1d8)
    [23:39:44] [Server thread/INFO] [FML]: Loading dimension -1 (New World) (net.minecraft.server.integrated.IntegratedServer@7fc5b1d8)
    [23:39:44] [Server thread/INFO]: Preparing start region for level 0
    [23:39:45] [Realms Notification Availability checker #1/INFO]: Could not authorize you against Realms server: Invalid session id
    [23:39:46] [Server thread/INFO]: Changing view distance to 9, from 10
    [23:39:47] [Netty Local Client IO #0/INFO] [FML]: Server protocol version 2
    [23:39:47] [Netty Server IO #1/INFO] [FML]: Client protocol version 2
    [23:39:47] [Netty Server IO #1/INFO] [FML]: Client attempting to join with 4 mods : FML@8.0.99.99,Forge@11.15.1.1722,wakfu@0.1,mcp@9.19
    [23:39:47] [Netty Local Client IO #0/INFO] [FML]: [Netty Local Client IO #0] Client side modded connection established
    [23:39:47] [Server thread/INFO] [FML]: [Server thread] Server side modded connection established
    [23:39:47] [Server thread/INFO]: tristepin20[local:E:fa7795f4] logged in with entity id 66 at (-806.929564783492, 4.0, 164.69069605494377)
    [23:39:47] [Server thread/INFO]: tristepin20 joined the game
    [23:39:49] [pool-2-thread-1/WARN]: Couldn't look up profile properties for com.mojang.authlib.GameProfile@72e6b1a5[id=3d8e993c-5877-30c3-8b64-912692f127ee,name=tristepin20,properties={},legacy=false]
    com.mojang.authlib.exceptions.AuthenticationException: The client has sent too many requests within a certain amount of time
    at com.mojang.authlib.yggdrasil.YggdrasilAuthenticationService.makeRequest(YggdrasilAuthenticationService.java:65) ~[YggdrasilAuthenticationService.class:?]
    at com.mojang.authlib.yggdrasil.YggdrasilMinecraftSessionService.fillGameProfile(YggdrasilMinecraftSessionService.java:175) [YggdrasilMinecraftSessionService.class:?]
    at com.mojang.authlib.yggdrasil.YggdrasilMinecraftSessionService$1.load(YggdrasilMinecraftSessionService.java:59) [YggdrasilMinecraftSessionService$1.class:?]
    at com.mojang.authlib.yggdrasil.YggdrasilMinecraftSessionService$1.load(YggdrasilMinecraftSessionService.java:56) [YggdrasilMinecraftSessionService$1.class:?]
    at com.google.common.cache.LocalCache$LoadingValueReference.loadFuture(LocalCache.java:3524) [guava-17.0.jar:?]
    at com.google.common.cache.LocalCache$Segment.loadSync(LocalCache.java:2317) [guava-17.0.jar:?]
    at com.google.common.cache.LocalCache$Segment.lockedGetOrLoad(LocalCache.java:2280) [guava-17.0.jar:?]
    at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2195) [guava-17.0.jar:?]
    at com.google.common.cache.LocalCache.get(LocalCache.java:3934) [guava-17.0.jar:?]
    at com.google.common.cache.LocalCache.getOrLoad(LocalCache.java:3938) [guava-17.0.jar:?]
    at com.google.common.cache.LocalCache$LocalLoadingCache.get(LocalCache.java:4821) [guava-17.0.jar:?]
    at com.google.common.cache.LocalCache$LocalLoadingCache.getUnchecked(LocalCache.java:4827) [guava-17.0.jar:?]
    at com.mojang.authlib.yggdrasil.YggdrasilMinecraftSessionService.fillProfileProperties(YggdrasilMinecraftSessionService.java:165) [YggdrasilMinecraftSessionService.class:?]
    at net.minecraft.client.Minecraft.func_181037_M(Minecraft.java:2915) [Minecraft.class:?]
    at net.minecraft.client.resources.SkinManager$3.run(SkinManager.java:130) [SkinManager$3.class:?]
    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [?:1.8.0_91]
    at java.util.concurrent.FutureTask.run(Unknown Source) [?:1.8.0_91]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [?:1.8.0_91]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [?:1.8.0_91]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_91]
    [23:40:52] [Client thread/INFO]: Stopping!
    [23:40:52] [Client thread/INFO]: SoundSystem shutting down…
    [23:40:52] [Server thread/INFO]: Stopping server
    [23:40:52] [Server thread/INFO]: Saving players
    [23:40:52] [Server thread/INFO]: Saving worlds
    [23:40:52] [Server thread/INFO]: Saving chunks for level 'New World'/Overworld
    [23:40:52] [Client thread/WARN]: Author: Paul Lamb, www.paulscode.com
    Exception in thread "Client Shutdown Thread" Java HotSpot(TM) 64-Bit Server VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
    
    

    le lien de mon dossier src :
    http://upload.lescigales.org/pzqc

    Merci d'avance de prendre du temps sur vous pour corriger mes bêtises vous êtes des chefs 😉


  • Administrateurs

    Salut,

    Il y a plusieurs problèmes dans ton code :

    • ta classe client et serveur sont présentes en double.
    • la déclaration ton item est en double.
    • tu appelles la fonction registerItems qui se trouve dans la classe Item au lieu de celle qui se trouve dans la classe Wakfuitems.

    Voila ce que ça donne une fois corrigé :
    src.zip



  • @'robin4002m':

    Salut,

    Il y a plusieurs problèmes dans ton code :

    • ta classe client et serveur sont présentes en double.
    • la déclaration ton item est en double.
    • tu appelles la fonction registerItems qui se trouve dans la classe Item au lieu de celle qui se trouve dans la classe Wakfuitems.

    Voila ce que ça donne une fois corrigé :

    Merci beaucoup robin je teste cela demain et je te dis ce qu'il en ait 😉



  • C'est bon je l'ai testé  il marche nikel ^^ juste une petite question:
    Dans mon dossier ou sont stockés les models des items pourquoi y'en a t-il 3 alors que j'en avait besoin que de 1 .


  • Administrateurs

    3 ? Il y en a que deux non ? Celui du bloc et celui de l'item.



  • Oui oui y'en a bien 2 excuse moi j'ai du mal m'exprimer^^
    ce que je voulais dire c'est qu'il y a 3.json dans models/items alors que j'en avait besoin que de 1