• Bonsoir,
    Alors voilà, je suis sous Ubuntu 14.04 LTS depuis peu et j'aurais voulu pouvoir modder pour la 1.7.10 mais j'ai une erreur lors du lancement du script gradlew avec les options "setupDecompWorkspace" suivie dans ce tutoriel , tout ce passe bien jusqu'à ~24% et qu'il me mette ça :

    
    Powered By MCP:
    http://mcp.ocean-labs.de/
    Searge, ProfMobius, Fesh0r,
    R4wk, ZeuX, IngisKahn
    MCP Data version : unknown
    ****************************
    :extractUserDev UP-TO-DATE
    :genSrgs SKIPPED
    :extractNatives UP-TO-DATE
    :getAssetsIndex
    :getAssets
    :makeStart FAILED
    
    FAILURE: Build failed with an exception.
    
    * What went wrong:
    Execution failed for task ':makeStart'.
    > Cannot find System Java Compiler. Ensure that you have installed a JDK (not just a JRE) and configured your JAVA_HOME system variable to point to the according directory.
    
    * Try:
    Run with –stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
    
    BUILD FAILED
    
    Total time: 28.864 secs
    
    

    dans mon fichier "environment" j'ai pourtant bien la variable JAVA_HOME=/usr/lib/jvm/java-7-openjdk-i386/

    Voilà, je suis à dispo° pour plus d'info

    PS: j'ai bien la JDK d'installé

    Merci d'avance 😉

  • Modérateurs

    Tu n'as pas le bon jdk, je pense. Regarde ici.

  • Moddeurs confirmés Rédacteurs Administrateurs

    Normalement tu peux aussi avec l'openJDK, le truc c'est que tu n'as que installé le JRE.
    Va dans la logithèque et installe le kit de développement d'openJDK. Ou alors installes la version d'oracle depuis le ppa de webupd8team comme indiqué dans le tutoriel.

    ÉDIT : attention avec openJDK, son nom peut causer des confusions car il y a bien deux paquets, un qui correspond au jre et un autre au jdk.


  • Merci à vous deux, ça marche nickel.