[1.7.10] Mes deux mobs ont le mêmes models !



  • Bonjour a tous, c'est le premier message que je poste ici malgré les nombreux que j'ai déjà lu.
    Jusqu’à maintenant j'arrivais a trouver la réponse parmi les post déjà présent sur le site mais la je ne trouve vraiment pas.
    Voila mon problème:
    J'ai crée deux mobs passifs et mes deux mobs partagent le même model (par extension la même texture) alors qu'ils en ont un chacun.
    Selon l'ordre dans lequel je mets les lignes 12 et 13

    package com.mod.arcadia.init;
    
    import com.mod.arcadia.entity.Tortue2;
    import com.mod.arcadia.entity.Tortue;
    import com.mod.arcadia.handlers.EntityHandler;
    import com.mod.arcadia.handlers.EntityHandlerTortue;
    
    public class EntityMod 
    {	
    	public static void init()
    		{
    			EntityHandlerTortue.registerAnimals1(Tortue.class, "Tortue");	
    			EntityHandler.registerAnimals(Tortue2.class, "Tortue2");
    		}	
    		
    }
    

    dans ma classe EntityMob le model change a chaque fois mais sur les deux mobs en même temps.
    (je sais que mes deux mobs différents spawn car ils ne drop pas les même choses et que j'ai les deux types de drops)
    J’espère que vous avez compris mon problème, la solution dois être évidente mais mes connaissances plutôt faible en java me bloque a ce stade.
    Merci d'avoir pris le temps de lire et j’espère avoir vos avis au plus vite.
    Bonne soirée/ journée à tous.



  • Désolé mais la 1.7.10 n'est plus supportée par Minecraft Forge France 😕 .
    Et pense à sérieusement apprendre le java avant de te lancer dans le modding.
    Sur ce, bonne soirée.


  • Modérateurs

    Mauvaise section, je ferme.


Log in to reply