Les accents et sponge...



  • Bonjour !
    Je travail actuellement sur un plugin sous sponge. J'utilise eclipse et gradle.

    Mais voilà dans mes messages il y a des accents ! Mais en jeu ils n'apparaissent pas. C'est assez problématique ! Surtout que dans mon gradle.build il y'a bien la ligne : compileJava.options.encoding = 'UTF-8'
    J'ai même rajouté ces lignes après quelques recherche mais rien n'a changé :

    compileTestJava.options.encoding = 'UTF-8'
    javadoc.options.encoding = 'UTF-8'

    J'ai bien sûr refresh le build gradle en sauvegardant le gradle.build.

    Je ne sais plus quoi faire ! Aidez moi s'il vous plaît !

    Le message d'erreur que j'ai quand je build le plugin est le suivant :

    error: unmappable character for encoding UTF-8

    Pourtant les caractères utiliser sont : é, è, ç, à, ê qui sont dans la table UTF-8...


  • Moddeurs confirmés Rédacteurs Modérateurs Administrateurs

    Déjà, c'est très bien, tu as trouvé la bonne ligne a ajouté dans le build.gradle à savoir compileJava.options.encoding = 'UTF-8'.
    Maintenant, il reste 2 possibilités :

    • Soit tu as oublié de changer l'encodage d'Eclipse.
    • Soit tu t'es trompé dans le positionnement de la ligne à ajouter dans le build.gradle.


  • Voici mon fichier build.gradle :

    plugins {
        id 'java'
        id 'org.spongepowered.plugin' version '0.9.0'
    }
    
    compileJava.options.encoding = 'UTF-8'
    
    
    
    group = 'fr.test'
    version = '1.0.0-SNAPSHOT'
    description = 'Plugin test'
    
    repositories {
        jcenter()
    }
    
    dependencies {
        compile 'org.spongepowered:spongeapi:7.1.0'
    }
    

    Et dans eclipse :

    Capture.PNG



  • Bon, et bien après un réinitialisation d'Eclipse, y'a fonctionne... Merci quand même !


Log in to reply