• Moddeurs confirmés Modérateurs

    Salut les amis après avoir terminé mon mod portal, j’ai voulu le compilé (recompile.bat) et voici mon erreur:

    
    == MCP 8.09 (data: 8.11, client: 1.6.4, server: 1.6.4) ==
    "scalac" is not found on the PATH. Scala files will not be recompiled
    # found ff, ff patches, srgs, name csvs, doc csvs, param csvs, astyle, astyle co
    nfig, rg, ss
    == Recompiling client ==
    > Cleaning bin
    > Recompiling
    '"C:\Program Files\Java\jdk1.7.0_45\bin\javac" -encoding UTF-8 -Xlint:-options -
    deprecation -g -source 1.6 -target 1.6 -classpath "jars\versions\1.6.4\1.6.4.jar
    ;lib;lib\*;jars\libraries\net\java\jinput\jinput\2.0.5\jinput-2.0.5.jar;jars\lib
    raries\org\lwjgl\lwjgl\lwjgl-platform\2.9.0\lwjgl-platform-2.9.0-natives-windows
    .jar;jars\libraries\org\apache\commons\commons-lang3\3.1\commons-lang3-3.1.jar;j
    ars\libraries\com\paulscode\libraryjavasound\20101123\libraryjavasound-20101123.
    jar;jars\libraries\net\sf\jopt-simple\jopt-simple\4.5\jopt-simple-4.5.jar;jars\l
    ibraries\com\google\guava\guava\14.0\guava-14.0.jar;jars\libraries\lzma\lzma\0.0
    .1\lzma-0.0.1.jar;jars\libraries\com\paulscode\codecjorbis\20101023\codecjorbis-
    20101023.jar;jars\libraries\org\bouncycastle\bcprov-jdk15on\1.47\bcprov-jdk15on-
    1.47.jar;jars\libraries\com\paulscode\soundsystem\20120107\soundsystem-20120107.
    jar;jars\libraries\com\paulscode\librarylwjglopenal\20100824\librarylwjglopenal-
    20100824.jar;jars\libraries\org\scala-lang\scala-library\2.10.2\scala-library-2.
    10.2.jar;jars\libraries\org\lwjgl\lwjgl\lwjgl_util\2.9.0\lwjgl_util-2.9.0.jar;ja
    rs\libraries\org\scala-lang\scala-compiler\2.10.2\scala-compiler-2.10.2.jar;jars
    \libraries\net\java\jutils\jutils\1.0.0\jutils-1.0.0.jar;jars\libraries\org\ow2\
    asm\asm-debug-all\4.1\asm-debug-all-4.1.jar;jars\libraries\org\lwjgl\lwjgl\lwjgl
    \2.9.0\lwjgl-2.9.0.jar;jars\libraries\commons-io\commons-io\2.4\commons-io-2.4.j
    ar;jars\libraries\net\sourceforge\argo\argo\2.25\argo-2.25.jar;jars\libraries\co
    m\google\code\gson\gson\2.2.2\gson-2.2.2.jar;jars\libraries\com\paulscode\codecw
    av\20101023\codecwav-20101023.jar;jars\libraries\net\java\jinput\jinput-platform
    \2.0.5\jinput-platform-2.0.5-natives-windows.jar;jars\libraries\net\minecraft\la
    unchwrapper\1.8\launchwrapper-1.8.jar" -sourcepath src\minecraft -d bin\minecraf
    t @"c:\users\z87gam~1\appdata\local\temp\java_src_path_gmvkmm.txt"' failed : 1
    
    == ERRORS FOUND in JAVA CODE ==
    
    C:\Users\Z87GAMING\Desktop\mod\forge\mcp\src\minecraft\Portal\RenderTable.java:9
    7: error: unmappable character for encoding UTF-8
    renderer.setRenderBounds( 0.0F, 0.0F, 0.0F, 3.0F, 3.0F, 1.0F); // cr?e u
    n "?tage" pour le rendu en jeu
    ^
    
    C:\Users\Z87GAMING\Desktop\mod\forge\mcp\src\minecraft\Portal\RenderTable.java:9
    7: error: unmappable character for encoding UTF-8
    renderer.setRenderBounds( 0.0F, 0.0F, 0.0F, 3.0F, 3.0F, 1.0F); // cr?e u
    n "?tage" pour le rendu en jeu
    
    ^
    
    C:\Users\Z87GAMING\Desktop\mod\forge\mcp\src\minecraft\Portal\RenderTable.java:9
    9: error: unmappable character for encoding UTF-8
    renderer.renderStandardBlock(block, x, y, z); //sauvegarde "l'?tage" pou
    r le rendu en jeu
    ^
    
    3 errors
    ==================
    
    !! Can not find server sources, try decompiling !!
    Appuyez sur une touche pour continuer…
    
    
  • Modérateurs

    Problème d’encodage, ```
    C:\Users\Z87GAMING\Desktop\mod\forge\mcp\src\minecraft\Portal\RenderTable.java:9?
    7: error: unmappable character for encoding UTF-8
    renderer.setRenderBounds( 0.0F, 0.0F, 0.0F, 3.0F, 3.0F, 1.0F); // cr?e u
    n “?tage” pour le rendu en jeu
    ^

    C:\Users\Z87GAMING\Desktop\mod\forge\mcp\src\minecraft\Portal\RenderTable.java:9?
    7: error: unmappable character for encoding UTF-8
    renderer.setRenderBounds( 0.0F, 0.0F, 0.0F, 3.0F, 3.0F, 1.0F); // cr?e u
    n “?tage” pour le rendu en jeu

    ^

    C:\Users\Z87GAMING\Desktop\mod\forge\mcp\src\minecraft\Portal\RenderTable.java:9?
    9: error: unmappable character for encoding UTF-8
    renderer.renderStandardBlock(block, x, y, z); //sauvegarde “l’?tage” pou
    r le rendu en jeu

  • Moddeurs confirmés Modérateurs

    donc il faut pas d’accent dans le message // ?


  • J’ai eu le même problème, supprime tous les accents.
    Si quelqu’un a une solution pour passer l’encodage en UTF-8 je veux bien.

  • Moddeurs confirmés Modérateurs

    a oui c’était bien ca, Fuck la logique merci, sujet résolue


  • Effectivement, pourquoi il ne prend pas les accents des commentaires sachant qu’il prend les accents de ce qui se trouve entre “guillemet” ?


  • Je ne sais pas, bug de Forge probablement ?

  • Modérateurs

    Non, c’est un problème d’encodage d’Eclipse.


  • Ok, merci de l’info Superloup10 😉

  • Moddeurs confirmés Modérateurs

    vive éclipse! ^^

  • Modérateurs


  • Moddeurs confirmés Modérateurs

    merci