Unable to play unknown soundEvent



  • Salut,

    J'ai un problème avec mes sons qui ne veulent pas se jouer…

    Dans mon Entity

    ​public String getLivingSound()
    
    {
        return "moddofusmobs:arakneHurt";
    }
    

    Le fichier sounds.json

    
    {
       "arakneHurt": {
           "category": "hostile",
           "sounds": [
               {
                   "name": "hurt1",
                   "stream": false
               }
           ]
       }
    }
    

    Le fichier .json se trouve dans forge\src\main\resources\assets\moddofusmobs\sounds
    Les musiques se trouve dans forge\src\main\resources\assets\moddofusmobs\sounds en .ogg

    J'ai fais des
    gradlew setupDecompWorkspace --refresh-dependencies

    puis
    gradlew eclipse

    Toujours le message :

    Unable to play unknown soundEvent: moddofusmobs:arakneHurt
    

    J'ai testé sous JDK/JRE 1.7 et 1.8

    Une idée de "pourquoi le son ne peut être joué ?"

    Cordialement.



  • Le .json doit être dans assets\moddofusmobs\     il me semble.



  • @'UnknowOrigin':

    Salut,

    J'ai un problème avec mes sons qui ne veulent pas se jouer…

    Dans mon Entity

    ​public String getLivingSound()
    
    {
        return "moddofusmobs:arakneHurt";
    }
    

    Le fichier sounds.json

    
    {
       "arakneHurt": {
           "category": "hostile",
           "sounds": [
               {
                   "name": "hurt1",
                   "stream": false
               }
           ]
       }
    }
    

    Le fichier .json se trouve dans forge\src\main\resources\assets\moddofusmobs\sounds
    Les musiques se trouve dans forge\src\main\resources\assets\moddofusmobs\sounds en .ogg

    J'ai fais des
    gradlew setupDecompWorkspace --refresh-dependencies

    puis
    gradlew eclipse

    Toujours le message :

    Unable to play unknown soundEvent: moddofusmobs:arakneHurt
    

    J'ai testé sous JDK/JRE 1.7 et 1.8

    Une idée de "pourquoi le son ne peut être joué ?"

    Cordialement.

    Ton son en .ogg doit bien s'appeler hurt1, sinon essaie dans ton .json de mettre le même nom (arakneHurt) pour hurt1



  • @'Gugu42':

    Le .json doit être dans assets\moddofusmobs\     il me semble.

    Arf… Effectivement, j'ai mal interpréter le tuto... Erreur c*n de lecture >< Merci, ça marche !

    Le son avait le bon nom ^^