1.12.2 [1.12.2]La Texture de Mon armure ne veux pas s'afficher



  • Bonjour comme écrit dans le titre la texture de mon armure ne veux pas s afficher sur moi quand je la porte pourtant je crois qu'il faut mettre le nom de la texture dans l'ArmorMaterial en deuxième position
    ma classe :

    public class ModItems {
        public static ItemArmor.ArmorMaterial armorTuto = EnumHelper.addArmorMaterial("armorTuto", NugarMod.MODID + ":Nugararmor", 2000, new int[]{4, 8, 6, 4}, 50, SoundEvents.ITEM_ARMOR_EQUIP_IRON, 2);
    
        public String textureName = "Nugararmor";
        public static Item NUGARINGOT = new ItemNugar();
        public static final Item BLOCK_NUGARMACHINE_ITEM = new ItemBlock(BlockMod.NUGARMACHINEBLOCK).setRegistryName(BlockMod.NUGARMACHINEBLOCK.getRegistryName());
    
        public static Item NUGARHELMET = new NugarArmor(armorTuto, 2, EntityEquipmentSlot.HEAD, "nugar_helmet");
        public static Item NUGARCHESTPLATE = new NugarArmor(armorTuto, 2, EntityEquipmentSlot.CHEST, "nugar_chesplate");
        public static Item NUGARLEGGING = new NugarArmor(armorTuto, 2,EntityEquipmentSlot.LEGS, "nugar_leggings");
        public static Item NUGARBOOTS = new NugarArmor(armorTuto, 2, EntityEquipmentSlot.FEET, "nugar_boots");
    
        @SideOnly(Side.CLIENT)
        @SubscribeEvent
        public static void registerItemsModels(ModelRegistryEvent event)
        {
            //jsp
            registerModel(BLOCK_NUGARMACHINE_ITEM, 0);
            //lingot(s)
            registerModel(NUGARINGOT, 0);
            //armure
            registerModel(NUGARHELMET, 0);
            registerModel(NUGARCHESTPLATE, 0);
            registerModel(NUGARLEGGING, 0);
            registerModel(NUGARBOOTS, 0);
    
        }
    
        @SideOnly(Side.CLIENT)
        public static void registerModel(Item item, int metadata)
        {
            if (metadata < 0) metadata = 0;
            String resourceName = item.getUnlocalizedName().substring(5).replace('.', ':');
            if (metadata > 0) resourceName += "_m" + String.valueOf(metadata);
    
            ModelLoader.setCustomModelResourceLocation(item, metadata, new ModelResourceLocation(resourceName, "inventory"));
        }
    
        public static void setItemName(Item item, String name)
        {
            item.setRegistryName(NugarMod.MODID, name).setUnlocalizedName(NugarMod.MODID + "." + name);
        }
    }
    
    

    et les images doivent etre misent dans les dossier textures/models/armor/cequejaimisdanslarmormaterial_layer_1 ou 2

    Merci d avance pour votre aide 🙂


  • Moddeurs confirmés Rédacteurs Administrateurs

    Bonsoir,
    Tu peux envoyer les logs du jeu et une capture de ton dossier de ressource ?



  • oui voila le dossier text alternatif
    et les logs:

    [19:14:29] [main/INFO]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker
    [19:14:29] [main/INFO]: Using primary tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker
    [19:14:29] [main/INFO]: Loading tweak class name net.minecraftforge.gradle.tweakers.CoremodTweaker
    [19:14:30] [main/INFO]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLTweaker
    [19:14:30] [main/INFO]: Forge Mod Loader version 14.23.5.2768 for Minecraft 1.12.2 loading
    [19:14:30] [main/INFO]: Java is Java HotSpot(TM) 64-Bit Server VM, version 1.8.0_201, running on Windows 10:amd64:10.0, installed at C:\Program Files\Java\jdk1.8.0_201\jre
    [19:14:30] [main/ERROR]: Apache Maven library folder was not in the format expected. Using default libraries directory.
    [19:14:30] [main/ERROR]: Full: C:\Users\tanou\.gradle\caches\modules-2\files-2.1\org.apache.maven\maven-artifact\3.5.3\7dc72b6d6d8a6dced3d294ed54c2cc3515ade9f4\maven-artifact-3.5.3.jar
    [19:14:30] [main/ERROR]: Trimmed: c:/users/tanou/.gradle/caches/modules-2/files-2.1/org.apache.maven/maven-artifact/3.5.3/
    [19:14:30] [main/INFO]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation
    [19:14:30] [main/INFO]: Detected deobfuscated environment, loading log configs for colored console logs.
    [19:14:32] [main/INFO] [FML]: Ignoring missing certificate for coremod FMLCorePlugin (net.minecraftforge.fml.relauncher.FMLCorePlugin), we are in deobf and it's a forge core plugin
    [19:14:32] [main/INFO] [FML]: Ignoring missing certificate for coremod FMLForgePlugin (net.minecraftforge.classloading.FMLForgePlugin), we are in deobf and it's a forge core plugin
    [19:14:32] [main/INFO] [FML]: Searching C:\Users\tanou\Desktop\java minecraft\NugaMod 1.12.2\run\.\mods for mods
    [19:14:32] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.CoremodTweaker
    [19:14:32] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.fml.relauncher.FMLCorePlugin
    [19:14:32] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.classloading.FMLForgePlugin
    [19:14:32] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker
    [19:14:32] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLDeobfTweaker
    [19:14:32] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
    [19:14:32] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker
    [19:14:32] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker
    [19:14:32] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper
    [19:14:36] [main/ERROR] [FML]: FML appears to be missing any signature data. This is not a good thing
    [19:14:36] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper
    [19:14:36] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLDeobfTweaker
    [19:14:37] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
    [19:14:37] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.TerminalTweaker
    [19:14:37] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.TerminalTweaker
    [19:14:37] [main/INFO] [LaunchWrapper]: Launching wrapped minecraft {net.minecraft.client.main.Main}
    [19:14:40] [main/INFO] [minecraft/Minecraft]: Setting user: Player162
    [19:14:47] [main/WARN] [minecraft/GameSettings]: Skipping bad option: lastServer:
    [19:14:47] [main/INFO] [minecraft/Minecraft]: LWJGL Version: 2.9.4
    [19:14:49] [main/INFO] [FML]: -- System Details --
    Details:
    	Minecraft Version: 1.12.2
    	Operating System: Windows 10 (amd64) version 10.0
    	Java Version: 1.8.0_201, Oracle Corporation
    	Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    	Memory: 160953568 bytes (153 MB) / 511705088 bytes (488 MB) up to 2854223872 bytes (2722 MB)
    	JVM Flags: 0 total; 
    	IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    	FML: 
    	Loaded coremods (and transformers): 
    	GL info: ' Vendor: 'NVIDIA Corporation' Version: '4.6.0 NVIDIA 441.41' Renderer: 'GeForce GTX 1050/PCIe/SSE2'
    [19:14:49] [main/INFO] [FML]: MinecraftForge v14.23.5.2768 Initialized
    [19:14:49] [main/INFO] [FML]: Starts to replace vanilla recipe ingredients with ore ingredients.
    [19:14:49] [main/INFO] [FML]: Replaced 1036 ore ingredients
    [19:14:50] [main/INFO] [FML]: Searching C:\Users\tanou\Desktop\java minecraft\NugaMod 1.12.2\run\.\mods for mods
    [19:14:51] [Thread-3/INFO] [FML]: Using sync timing. 200 frames of Display.update took 259726800 nanos
    [19:14:52] [main/INFO] [FML]: Forge Mod Loader has identified 5 mods to load
    [19:14:52] [main/INFO] [FML]: Attempting connection with missing mods [minecraft, mcp, FML, forge, nugar] at CLIENT
    [19:14:52] [main/INFO] [FML]: Attempting connection with missing mods [minecraft, mcp, FML, forge, nugar] at SERVER
    [19:14:53] [main/INFO] [minecraft/SimpleReloadableResourceManager]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:Nugar Mod
    [19:14:53] [main/INFO] [FML]: Processing ObjectHolder annotations
    [19:14:53] [main/INFO] [FML]: Found 1168 ObjectHolder annotations
    [19:14:53] [main/INFO] [FML]: Identifying ItemStackHolder annotations
    [19:14:53] [main/INFO] [FML]: Found 0 ItemStackHolder annotations
    [19:14:53] [main/INFO] [FML]: Configured a dormant chunk cache size of 0
    [19:14:54] [main/INFO] [FML]: Applying holder lookups
    [19:14:54] [main/INFO] [FML]: Holder lookups applied
    [19:14:54] [main/INFO] [FML]: Applying holder lookups
    [19:14:54] [main/INFO] [FML]: Holder lookups applied
    [19:14:54] [main/INFO] [FML]: Applying holder lookups
    [19:14:54] [main/INFO] [FML]: Holder lookups applied
    [19:14:54] [Forge Version Check/INFO] [forge.VersionCheck]: [forge] Starting version check at http://files.minecraftforge.net/maven/net/minecraftforge/forge/promotions_slim.json
    [19:14:54] [main/INFO] [FML]: Applying holder lookups
    [19:14:54] [main/INFO] [FML]: Holder lookups applied
    [19:14:54] [main/INFO] [FML]: Injecting itemstacks
    [19:14:54] [main/INFO] [FML]: Itemstack injection complete
    [19:14:54] [Forge Version Check/INFO] [forge.VersionCheck]: [forge] Found status: UP_TO_DATE Target: null
    [19:15:08] [Sound Library Loader/INFO] [minecraft/SoundManager]: Starting up SoundSystem...
    [19:15:09] [Thread-5/INFO] [minecraft/SoundManager]: Initializing LWJGL OpenAL
    [19:15:09] [Thread-5/INFO] [minecraft/SoundManager]: (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)
    [19:15:09] [Thread-5/INFO] [minecraft/SoundManager]: OpenAL initialized.
    [19:15:09] [Sound Library Loader/INFO] [minecraft/SoundManager]: Sound engine started
    [19:15:18] [main/INFO] [FML]: Max texture size: 16384
    [19:15:18] [main/INFO] [minecraft/TextureMap]: Created: 512x512 textures-atlas
    [19:15:19] [main/WARN] [minecraft/ModelBlock]: Unable to resolve texture due to upward reference: #side in minecraft:models/block/cube_bottom_top
    [19:15:19] [main/WARN] [minecraft/ModelBlock]: Unable to resolve texture due to upward reference: #bottom in minecraft:models/block/cube_bottom_top
    [19:15:19] [main/WARN] [minecraft/ModelBlock]: Unable to resolve texture due to upward reference: #top in minecraft:models/block/cube_bottom_top
    [19:15:19] [main/WARN] [minecraft/ModelBlock]: Unable to resolve texture due to upward reference: #side in minecraft:models/block/cube_bottom_top
    [19:15:19] [main/WARN] [minecraft/ModelBlock]: Unable to resolve texture due to upward reference: #side in minecraft:models/block/cube_bottom_top
    [19:15:19] [main/WARN] [minecraft/ModelBlock]: Unable to resolve texture due to upward reference: #side in minecraft:models/block/cube_bottom_top
    [19:15:19] [main/WARN] [minecraft/ModelBlock]: Unable to resolve texture due to upward reference: #side in minecraft:models/block/cube_bottom_top
    [19:15:19] [main/ERROR] [FML]: Exception loading model for variant nugar:nugar_machine#normal for blockstate "nugar:nugar_machine"
    net.minecraftforge.client.model.ModelLoaderRegistry$LoaderException: Exception loading model nugar:nugar_machine#normal with loader VariantLoader.INSTANCE, skipping
    	at net.minecraftforge.client.model.ModelLoaderRegistry.getModel(ModelLoaderRegistry.java:161) ~[ModelLoaderRegistry.class:?]
    	at net.minecraftforge.client.model.ModelLoader.registerVariant(ModelLoader.java:235) ~[ModelLoader.class:?]
    	at net.minecraft.client.renderer.block.model.ModelBakery.loadBlock(ModelBakery.java:153) ~[ModelBakery.class:?]
    	at net.minecraftforge.client.model.ModelLoader.loadBlocks(ModelLoader.java:223) ~[ModelLoader.class:?]
    	at net.minecraftforge.client.model.ModelLoader.setupModelRegistry(ModelLoader.java:150) ~[ModelLoader.class:?]
    	at net.minecraft.client.renderer.block.model.ModelManager.onResourceManagerReload(ModelManager.java:28) [ModelManager.class:?]
    	at net.minecraft.client.resources.SimpleReloadableResourceManager.registerReloadListener(SimpleReloadableResourceManager.java:121) [SimpleReloadableResourceManager.class:?]
    	at net.minecraft.client.Minecraft.init(Minecraft.java:559) [Minecraft.class:?]
    	at net.minecraft.client.Minecraft.run(Minecraft.java:421) [Minecraft.class:?]
    	at net.minecraft.client.main.Main.main(Main.java:118) [Main.class:?]
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_201]
    	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_201]
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_201]
    	at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_201]
    	at net.minecraft.launchwrapper.Launch.launch(Launch.java:135) [launchwrapper-1.12.jar:?]
    	at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.12.jar:?]
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_201]
    	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_201]
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_201]
    	at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_201]
    	at net.minecraftforge.gradle.GradleStartCommon.launch(GradleStartCommon.java:97) [start/:?]
    	at GradleStart.main(GradleStart.java:25) [start/:?]
    Caused by: net.minecraftforge.client.model.ModelLoaderRegistry$LoaderException: Exception loading model nugar:block/nugar_machine with loader VanillaLoader.INSTANCE, skipping
    	at net.minecraftforge.client.model.ModelLoaderRegistry.getModel(ModelLoaderRegistry.java:161) ~[ModelLoaderRegistry.class:?]
    	at net.minecraftforge.client.model.ModelLoader$WeightedRandomModel.<init>(ModelLoader.java:658) ~[ModelLoader$WeightedRandomModel.class:?]
    	at net.minecraftforge.client.model.ModelLoader$VariantLoader.loadModel(ModelLoader.java:1176) ~[ModelLoader$VariantLoader.class:?]
    	at net.minecraftforge.client.model.ModelLoaderRegistry.getModel(ModelLoaderRegistry.java:157) ~[ModelLoaderRegistry.class:?]
    	... 21 more
    Caused by: com.google.gson.JsonSyntaxException: Missing faces, expected to find a JsonObject
    	at net.minecraft.util.JsonUtils.getJsonObject(JsonUtils.java:302) ~[JsonUtils.class:?]
    	at net.minecraft.client.renderer.block.model.BlockPart$Deserializer.parseFaces(BlockPart.java:157) ~[BlockPart$Deserializer.class:?]
    	at net.minecraft.client.renderer.block.model.BlockPart$Deserializer.parseFacesCheck(BlockPart.java:142) ~[BlockPart$Deserializer.class:?]
    	at net.minecraft.client.renderer.block.model.BlockPart$Deserializer.deserialize(BlockPart.java:79) ~[BlockPart$Deserializer.class:?]
    	at net.minecraft.client.renderer.block.model.BlockPart$Deserializer.deserialize(BlockPart.java:70) ~[BlockPart$Deserializer.class:?]
    	at com.google.gson.internal.bind.TreeTypeAdapter.read(TreeTypeAdapter.java:69) ~[TreeTypeAdapter.class:?]
    	at com.google.gson.Gson.fromJson(Gson.java:887) ~[Gson.class:?]
    	at com.google.gson.Gson.fromJson(Gson.java:952) ~[Gson.class:?]
    	at com.google.gson.internal.bind.TreeTypeAdapter$GsonContextImpl.deserialize(TreeTypeAdapter.java:162) ~[TreeTypeAdapter$GsonContextImpl.class:?]
    	at net.minecraft.client.renderer.block.model.ModelBlock$Deserializer.getModelElements(ModelBlock.java:315) ~[ModelBlock$Deserializer.class:?]
    	at net.minecraft.client.renderer.block.model.ModelBlock$Deserializer.deserialize(ModelBlock.java:248) ~[ModelBlock$Deserializer.class:?]
    	at net.minecraft.client.renderer.block.model.ModelBlock$Deserializer.deserialize(ModelBlock.java:242) ~[ModelBlock$Deserializer.class:?]
    	at com.google.gson.internal.bind.TreeTypeAdapter.read(TreeTypeAdapter.java:69) ~[TreeTypeAdapter.class:?]
    	at net.minecraft.util.JsonUtils.gsonDeserialize(JsonUtils.java:435) ~[JsonUtils.class:?]
    	at net.minecraft.client.renderer.block.model.ModelBlock.deserialize(ModelBlock.java:51) ~[ModelBlock.class:?]
    	at net.minecraft.client.renderer.block.model.ModelBakery.loadModel(ModelBakery.java:338) ~[ModelBakery.class:?]
    	at net.minecraftforge.client.model.ModelLoader.access$1400(ModelLoader.java:115) ~[ModelLoader.class:?]
    	at net.minecraftforge.client.model.ModelLoader$VanillaLoader.loadModel(ModelLoader.java:861) ~[ModelLoader$VanillaLoader.class:?]
    	at net.minecraftforge.client.model.ModelLoaderRegistry.getModel(ModelLoaderRegistry.java:157) ~[ModelLoaderRegistry.class:?]
    	at net.minecraftforge.client.model.ModelLoader$WeightedRandomModel.<init>(ModelLoader.java:658) ~[ModelLoader$WeightedRandomModel.class:?]
    	at net.minecraftforge.client.model.ModelLoader$VariantLoader.loadModel(ModelLoader.java:1176) ~[ModelLoader$VariantLoader.class:?]
    	at net.minecraftforge.client.model.ModelLoaderRegistry.getModel(ModelLoaderRegistry.java:157) ~[ModelLoaderRegistry.class:?]
    	... 21 more
    [19:15:21] [main/INFO] [FML]: Applying holder lookups
    [19:15:21] [main/INFO] [FML]: Holder lookups applied
    [19:15:21] [main/INFO] [FML]: Injecting itemstacks
    [19:15:21] [main/INFO] [FML]: Itemstack injection complete
    [19:15:21] [main/INFO] [FML]: Forge Mod Loader has successfully loaded 5 mods
    [19:15:21] [main/WARN] [minecraft/GameSettings]: Skipping bad option: lastServer:
    [19:15:22] [main/INFO] [mojang/NarratorWindows]: Narrator library for x64 successfully loaded
    [19:15:23] [Realms Notification Availability checker #1/INFO] [mojang/RealmsClient]: Could not authorize you against Realms server: Invalid session id
    

    les erreurs de textures(blocktastes) serons régler plus tard 🙂
    ok dans les log quand je lance mon monde il y a cette ligne
    [19:17:14] [main/WARN] [minecraft/TextureManager]: Failed to load texture:

    nugar:textures/models/armor/nugararmor_layer_1.png
    

  • Moddeurs confirmés Rédacteurs Administrateurs

    Bon déjà le N majuscule faut le passer en minuscule partout.

    Ensuite dans les logs je ne vois pas d'erreur lié au chargement des textures des armures, il faudrait aller dans un monde pour qu'elles tentent de s'afficher et avoir l'erreur.



  • je pense que c était liée à la majuscule 😁
    Edit je test sans les majs
    c était bien les majuscules qui bloquais tout je suis vraiment un boulet 😢


Log in to reply