Forge gradle : Problème gradlew build avec le mods open sources de Eydamos
#1
Bonsoir je n'arrive pas à build gradlew me dit que CodeChicken et NotEnougtItem introuvable alors que je l'ai ai bien .
Code :
C:\Users\*****\Desktop\Backpack>gradlew build
****************************
Powered By MCP:
http://modcoderpack.com/
Searge, ProfMobius, Fesh0r,
R4wk, ZeuX, IngisKahn, bspkrs
MCP Data version : unknown
****************************
:compileApiJava UP-TO-DATE
:processApiResources UP-TO-DATE
:apiClasses UP-TO-DATE
:sourceMainJava UP-TO-DATE
:compileJava

FAILURE: Build failed with an exception.

* What went wrong:
Could not resolve all dependencies for configuration ':compile'.
> Could not find codechicken:CodeChickenCore:1.7.10-1.0.7.47.
 Required by:
     de.eydamos.backpack:Backpack:2.0.1-1.7x
> Could not find codechicken:NotEnoughItems:1.7.10-1.0.5.120.
 Required by:
     de.eydamos.backpack:Backpack:2.0.1-1.7x

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 10.911 secs




J'ai bien essayer ça aussi comme je l'ai vue sur un github : gradlew setupDecompWorkspace build mais ça fait la même chose .
Répondre
#2
Salut,
Si tu mets les dépendances au format maven il faut ajouter le repo où se trouve les fichiers en question, ce qui ne semble pas être le cas chez toi comme il ne les trouve pas.
Répondre
#3
(16-04-2018, 17:56)robin4002 a écrit : Salut,
Si tu mets les dépendances au format maven il faut ajouter le repo où se trouve les fichiers en question, ce qui ne semble pas être le cas chez toi comme il ne les trouve pas.

Code :
buildscript {
  repositories {
      mavenCentral()
      maven {
          name 'MCForge Repo'
          url "http://files.minecraftforge.net/maven/"
      }
      maven {
          name = "sonatype"
          url = "https://oss.sonatype.org/content/repositories/snapshots/"
      }
       maven {
           name 'CB Repo'
           url "http://chickenbones.net/maven/"
       }
  }
  dependencies {
      classpath 'net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT'
  }
}

apply plugin: 'forge'



version = "2.0.1-1.7x"
group= "de.eydamos.backpack" // http://maven.apache.org/guides/mini/guide-naming-conventions.html
archivesBaseName = "backpack"

minecraft {
  version = "1.7.10-10.13.4.1614-1.7.10"
  runDir = "eclipse"
}

dependencies {
  // you may put jars on which you depend on in ./libs
  // or you may define them like so..
  //compile "some.group:artifact:version:classifier"
  //compile "some.group:artifact:version"
   
  // real examples
  //compile 'com.mod-buildcraft:buildcraft:6.0.8:dev'  // adds buildcraft to the dev env
  //compile 'com.googlecode.efficient-java-matrix-library:ejml:0.24' // adds ejml to the dev env

  // for more info...
  // http://www.gradle.org/docs/current/userguide/artifact_dependencies_tutorial.html
  // http://www.gradle.org/docs/current/userguide/dependency_management.html
   compile "codechicken:CodeChickenCore:1.7.10-1.0.7.47:dev"
   compile "codechicken:NotEnoughItems:1.7.10-1.0.5.120:dev"
    compile "codechicken:CodeChickenLib:1.7.10-1.1.3.140:dev"
}

processResources
{
  // this will ensure that this task is redone when the versions change.
  inputs.property "version", project.version
  inputs.property "mcversion", project.minecraft.version

  // replace stuff in mcmod.info, nothing else
  from(sourceSets.main.resources.srcDirs) {
      include 'mcmod.info'
             
      // replace version and mcversion
      expand 'version':project.version, 'mcversion':project.minecraft.version
  }
     
  // copy everything else, thats not the mcmod.info
  from(sourceSets.main.resources.srcDirs) {
      exclude 'mcmod.info'
  }
}
Je dois ajouter les liens ou ? ^^
Répondre
#4
va voir sur les guthub d'autre mod pour lire le build.gradle c'est comme je fait quand je trouve pas moi, c'est vrai que c'est relou ces histoire de dependences
Répondre
#5
(16-04-2018, 18:42)SpyMan a écrit : va voir sur les guthub d'autre mod pour lire le build.gradle c'est comme je fait quand je trouve pas moi, c'est vrai que c'est relou ces histoire de dependences

Justement je cherche depuis ce matin sur d'autres github etc mais je ne trouve pas :/


-------------------------------------------

Ces bon j'ai résolu , j'ai rajouter sa si y'en à qui on le même problème dans dependencies :  

Code :
dependencies {
   runtime "codechicken:CodeChickenCore:1.7.10-1.0.7.47:dev"
   runtime "codechicken:NotEnoughItems:1.7.10-1.0.5.120:dev"
   runtime "codechicken:CodeChickenLib:1.7.10-1.1.3.140:dev"
}
Répondre
#6
En fait, ton build.gradle n'est pas bon.
Code :
buildscript {
  repositories {
      mavenCentral()
      maven {
          name 'MCForge Repo'
          url "http://files.minecraftforge.net/maven/"
      }
      maven {
          name = "sonatype"
          url = "https://oss.sonatype.org/content/repositories/snapshots/"
      }
       maven {
           name 'CB Repo'
           url "http://chickenbones.net/maven/"
       }
  }
  dependencies {
      classpath 'net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT'
  }
}
Cette partie ne concerne que les plugins Gradle.

Pour rajouter le maven d'une dépendance, il faut mettre ça :
Code :
repositories {
       maven {
           name 'CB Repo'
           url "http://chickenbones.net/maven/"
       }
  }
au dessus du bloc dependencies.
Si vous souhaitez me faire un don, il vous suffit de cliquer sur le bouton situé en dessous.

[Image: btn_donate_SM.gif]

Les dons serviront à m'acheter les composants pour monter un ordinateur.

Je suis un membre apprécié et joueur, j'ai déjà obtenu 16 points de réputation.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)